aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2022-04-02 22:13:32 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2022-04-02 22:13:32 +0000
commitde02b1a9d209f0b6727e63848bc58c9b4ef1c064 (patch)
tree781b4669f40c8f7c6d788c7ed269150ea140ab33
parent2410b0204c279e243b284b75d79612a8d39a3b4e (diff)
downloadports-de02b1a9d209f0b6727e63848bc58c9b4ef1c064.tar.gz
ports-de02b1a9d209f0b6727e63848bc58c9b4ef1c064.zip
editors/vim: Update to 8.2.4669, add x11 support, drop Athena
Vim no longer includes the Athena (Xaw) frontend, so drop the athena flavor. As requested by many (and based on a patch from scf), restore the x11 flavor. The x11 flavor is a bit odd; it doesn't actually include an X GUI. As a result, when Vim got flavorized I dropped it as I thought it was vestigial. What the x11 flavor actually provides is support for some X interaction (mainly xclipboard), and is highly useful to people who run console Vim within X. The outcry was pretty swift, and I'd like to thank all the people who took the time to email me about it, and especially scf who provided the bulk of this patch. I'm going to MFH this due to the athena build failure.
-rw-r--r--editors/vim/Makefile18
-rw-r--r--editors/vim/distinfo6
-rw-r--r--editors/vim/pkg-descr3
3 files changed, 14 insertions, 13 deletions
diff --git a/editors/vim/Makefile b/editors/vim/Makefile
index 38ca4e1367c6..6e894ed81e0a 100644
--- a/editors/vim/Makefile
+++ b/editors/vim/Makefile
@@ -1,7 +1,7 @@
# Created by: David O'Brien <obrien@cs.ucdavis.edu>
PORTNAME= vim
-PORTVERSION= 8.2.4659
+PORTVERSION= 8.2.4669
DISTVERSIONPREFIX= v
CATEGORIES= editors
@@ -37,7 +37,7 @@ VIM_VER= ${PORTNAME}${PORTVERSION:R:S|.||g}
# Flavors {{{1
# FLAVORS are used to build various Vim GUIs. The default flavor (`vim') is
# console-only.
-FLAVORS= console athena gtk2 gtk3 motif tiny
+FLAVORS= console gtk2 gtk3 motif x11 tiny
FLAVOR?= ${FLAVORS:[1]}
# Register conflicts with all other flavors
CONFLICTS_INSTALL= ${FLAVORS:N${FLAVOR}:S/^/vim-/}
@@ -57,13 +57,6 @@ GUI= no
CONFIGURE_ARGS+=--without-x
PLIST= ${.CURDIR}/pkg-plist-tiny
-.elif ${FLAVOR:U} == athena
-GUI= athena
-CONFIGURE_ARGS+=--enable-xim --enable-fontset
-PLIST_SUB+= GUI="" DESKTOP="@comment "
-USES+= xorg
-USE_XORG+= ice sm x11 xaw xmu xpm xt
-
.elif ${FLAVOR:U} == gtk2
GUI= gtk2
CONFIGURE_ARGS+=--enable-xim --enable-fontset
@@ -87,6 +80,13 @@ CONFIGURE_ENV+= MOTIFHOME=${LOCALBASE}
PLIST_SUB+= GUI="" DESKTOP="@comment "
USES+= motif xorg
USE_XORG= ice sm x11 xmu xt
+
+.elif ${FLAVOR:U} == x11
+GUI= x11
+CONFIGURE_ARGS+=--with-x
+PLIST_SUB+= GUI="@comment " DESKTOP="@comment "
+USES+= xorg
+USE_XORG= ice sm x11 xmu xpm xt
.endif
# Options {{{1
diff --git a/editors/vim/distinfo b/editors/vim/distinfo
index 20e2259ce63a..654d89e50d93 100644
--- a/editors/vim/distinfo
+++ b/editors/vim/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1648806173
-SHA256 (vim-vim-v8.2.4659_GH0.tar.gz) = daa9252e215548221d24f51cd1e773d3cd5d8c53d29220a8136a0835a3983acc
-SIZE (vim-vim-v8.2.4659_GH0.tar.gz) = 16304340
+TIMESTAMP = 1648936763
+SHA256 (vim-vim-v8.2.4669_GH0.tar.gz) = cca3c98dd36423a5c968260e5ee1b04f0acd36161388e284232b189cadebb3db
+SIZE (vim-vim-v8.2.4669_GH0.tar.gz) = 16305422
diff --git a/editors/vim/pkg-descr b/editors/vim/pkg-descr
index daacdb5d7419..02f7be21f003 100644
--- a/editors/vim/pkg-descr
+++ b/editors/vim/pkg-descr
@@ -8,7 +8,8 @@ configuration files.
FreeBSD has the following Vim packages:
* vim: Console-only Vim (vim binary) with all runtime files
-* vim-gtk3, -gtk2, -athena, -motif, -x11: Console Vim plus a GUI (gvim binary)
+* vim-gtk3, -gtk2, -motif: Console Vim plus a GUI (gvim binary)
+* vim-x11: Console Vim only, with xclipboard support
* vim-tiny: Vim binary only, with no runtime files. Not useful for most people;
intended for minimal (ex. jail) installations