aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2011-11-03 16:13:27 +0000
committerKoop Mast <kwm@FreeBSD.org>2011-11-03 16:13:27 +0000
commitde5507d6636c8c2534d4636ecb1f45dd7b53d2e9 (patch)
treed6f79cafbd16fc994ba8f30ecb431d68c7376595
parent522d48aa71e444ed2488c8de12f295bde6207b9f (diff)
downloadports-de5507d6636c8c2534d4636ecb1f45dd7b53d2e9.tar.gz
ports-de5507d6636c8c2534d4636ecb1f45dd7b53d2e9.zip
Update to 0.7.6.
PR: ports/160506 Submitted by: Ruslan Mahmatkhanov <cvs-src@yandex.ru>
Notes
Notes: svn path=/head/; revision=284990
-rw-r--r--deskutils/gnote/Makefile21
-rw-r--r--deskutils/gnote/distinfo4
-rw-r--r--deskutils/gnote/files/patch-src_debug.cpp11
-rw-r--r--deskutils/gnote/files/patch-src_noterenamedialog.cpp20
-rw-r--r--deskutils/gnote/files/patch-src_sharp_datetime.cpp52
-rw-r--r--deskutils/gnote/pkg-descr2
-rw-r--r--deskutils/gnote/pkg-plist67
7 files changed, 69 insertions, 108 deletions
diff --git a/deskutils/gnote/Makefile b/deskutils/gnote/Makefile
index 3abc33c6d384..079e94b1db96 100644
--- a/deskutils/gnote/Makefile
+++ b/deskutils/gnote/Makefile
@@ -7,21 +7,26 @@
#
PORTNAME= gnote
-PORTVERSION= 0.7.3
+PORTVERSION= 0.7.6
CATEGORIES= deskutils gnome
MASTER_SITES= GNOME
MAINTAINER= gnome@FreeBSD.org
COMMENT= A port of Tomboy to C++, note taking application
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/COPYING
+
LIB_DEPENDS= gtkmm-2.4.1:${PORTSDIR}/x11-toolkits/gtkmm24 \
+ pcre.0:${PORTSDIR}/devel/pcre \
gtkspell.0:${PORTSDIR}/textproc/gtkspell \
boost_filesystem.4:${PORTSDIR}/devel/boost-libs \
uuid.1:${PORTSDIR}/misc/e2fsprogs-libuuid
USE_GMAKE= yes
-USE_BZIP2= yes
-USE_GNOME= gnomehack gnomeprefix gconf2 intltool ltverhack gnomepanel
+USE_XZ= yes
+USE_GNOME= gnomehack gnomeprefix gconf2 gtk20 intltool libxml2 libxslt \
+ ltverhack gnomepanel
USE_GETTEXT= yes
INSTALLS_OMF= yes
GCONF_SCHEMAS= gnote.schemas
@@ -32,7 +37,7 @@ CONFIGURE_ENV= PANELAPPLET_SERVER_DIR="${PREFIX}/libdata/bonobo/servers"
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ARGS= --disable-dbus
-DOCS= AUTHORS COPYING ChangeLog NEWS README TODO
+DOCS= AUTHORS ChangeLog NEWS README TODO
MAN1= gnote.1
.if !defined(WITHOUT_APPLET)
@@ -46,12 +51,6 @@ PLIST_SUB+= APPLET="@comment "
PLIST_SUB+= VERSION=${PORTVERSION}
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 700000
-BROKEN= does not configure on 6.X
-.endif
-
post-patch:
@${REINPLACE_CMD} -e 's|/usr/include/boost|${LOCALBASE}/include/boost|g' \
${WRKSRC}/configure
@@ -64,4 +63,4 @@ post-install:
.endfor
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/deskutils/gnote/distinfo b/deskutils/gnote/distinfo
index 5f4eaa7782c0..70497da4b843 100644
--- a/deskutils/gnote/distinfo
+++ b/deskutils/gnote/distinfo
@@ -1,2 +1,2 @@
-SHA256 (gnote-0.7.3.tar.bz2) = 4853315711baf7647cdae4c2f7d23e22e2b13322605efe3dd98796a06f928321
-SIZE (gnote-0.7.3.tar.bz2) = 1606926
+SHA256 (gnote-0.7.6.tar.xz) = 20bc138a636e2bf099499824c56bd55c3e0aca7461e07015fbc8bcce1983135a
+SIZE (gnote-0.7.6.tar.xz) = 2027876
diff --git a/deskutils/gnote/files/patch-src_debug.cpp b/deskutils/gnote/files/patch-src_debug.cpp
deleted file mode 100644
index 69c81272cbb6..000000000000
--- a/deskutils/gnote/files/patch-src_debug.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/debug.cpp.orig 2009-11-25 14:12:33.000000000 +0100
-+++ src/debug.cpp 2009-12-03 17:28:54.000000000 +0100
-@@ -126,7 +126,7 @@
- // static boost::recursive_mutex mutex;
- // boost::recursive_mutex::scoped_lock lock(mutex);
- char buf[128];
-- snprintf(buf, 128, "(%d) ", (int)pthread_self());
-+ snprintf(buf, 128, "(%ld) ", (pthread_t)pthread_self());
- fwrite(buf, 1, strlen(buf), stderr);
- fwrite(prefix, 1, strlen(prefix), stderr);
-
diff --git a/deskutils/gnote/files/patch-src_noterenamedialog.cpp b/deskutils/gnote/files/patch-src_noterenamedialog.cpp
deleted file mode 100644
index 0e7002990f23..000000000000
--- a/deskutils/gnote/files/patch-src_noterenamedialog.cpp
+++ /dev/null
@@ -1,20 +0,0 @@
---- src/noterenamedialog.cpp.orig 2010-03-14 00:32:43.000000000 -0500
-+++ src/noterenamedialog.cpp 2010-03-14 00:33:46.000000000 -0500
-@@ -63,6 +63,8 @@ private:
- Gtk::TreeModelColumn<Note::Ptr> m_column_note;
- };
-
-+ModelColumnRecord model_column_record;
-+
- ModelColumnRecord::ModelColumnRecord()
- : Gtk::TreeModelColumnRecord()
- , m_column_selected()
-@@ -152,7 +154,7 @@ NoteRenameDialog::NoteRenameDialog(const
- *renamed_note->get_window(),
- false,
- false)
-- , m_notes_model(Gtk::ListStore::create(ModelColumnRecord()))
-+ , m_notes_model(Gtk::ListStore::create(model_column_record))
- , m_dont_rename_button(_("_Don't Rename Links"), true)
- , m_rename_button(_("_Rename Links"), true)
- , m_select_all_button(_("Select All"))
diff --git a/deskutils/gnote/files/patch-src_sharp_datetime.cpp b/deskutils/gnote/files/patch-src_sharp_datetime.cpp
deleted file mode 100644
index d2a7601b83ab..000000000000
--- a/deskutils/gnote/files/patch-src_sharp_datetime.cpp
+++ /dev/null
@@ -1,52 +0,0 @@
---- src/sharp/datetime.cpp.orig 2009-12-28 12:46:01.000000000 +0100
-+++ src/sharp/datetime.cpp 2010-02-14 15:47:21.000000000 +0100
-@@ -69,28 +69,28 @@ namespace sharp {
- int DateTime::day() const
- {
- struct tm result;
-- localtime_r(&m_date.tv_sec, &result);
-+ localtime_r((const time_t *)&m_date.tv_sec, &result);
- return result.tm_mday;
- }
-
- int DateTime::month() const
- {
- struct tm result;
-- localtime_r(&m_date.tv_sec, &result);
-+ localtime_r((const time_t *)&m_date.tv_sec, &result);
- return result.tm_mon + 1;
- }
-
- int DateTime::year() const
- {
- struct tm result;
-- localtime_r(&m_date.tv_sec, &result);
-+ localtime_r((const time_t *)&m_date.tv_sec, &result);
- return result.tm_year + 1900;
- }
-
- int DateTime::day_of_year() const
- {
- struct tm result;
-- localtime_r(&m_date.tv_sec, &result);
-+ localtime_r((const time_t *)&m_date.tv_sec, &result);
- return result.tm_yday;
- }
-
-@@ -109,14 +109,14 @@ namespace sharp {
- std::string DateTime::to_string(const char * format) const
- {
- struct tm result;
-- return _to_string(format, localtime_r(&m_date.tv_sec, &result));
-+ return _to_string(format, localtime_r((const time_t *)&m_date.tv_sec, &result));
- }
-
-
- std::string DateTime::to_short_time_string() const
- {
- struct tm result;
-- return _to_string("%R", localtime_r(&m_date.tv_sec, &result));
-+ return _to_string("%R", localtime_r((const time_t *)&m_date.tv_sec, &result));
- }
-
- std::string DateTime::to_iso8601() const
diff --git a/deskutils/gnote/pkg-descr b/deskutils/gnote/pkg-descr
index 5dd92d2479af..beb8b98a8c24 100644
--- a/deskutils/gnote/pkg-descr
+++ b/deskutils/gnote/pkg-descr
@@ -1,4 +1,4 @@
-Gnote is a port of Tomboy to C++.
+Gnote is a port of Tomboy to C++.
It is the same note taking application, including most of the add-ins (more
are to come). Synchronization support is being worked on.
diff --git a/deskutils/gnote/pkg-plist b/deskutils/gnote/pkg-plist
index 1b4c1b466321..966f00fa52af 100644
--- a/deskutils/gnote/pkg-plist
+++ b/deskutils/gnote/pkg-plist
@@ -33,7 +33,6 @@ lib/gnote/addins/%%VERSION%%/underline.so
%%APPLET%%libexec/gnote-applet
share/applications/gnote.desktop
%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
-%%PORTDOCS%%%%DOCSDIR%%/COPYING
%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
%%PORTDOCS%%%%DOCSDIR%%/NEWS
%%PORTDOCS%%%%DOCSDIR%%/README
@@ -57,6 +56,44 @@ share/gnome/help/gnote/C/figures/note-template.png
share/gnome/help/gnote/C/figures/notebook-icon.png
share/gnome/help/gnote/C/gnote.xml
share/gnome/help/gnote/C/legal.xml
+share/gnome/help/gnote/cs/figures/add-notebook-search.png
+share/gnome/help/gnote/cs/figures/add-to-notebook.png
+share/gnome/help/gnote/cs/figures/delete-notebook.png
+share/gnome/help/gnote/cs/figures/gnote-main-menu.png
+share/gnome/help/gnote/cs/figures/gnote-new-note.png
+share/gnome/help/gnote/cs/figures/gnote-panel.png
+share/gnome/help/gnote/cs/figures/gnote-pindown.png
+share/gnome/help/gnote/cs/figures/gnote-pinup.png
+share/gnome/help/gnote/cs/figures/gnote-preferences-add-ins.png
+share/gnome/help/gnote/cs/figures/gnote-preferences-editing.png
+share/gnome/help/gnote/cs/figures/gnote-preferences-hotkeys.png
+share/gnome/help/gnote/cs/figures/gnote-preferences-synchronization.png
+share/gnome/help/gnote/cs/figures/gnote-tools.png
+share/gnome/help/gnote/cs/figures/move-notes-search.png
+share/gnome/help/gnote/cs/figures/new-notebook.png
+share/gnome/help/gnote/cs/figures/note-template.png
+share/gnome/help/gnote/cs/figures/notebook-icon.png
+share/gnome/help/gnote/cs/gnote.xml
+share/gnome/help/gnote/cs/legal.xml
+share/gnome/help/gnote/da/figures/add-notebook-search.png
+share/gnome/help/gnote/da/figures/add-to-notebook.png
+share/gnome/help/gnote/da/figures/delete-notebook.png
+share/gnome/help/gnote/da/figures/gnote-main-menu.png
+share/gnome/help/gnote/da/figures/gnote-new-note.png
+share/gnome/help/gnote/da/figures/gnote-panel.png
+share/gnome/help/gnote/da/figures/gnote-pindown.png
+share/gnome/help/gnote/da/figures/gnote-pinup.png
+share/gnome/help/gnote/da/figures/gnote-preferences-add-ins.png
+share/gnome/help/gnote/da/figures/gnote-preferences-editing.png
+share/gnome/help/gnote/da/figures/gnote-preferences-hotkeys.png
+share/gnome/help/gnote/da/figures/gnote-preferences-synchronization.png
+share/gnome/help/gnote/da/figures/gnote-tools.png
+share/gnome/help/gnote/da/figures/move-notes-search.png
+share/gnome/help/gnote/da/figures/new-notebook.png
+share/gnome/help/gnote/da/figures/note-template.png
+share/gnome/help/gnote/da/figures/notebook-icon.png
+share/gnome/help/gnote/da/gnote.xml
+share/gnome/help/gnote/da/legal.xml
share/gnome/help/gnote/de/figures/add-notebook-search.png
share/gnome/help/gnote/de/figures/add-to-notebook.png
share/gnome/help/gnote/de/figures/delete-notebook.png
@@ -245,6 +282,7 @@ share/locale/ja/LC_MESSAGES/gnote.mo
share/locale/kn/LC_MESSAGES/gnote.mo
share/locale/ko/LC_MESSAGES/gnote.mo
share/locale/lt/LC_MESSAGES/gnote.mo
+share/locale/lv/LC_MESSAGES/gnote.mo
share/locale/ml/LC_MESSAGES/gnote.mo
share/locale/mr/LC_MESSAGES/gnote.mo
share/locale/nb/LC_MESSAGES/gnote.mo
@@ -260,9 +298,12 @@ share/locale/sv/LC_MESSAGES/gnote.mo
share/locale/ta/LC_MESSAGES/gnote.mo
share/locale/te/LC_MESSAGES/gnote.mo
share/locale/th/LC_MESSAGES/gnote.mo
+share/locale/tr/LC_MESSAGES/gnote.mo
share/locale/uk/LC_MESSAGES/gnote.mo
share/locale/zh_CN/LC_MESSAGES/gnote.mo
share/omf/gnote/gnote-C.omf
+share/omf/gnote/gnote-cs.omf
+share/omf/gnote/gnote-da.omf
share/omf/gnote/gnote-de.omf
share/omf/gnote/gnote-el.omf
share/omf/gnote/gnote-es.omf
@@ -271,6 +312,16 @@ share/omf/gnote/gnote-sl.omf
share/omf/gnote/gnote-sv.omf
share/omf/gnote/gnote-zh_CN.omf
@dirrm share/omf/gnote
+@dirrmtry share/locale/te/LC_MESSAGES
+@dirrmtry share/locale/te
+@dirrmtry share/locale/mr/LC_MESSAGES
+@dirrmtry share/locale/mr
+@dirrmtry share/locale/ca@valencia/LC_MESSAGES
+@dirrmtry share/locale/ca@valencia
+@dirrmtry share/locale/bn_IN/LC_MESSAGES
+@dirrmtry share/locale/bn_IN
+@dirrmtry share/locale/as/LC_MESSAGES
+@dirrmtry share/locale/as
@dirrm %%DATADIR%%/icons/hicolor/scalable/actions
@dirrm %%DATADIR%%/icons/hicolor/scalable
@dirrm %%DATADIR%%/icons/hicolor/48x48/actions
@@ -303,6 +354,10 @@ share/omf/gnote/gnote-zh_CN.omf
@dirrm share/gnome/help/gnote/el
@dirrm share/gnome/help/gnote/de/figures
@dirrm share/gnome/help/gnote/de
+@dirrm share/gnome/help/gnote/da/figures
+@dirrm share/gnome/help/gnote/da
+@dirrm share/gnome/help/gnote/cs/figures
+@dirrm share/gnome/help/gnote/cs
@dirrm share/gnome/help/gnote/C/figures
@dirrm share/gnome/help/gnote/C
@dirrm share/gnome/help/gnote
@@ -311,13 +366,3 @@ share/omf/gnote/gnote-zh_CN.omf
@dirrmtry lib/gnote/addins/%%VERSION%%
@dirrmtry lib/gnote/addins
@dirrmtry lib/gnote
-@dirrmtry share/locale/te/LC_MESSAGES
-@dirrmtry share/locale/te
-@dirrmtry share/locale/mr/LC_MESSAGES
-@dirrmtry share/locale/mr
-@dirrmtry share/locale/ca@valencia/LC_MESSAGES
-@dirrmtry share/locale/ca@valencia
-@dirrmtry share/locale/bn_IN/LC_MESSAGES
-@dirrmtry share/locale/bn_IN
-@dirrmtry share/locale/as/LC_MESSAGES
-@dirrmtry share/locale/as