aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-07-21 17:07:30 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-07-21 17:20:04 +0000
commitdf17c9422768830b281929a996f2676182d34eb7 (patch)
tree6d25963315b1b3a1fdd80b23b6acf25a50f42053
parent41c8da382cde6a7be3278832604ca9a5eb64ce8e (diff)
downloadports-df17c9422768830b281929a996f2676182d34eb7.tar.gz
ports-df17c9422768830b281929a996f2676182d34eb7.zip
science/antioch: Fix build with llvm16
Approved by: portmgr (blanket) Sponsored by: The FreeBSD Foundation
-rw-r--r--science/antioch/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/science/antioch/Makefile b/science/antioch/Makefile
index b7f7acb96e81..70c2f0a8f240 100644
--- a/science/antioch/Makefile
+++ b/science/antioch/Makefile
@@ -18,11 +18,12 @@ LIB_DEPENDS= libgsl.so:math/gsl \
libOpenCL.so:devel/ocl-icd
USES= autoreconf compiler:c++11-lang eigen:3 gmake libtool localbase
+USE_CXXSTD= c++11
USE_GITHUB= yes
GH_ACCOUNT= libantioch
-GNU_CONFIGURE= yes
USE_LDCONFIG= yes
+GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-static \
--enable-eigen --with-eigen-include=${LOCALBASE}/include/eigen3 \
--enable-opencl \