aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2010-05-07 03:37:45 +0000
committerMartin Wilke <miwi@FreeBSD.org>2010-05-07 03:37:45 +0000
commitdf1c5551d24aae8ad7283a1b1be1e2b2233aae21 (patch)
tree8815b4601f79ffeb4afb592441c225238e4eba54
parent79f18f57cd71506ee0cf4a0dc57c2821a26e50c7 (diff)
downloadports-df1c5551d24aae8ad7283a1b1be1e2b2233aae21.tar.gz
ports-df1c5551d24aae8ad7283a1b1be1e2b2233aae21.zip
- Fix build on 6.X
Notes
Notes: svn path=/head/; revision=253877
-rw-r--r--x11-drivers/input-wacom/Makefile2
-rw-r--r--x11-drivers/xf86-input-acecad/Makefile8
-rw-r--r--x11-drivers/xf86-input-citron/Makefile8
-rw-r--r--x11-drivers/xf86-input-elographics/Makefile8
-rw-r--r--x11-drivers/xf86-input-fpit/Makefile8
-rw-r--r--x11-drivers/xf86-input-hyperpen/Makefile9
-rw-r--r--x11-drivers/xf86-input-joystick/Makefile10
-rw-r--r--x11-drivers/xf86-input-keyboard/Makefile9
-rw-r--r--x11-drivers/xf86-input-mouse/Makefile8
-rw-r--r--x11-drivers/xf86-input-penmount/Makefile9
-rw-r--r--x11-drivers/xf86-input-synaptics/Makefile8
-rw-r--r--x11-drivers/xf86-input-void/Makefile8
12 files changed, 84 insertions, 11 deletions
diff --git a/x11-drivers/input-wacom/Makefile b/x11-drivers/input-wacom/Makefile
index 37b71cf507e3..afe5bc97070b 100644
--- a/x11-drivers/input-wacom/Makefile
+++ b/x11-drivers/input-wacom/Makefile
@@ -65,6 +65,8 @@ PLIST_SUB+= UWACOMKLD="@noinst UWACOMKLD uwacom.ko"
PORTTYPE= serial
.endif
+BROKEN= build failed
+
do-configure:
@cd ${WRKDIR}/linuxwacom \
&& ${LN} -s ${DISTDIR}/${DIST_SUBDIR}/${LINUXWACOM}.tar.bz2 \
diff --git a/x11-drivers/xf86-input-acecad/Makefile b/x11-drivers/xf86-input-acecad/Makefile
index 51ad8d266732..318080e1887f 100644
--- a/x11-drivers/xf86-input-acecad/Makefile
+++ b/x11-drivers/xf86-input-acecad/Makefile
@@ -15,4 +15,10 @@ COMMENT= X.Org acecad input driver
XORG_CAT= driver
MAN4= acecad.4x
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 700000
+USE_GCC= 4.2+
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/x11-drivers/xf86-input-citron/Makefile b/x11-drivers/xf86-input-citron/Makefile
index 4c49036ad882..b514f556f965 100644
--- a/x11-drivers/xf86-input-citron/Makefile
+++ b/x11-drivers/xf86-input-citron/Makefile
@@ -16,4 +16,10 @@ COMMENT= X.Org citron input driver
XORG_CAT= driver
MAN4= citron.4x
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 700000
+USE_GCC= 4.2+
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/x11-drivers/xf86-input-elographics/Makefile b/x11-drivers/xf86-input-elographics/Makefile
index d26a077ef527..ef8df3792ab5 100644
--- a/x11-drivers/xf86-input-elographics/Makefile
+++ b/x11-drivers/xf86-input-elographics/Makefile
@@ -16,4 +16,10 @@ COMMENT= X.Org elographics input driver
XORG_CAT= driver
MAN4= elographics.4x
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 700000
+USE_GCC= 4.2+
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/x11-drivers/xf86-input-fpit/Makefile b/x11-drivers/xf86-input-fpit/Makefile
index e34603bc2b8f..d2956cc9352f 100644
--- a/x11-drivers/xf86-input-fpit/Makefile
+++ b/x11-drivers/xf86-input-fpit/Makefile
@@ -18,4 +18,10 @@ USE_XORG= xrandr
MAN4= fpit.4x
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 700000
+USE_GCC= 4.2+
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/x11-drivers/xf86-input-hyperpen/Makefile b/x11-drivers/xf86-input-hyperpen/Makefile
index 5c76af262b35..aca1b54e0a10 100644
--- a/x11-drivers/xf86-input-hyperpen/Makefile
+++ b/x11-drivers/xf86-input-hyperpen/Makefile
@@ -15,4 +15,11 @@ COMMENT= X.Org hyperpen input driver
XORG_CAT= driver
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 700000
+USE_GCC= 4.2+
+.endif
+
+.include <bsd.port.post.mk>
+
diff --git a/x11-drivers/xf86-input-joystick/Makefile b/x11-drivers/xf86-input-joystick/Makefile
index 7ac0f4635173..2118f973e9a7 100644
--- a/x11-drivers/xf86-input-joystick/Makefile
+++ b/x11-drivers/xf86-input-joystick/Makefile
@@ -20,4 +20,12 @@ post-patch:
@${REINPLACE_CMD} -e 's|[(]libdir[)]/pkgconfig|(prefix)/libdata/pkgconfig|g' \
${WRKSRC}/Makefile.in
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 700000
+USE_GCC= 4.2+
+.endif
+
+.include <bsd.port.post.mk>
+
+
diff --git a/x11-drivers/xf86-input-keyboard/Makefile b/x11-drivers/xf86-input-keyboard/Makefile
index a24488f4a6cc..2a8c6b6e1b4b 100644
--- a/x11-drivers/xf86-input-keyboard/Makefile
+++ b/x11-drivers/xf86-input-keyboard/Makefile
@@ -16,4 +16,11 @@ XORG_CAT= driver
USE_XORG= kbproto
MAN4= kbd.4x
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 700000
+USE_GCC= 4.2+
+.endif
+
+.include <bsd.port.post.mk>
+
diff --git a/x11-drivers/xf86-input-mouse/Makefile b/x11-drivers/xf86-input-mouse/Makefile
index 088123373dfc..a242f927a845 100644
--- a/x11-drivers/xf86-input-mouse/Makefile
+++ b/x11-drivers/xf86-input-mouse/Makefile
@@ -15,4 +15,10 @@ COMMENT= X.Org mouse input driver
XORG_CAT= driver
MAN4= mousedrv.4x
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 700000
+USE_GCC= 4.2+
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/x11-drivers/xf86-input-penmount/Makefile b/x11-drivers/xf86-input-penmount/Makefile
index c06afc1ca891..5fa014b5d542 100644
--- a/x11-drivers/xf86-input-penmount/Makefile
+++ b/x11-drivers/xf86-input-penmount/Makefile
@@ -15,4 +15,11 @@ COMMENT= X.Org penmount input driver
XORG_CAT= driver
MAN4= penmount.4x
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 700000
+USE_GCC= 4.2+
+.endif
+
+.include <bsd.port.post.mk>
+
diff --git a/x11-drivers/xf86-input-synaptics/Makefile b/x11-drivers/xf86-input-synaptics/Makefile
index 5ee9b9158b14..27c9090a1484 100644
--- a/x11-drivers/xf86-input-synaptics/Makefile
+++ b/x11-drivers/xf86-input-synaptics/Makefile
@@ -27,4 +27,10 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/fdi/11-x11-synaptics.fdi \
${PREFIX}/share/hal/fdi/policy/10osvendor/
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 700000
+USE_GCC= 4.2+
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/x11-drivers/xf86-input-void/Makefile b/x11-drivers/xf86-input-void/Makefile
index cd7f6a7d1606..6f12e2a07625 100644
--- a/x11-drivers/xf86-input-void/Makefile
+++ b/x11-drivers/xf86-input-void/Makefile
@@ -15,4 +15,10 @@ COMMENT= X.Org void input driver
XORG_CAT= driver
MAN4= void.4x
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 700000
+USE_GCC= 4.2+
+.endif
+
+.include <bsd.port.post.mk>