aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2024-06-16 17:42:12 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2024-06-16 17:42:53 +0000
commitdf5fa2c390adceabc5c5f532cd2b165ff4398fe4 (patch)
tree5589aa2b2781e4acc0f852a9cd90779d28f87649
parent65295bff3a99a83ef5dc59a75dbdb75a4f3a943e (diff)
downloadports-df5fa2c390adceabc5c5f532cd2b165ff4398fe4.tar.gz
ports-df5fa2c390adceabc5c5f532cd2b165ff4398fe4.zip
print/microtex: Dynamic, cross-platform, and embeddable LaTeX rendering library
-rw-r--r--print/Makefile1
-rw-r--r--print/microtex/Makefile24
-rw-r--r--print/microtex/distinfo3
-rw-r--r--print/microtex/pkg-descr4
-rw-r--r--print/microtex/pkg-plist128
5 files changed, 160 insertions, 0 deletions
diff --git a/print/Makefile b/print/Makefile
index 51b86ed528c5..7e1896fa7452 100644
--- a/print/Makefile
+++ b/print/Makefile
@@ -107,6 +107,7 @@
SUBDIR += magicfilter
SUBDIR += makeindex
SUBDIR += mftrace
+ SUBDIR += microtex
SUBDIR += miktex
SUBDIR += min12xxw
SUBDIR += mp-a4
diff --git a/print/microtex/Makefile b/print/microtex/Makefile
new file mode 100644
index 000000000000..52cb274a905b
--- /dev/null
+++ b/print/microtex/Makefile
@@ -0,0 +1,24 @@
+PORTNAME= microtex
+DISTVERSION= g20230528
+CATEGORIES= print devel
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Dynamic, cross-platform, and embeddable LaTeX rendering library
+WWW= https://github.com/NanoMichael/MicroTex
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
+ libtinyxml2.so:textproc/tinyxml2
+
+USES= compiler:c++17-lang gnome meson pkgconfig
+USE_GNOME= cairomm gtkmm30 glibmm pangomm
+USE_LDCONFIG= yes
+
+USE_GITHUB= yes
+GH_ACCOUNT= NanoMichael
+GH_PROJECT= MicroTeX
+GH_TAGNAME= d87ebec
+
+.include <bsd.port.mk>
diff --git a/print/microtex/distinfo b/print/microtex/distinfo
new file mode 100644
index 000000000000..0167131d6bac
--- /dev/null
+++ b/print/microtex/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1718557879
+SHA256 (NanoMichael-MicroTeX-g20230528-d87ebec_GH0.tar.gz) = c59f185f0028c4017841835bcd217ebe7b5ef50fe7c3c0b755d8274ea3cb3cc1
+SIZE (NanoMichael-MicroTeX-g20230528-d87ebec_GH0.tar.gz) = 1596605
diff --git a/print/microtex/pkg-descr b/print/microtex/pkg-descr
new file mode 100644
index 000000000000..badf100a6414
--- /dev/null
+++ b/print/microtex/pkg-descr
@@ -0,0 +1,4 @@
+MicroTeX is a dynamic, cross-platform, and embeddable LaTeX rendering library.
+Its main purpose is to display mathematical formulas written in LaTeX. It can
+be embedded in applications on various platforms (Android, iOS, Windows, Linux
+GTK, Qt...).
diff --git a/print/microtex/pkg-plist b/print/microtex/pkg-plist
new file mode 100644
index 000000000000..98af5903f23b
--- /dev/null
+++ b/print/microtex/pkg-plist
@@ -0,0 +1,128 @@
+include/clatexmath/atom/atom.h
+include/clatexmath/atom/atom_basic.h
+include/clatexmath/atom/atom_char.h
+include/clatexmath/atom/atom_impl.h
+include/clatexmath/atom/atom_matrix.h
+include/clatexmath/atom/atom_row.h
+include/clatexmath/atom/atom_space.h
+include/clatexmath/box/box.h
+include/clatexmath/box/box_factory.h
+include/clatexmath/box/box_group.h
+include/clatexmath/box/box_single.h
+include/clatexmath/common.h
+include/clatexmath/config.h
+include/clatexmath/core/core.h
+include/clatexmath/core/formula.h
+include/clatexmath/core/glue.h
+include/clatexmath/core/macro.h
+include/clatexmath/core/macro_impl.h
+include/clatexmath/core/parser.h
+include/clatexmath/fonts/alphabet.h
+include/clatexmath/fonts/font_basic.h
+include/clatexmath/fonts/font_info.h
+include/clatexmath/fonts/font_reg.h
+include/clatexmath/fonts/fonts.h
+include/clatexmath/fonts/symbol_reg.h
+include/clatexmath/fonts/tex_font.h
+include/clatexmath/graphic/graphic.h
+include/clatexmath/graphic/graphic_basic.h
+include/clatexmath/latex.h
+include/clatexmath/platform/cairo/graphic_cairo.h
+include/clatexmath/reg/builtin_font_reg.h
+include/clatexmath/reg/builtin_syms_reg.h
+include/clatexmath/render.h
+include/clatexmath/res/font_def.res.h
+include/clatexmath/res/parser/font_parser.h
+include/clatexmath/res/parser/formula_parser.h
+include/clatexmath/res/symbol_def.res.h
+include/clatexmath/utils/dict_tree.h
+include/clatexmath/utils/enums.h
+include/clatexmath/utils/exceptions.h
+include/clatexmath/utils/indexed_arr.h
+include/clatexmath/utils/log.h
+include/clatexmath/utils/nums.h
+include/clatexmath/utils/string_utils.h
+include/clatexmath/utils/utf.h
+include/clatexmath/utils/utils.h
+lib/libclatexmath.so
+lib/libclatexmath.so.0
+lib/libclatexmath.so.0.0.5
+libdata/pkgconfig/clatexmath.pc
+share/clatexmath/.clatexmath-res_root
+share/clatexmath/RES_README
+share/clatexmath/SAMPLES.tex
+share/clatexmath/cyrillic/LICENSE
+share/clatexmath/cyrillic/cyrillic.map.xml
+share/clatexmath/cyrillic/language_cyrillic.xml
+share/clatexmath/cyrillic/mappings_cyrillic.xml
+share/clatexmath/cyrillic/symbols_cyrillic.xml
+share/clatexmath/cyrillic/wnbx10.ttf
+share/clatexmath/cyrillic/wnbx10.xml
+share/clatexmath/cyrillic/wnbxti10.ttf
+share/clatexmath/cyrillic/wnbxti10.xml
+share/clatexmath/cyrillic/wnr10.ttf
+share/clatexmath/cyrillic/wnr10.xml
+share/clatexmath/cyrillic/wnss10.ttf
+share/clatexmath/cyrillic/wnss10.xml
+share/clatexmath/cyrillic/wnssbx10.ttf
+share/clatexmath/cyrillic/wnssbx10.xml
+share/clatexmath/cyrillic/wnssi10.ttf
+share/clatexmath/cyrillic/wnssi10.xml
+share/clatexmath/cyrillic/wnti10.ttf
+share/clatexmath/cyrillic/wnti10.xml
+share/clatexmath/cyrillic/wntt10.ttf
+share/clatexmath/cyrillic/wntt10.xml
+share/clatexmath/fonts/base/cmex10.ttf
+share/clatexmath/fonts/base/cmmi10.ttf
+share/clatexmath/fonts/base/cmmib10.ttf
+share/clatexmath/fonts/euler/eufb10.ttf
+share/clatexmath/fonts/euler/eufm10.ttf
+share/clatexmath/fonts/latin/bi10.ttf
+share/clatexmath/fonts/latin/bx10.ttf
+share/clatexmath/fonts/latin/cmr10.ttf
+share/clatexmath/fonts/latin/i10.ttf
+share/clatexmath/fonts/latin/optional/cmbx10.ttf
+share/clatexmath/fonts/latin/optional/cmbxti10.ttf
+share/clatexmath/fonts/latin/optional/cmss10.ttf
+share/clatexmath/fonts/latin/optional/cmssbx10.ttf
+share/clatexmath/fonts/latin/optional/cmssi10.ttf
+share/clatexmath/fonts/latin/optional/cmti10.ttf
+share/clatexmath/fonts/latin/optional/cmtt10.ttf
+share/clatexmath/fonts/latin/r10.ttf
+share/clatexmath/fonts/latin/sb10.ttf
+share/clatexmath/fonts/latin/sbi10.ttf
+share/clatexmath/fonts/latin/si10.ttf
+share/clatexmath/fonts/latin/ss10.ttf
+share/clatexmath/fonts/latin/tt10.ttf
+share/clatexmath/fonts/licences/Knuth_License.txt
+share/clatexmath/fonts/licences/License_for_dsrom.txt
+share/clatexmath/fonts/licences/OFL.txt
+share/clatexmath/fonts/maths/cmbsy10.ttf
+share/clatexmath/fonts/maths/cmsy10.ttf
+share/clatexmath/fonts/maths/msam10.ttf
+share/clatexmath/fonts/maths/msbm10.ttf
+share/clatexmath/fonts/maths/optional/dsrom10.ttf
+share/clatexmath/fonts/maths/rsfs10.ttf
+share/clatexmath/fonts/maths/special.ttf
+share/clatexmath/fonts/maths/stmary10.ttf
+share/clatexmath/greek/LICENSE
+share/clatexmath/greek/fcmbipg.ttf
+share/clatexmath/greek/fcmbipg.xml
+share/clatexmath/greek/fcmbpg.ttf
+share/clatexmath/greek/fcmbpg.xml
+share/clatexmath/greek/fcmripg.ttf
+share/clatexmath/greek/fcmripg.xml
+share/clatexmath/greek/fcmrpg.ttf
+share/clatexmath/greek/fcmrpg.xml
+share/clatexmath/greek/fcsbpg.ttf
+share/clatexmath/greek/fcsbpg.xml
+share/clatexmath/greek/fcsropg.ttf
+share/clatexmath/greek/fcsropg.xml
+share/clatexmath/greek/fcsrpg.ttf
+share/clatexmath/greek/fcsrpg.xml
+share/clatexmath/greek/fctrpg.ttf
+share/clatexmath/greek/fctrpg.xml
+share/clatexmath/greek/greek.map.xml
+share/clatexmath/greek/language_greek.xml
+share/clatexmath/greek/mappings_greek.xml
+share/clatexmath/greek/symbols_greek.xml