aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2021-12-15 20:01:56 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2021-12-15 20:01:56 +0000
commitdf87dedfe1f5e41e90d3748ecaf842c083273e7b (patch)
tree084cce46811a3663a78d90c0053cc5ecaaf11568
parent608389cd9c42d7ec348c90a3a63eab788cd13b0f (diff)
downloadports-df87dedfe1f5e41e90d3748ecaf842c083273e7b.tar.gz
ports-df87dedfe1f5e41e90d3748ecaf842c083273e7b.zip
net/haproxy: fix build on powerpc
LLVM does not have libatomic. Passing MAKE_ARGS needs to be done earlier then bsd.port.pre.mk.
-rw-r--r--net/haproxy/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/net/haproxy/Makefile b/net/haproxy/Makefile
index 20fb5b3e1d8a..d9bfbc01405e 100644
--- a/net/haproxy/Makefile
+++ b/net/haproxy/Makefile
@@ -53,6 +53,12 @@ LUA_MAKE_ARGS= USE_LUA=1 LUA_INC=${LUA_INCDIR} LUA_LIB=${LUA_LIBDIR} LUA_LIB_NA
OPTIONS_DEFAULT+= LUA
.endif
+.include <bsd.port.options.mk>
+
+.if ${ARCH} == powerpc
+MAKE_ARGS+= USE_LIBATOMIC=
+.endif
+
.include <bsd.port.pre.mk>
.if ${ARCH} == "amd64" || ${ARCH} == "i386"