aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMateusz Piotrowski <0mp@FreeBSD.org>2021-05-12 18:45:10 +0000
committerMateusz Piotrowski <0mp@FreeBSD.org>2021-05-12 18:45:53 +0000
commite025129daf0d7006391e5311f20ec6102fb3d889 (patch)
treec38c9e9efc6edd0b3f807ffa91bbe4739a8b0405
parentdb2183a6ff2d726b01d0792a960d00d780eddffb (diff)
downloadports-e025129daf0d7006391e5311f20ec6102fb3d889.tar.gz
ports-e025129daf0d7006391e5311f20ec6102fb3d889.zip
sysutils/ansible: Update to 3.3.0
-rw-r--r--UPDATING9
-rw-r--r--sysutils/ansible/Makefile57
-rw-r--r--sysutils/ansible/distinfo6
-rw-r--r--sysutils/ansible/files/pkg-message.in16
4 files changed, 23 insertions, 65 deletions
diff --git a/UPDATING b/UPDATING
index 5777d5b9570c..273efd0be4ea 100644
--- a/UPDATING
+++ b/UPDATING
@@ -5,6 +5,15 @@ they are unavoidable.
You should get into the habit of checking this file for changes each time
you update your ports collection, before attempting any port upgrades.
+20200512:
+ AFFECTS: users of sysutils/ansible*
+ AUTHOR: 0mp@FreeBSD.org
+
+ Ansible has been updated to 3.3.0. Please follow the porting guide
+ to update the rulesets:
+
+ https://docs.ansible.com/ansible/devel/porting_guides/porting_guide_3.html
+
20210508:
AFFECTS: users of devel/pycharm-ce
AUTHOR: bsam@FreeBSD.org
diff --git a/sysutils/ansible/Makefile b/sysutils/ansible/Makefile
index 45dad643c437..ec4262815c8b 100644
--- a/sysutils/ansible/Makefile
+++ b/sysutils/ansible/Makefile
@@ -1,6 +1,5 @@
PORTNAME= ansible
-DISTVERSION= 2.9.21
-PORTREVISION= 1
+DISTVERSION= 3.3.0
CATEGORIES= sysutils python
MASTER_SITES= http://releases.ansible.com/ansible/
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -11,52 +10,30 @@ COMMENT= Radically simple IT automation
LICENSE= GPLv3+
LICENSE_FILE= ${WRKSRC}/COPYING
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cryptography>0:security/py-cryptography@${PY_FLAVOR} \
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}ansible-base>0:sysutils/py-ansible-base@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}cryptography>0:security/py-cryptography@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}Jinja2>0:devel/py-Jinja2@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}jmespath>0:devel/py-jmespath@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}netaddr>0:net/py-netaddr@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}paramiko>0:security/py-paramiko@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}yaml>0:devel/py-yaml@${PY_FLAVOR}
-TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}boto3>0:www/py-boto3@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}mock>0:devel/py-mock@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}nose>0:devel/py-nose@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}packaging>=0:devel/py-packaging@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}passlib>0:security/py-passlib@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}pycrypto>=0:security/py-pycrypto@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}pytest-mock>0:devel/py-pytest-mock@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}pytest-xdist>0:devel/py-pytest-xdist@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}pytest>0:devel/py-pytest@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}requests>0:www/py-requests@${PY_FLAVOR}
USES= cpe gmake python:3.6+ shebangfix
CPE_VENDOR= ansibleworks
USE_PYTHON= autoplist concurrent distutils
-SHEBANG_REGEX= [.]/test/.*[.]py
-
-TEST_ARGS= VERSION=${PORTVERSION} \
- PYTHON=${PYTHON_CMD} \
- DATE=
-TEST_ENV= PYTHON_VERSION=${PYTHON_VER}
-TEST_TARGET= tests
+SHEBANG_FILES= ansible_collections/community/zabbix/roles/zabbix_proxy/files/install_semodule.bsx \
+ ansible_collections/community/zabbix/roles/zabbix_server/files/install_semodule.bsx \
+ ansible_collections/cyberark/conjur/ci/build_release \
+ ansible_collections/cyberark/conjur/ci/publish_to_galaxy \
+ ansible_collections/ovirt/ovirt/roles/disaster_recovery/files/ovirt-dr
+SHEBANG_GLOB= *.py *.sh
CONFLICTS_INSTALL= ${_ANSIBLE_PACKAGES:N${PKGBASE}-*}
NO_ARCH= yes
SUB_FILES= pkg-message
-SUB_LIST= MAJMINVER=${PORTVERSION:R} \
- PYTHON_PKGNAMEPREFIX=${PYTHON_PKGNAMEPREFIX}
-
-PLIST_FILES= man/man1/ansible-config.1.gz \
- man/man1/ansible-console.1.gz \
- man/man1/ansible-doc.1.gz \
- man/man1/ansible-galaxy.1.gz \
- man/man1/ansible-inventory.1.gz \
- man/man1/ansible-playbook.1.gz \
- man/man1/ansible-pull.1.gz \
- man/man1/ansible-vault.1.gz \
- man/man1/ansible.1.gz
-PORTEXAMPLES= ansible.cfg hosts
+SUB_LIST= PYTHON_PKGNAMEPREFIX=${PYTHON_PKGNAMEPREFIX}
_ANSIBLE_VERSIONS= 1 2 23 24 25 26 27 28
_ANSIBLE_PACKAGES= ${PYTHON_PKGNAMEPREFIX}ansible-*
@@ -67,23 +44,11 @@ _ANSIBLE_PACKAGES+= ${PYTHON_PKGNAMEPREFIX}ansible${version}-*
OPTIONS_DEFINE= DOCS EXAMPLES
post-patch:
- ${FIND} ${WRKSRC} -type f -print0 | ${XARGS} -0 ${REINPLACE_CMD} \
+ ${FIND} ${WRKSRC} -type f -exec grep --null -El '(/etc/ansible|/usr/share/ansible)' | ${XARGS} -0 ${REINPLACE_CMD} \
-e 's|/etc/ansible|${ETCDIR:S/${PY_FLAVOR}-//}|g' \
-e 's|/usr/share/ansible|${DATADIR}|g'
${FIND} ${WRKSRC} -type f -name "*.bak" -delete
- ${REINPLACE_CMD} 's|"/etc"|"${PREFIX}/etc/"|g' ${WRKSRC}/test/units/playbook/test_helpers.py
-
-post-install:
- @${MKDIR} ${STAGEDIR}${MAN1PREFIX}/man/man1
- ${INSTALL_MAN} ${WRKSRC}/docs/man/man1/*.1 \
- ${STAGEDIR}${MAN1PREFIX}/man/man1
-
-post-install-EXAMPLES-on:
- @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
- ${INSTALL_DATA} ${WRKSRC}/examples/ansible.cfg ${STAGEDIR}${EXAMPLESDIR}
- ${INSTALL_DATA} ${WRKSRC}/examples/hosts ${STAGEDIR}${EXAMPLESDIR}
-
post-stage:
${FIND} ${STAGEDIR}${PREFIX}/bin -type l -name ansible-\* -lname ansible \
-execdir ${RLN} ansible-${PYTHON_VER} {} \;
diff --git a/sysutils/ansible/distinfo b/sysutils/ansible/distinfo
index 7a1b3c1a7f07..196e42112d25 100644
--- a/sysutils/ansible/distinfo
+++ b/sysutils/ansible/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1620220411
-SHA256 (ansible-2.9.21.tar.gz) = 4098246b67aa143e1e3af79d99346419e0545d5405d1cdf6e7fd389beab6de5a
-SIZE (ansible-2.9.21.tar.gz) = 14277062
+TIMESTAMP = 1620652330
+SHA256 (ansible-3.3.0.tar.gz) = 2de5385c48a2a24a19f6cbaccc7d7684c64b6194f9a9b175aba7949d53b07bc9
+SIZE (ansible-3.3.0.tar.gz) = 31514793
diff --git a/sysutils/ansible/files/pkg-message.in b/sysutils/ansible/files/pkg-message.in
index 07ec89d35d18..3c6f3c49ae6e 100644
--- a/sysutils/ansible/files/pkg-message.in
+++ b/sysutils/ansible/files/pkg-message.in
@@ -11,20 +11,4 @@ inventory and a sample configuration file:
EOD
type: install
}
-{
-message: <<EOD
-Ansible has been updated to %%MAJMINVER%%. Please follow the porting guide
-to update the rulesets:
-
- https://docs.ansible.com/ansible/devel/porting_guides/porting_guide_%%MAJMINVER%%.html
-
-In order to stay with an older version instead, e.g., 2.7, use pkg-set(8).
-For example:
-
- # pkg set -n %%PYTHON_PKGNAMEPREFIX%%ansible:%%PYTHON_PKGNAMEPREFIX%%ansible27
-
-EOD
-maximum_version: "%%MAJMINVER%%"
-type: upgrade
-}
]