aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2022-06-21 21:23:44 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2022-06-21 21:25:24 +0000
commite07cd0e5fd4211550db6ca7a7ec1e64d3f45731e (patch)
treeae03c03d6818e116bc966f928f68b0fb4e9cd4ab
parent11d637547bc9b0f0745c3f8a85421b5554c4cd08 (diff)
downloadports-e07cd0e5fd4211550db6ca7a7ec1e64d3f45731e.tar.gz
ports-e07cd0e5fd4211550db6ca7a7ec1e64d3f45731e.zip
graphics/webp: Move USES=jpeg under IMGCONV
The jpeg library is only needed for the image conversion library. I missed it in the original patch. PR: 264798
-rw-r--r--graphics/webp/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/graphics/webp/Makefile b/graphics/webp/Makefile
index 9353471148c9..a28f084e08c3 100644
--- a/graphics/webp/Makefile
+++ b/graphics/webp/Makefile
@@ -13,7 +13,7 @@ COMMENT= Google WebP image format conversion tool
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/COPYING
-USES= compiler:c11 jpeg libtool localbase
+USES= compiler:c11 libtool localbase
CONFIGURE_ARGS= --enable-libwebpdecoder \
--enable-libwebpdemux \
@@ -35,6 +35,7 @@ IMGCONV_CONFIGURE_ON= build_cwebp=yes build_dwebp=yes build_gif2webp=yes build_i
IMGCONV_LIB_DEPENDS= libgif.so:graphics/giflib \
libpng.so:graphics/png \
libtiff.so:graphics/tiff
+INGCONV_USES= jpeg
X11_CONFIGURE_OFF= build_vwebp=no
X11_CONFIGURE_ON= build_vwebp=yes
X11_USE= GL=glut