aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-02-21 14:12:50 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-02-21 15:06:05 +0000
commite0bab44c0245be5c46717f8342f652b6f0a27380 (patch)
tree3520cf92d669d2374cf630dd4a3296cf39242e38
parent4e7341ccc5c87ba09f66d6b45d1c6a3e699247ea (diff)
downloadports-e0bab44c0245be5c46717f8342f652b6f0a27380.tar.gz
ports-e0bab44c0245be5c46717f8342f652b6f0a27380.zip
devel/py-mmh3: Add py-mmh3 4.1.0
mmh3 is a Python extension for MurmurHash (MurmurHash3), a set of fast and robust non-cryptographic hash functions invented by Austin Appleby. Combined with probabilistic techniques like a Bloom filter, MinHash, and feature hashing, mmh3 allows you to develop high-performance systems in fields such as data mining, machine learning, and natural language processing. Another common use of mmh3 is to calculate favicon hashes used by Shodan, the world's first IoT search engine.
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-mmh3/Makefile23
-rw-r--r--devel/py-mmh3/distinfo3
-rw-r--r--devel/py-mmh3/pkg-descr9
4 files changed, 36 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 32dfe11ad80b..4c50a5c732c7 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -5030,6 +5030,7 @@
SUBDIR += py-minimal-snowplow-tracker
SUBDIR += py-minimongo
SUBDIR += py-minio
+ SUBDIR += py-mmh3
SUBDIR += py-mock
SUBDIR += py-molecule
SUBDIR += py-mondrian
diff --git a/devel/py-mmh3/Makefile b/devel/py-mmh3/Makefile
new file mode 100644
index 000000000000..9f0e8ad70dfc
--- /dev/null
+++ b/devel/py-mmh3/Makefile
@@ -0,0 +1,23 @@
+PORTNAME= mmh3
+PORTVERSION= 4.1.0
+CATEGORIES= devel python
+MASTER_SITES= PYPI
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Python extension for MurmurHash3, a set of fast and robust hash functions
+WWW= https://github.com/hajimes/mmh3
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools>=61.0.0:devel/py-setuptools@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}wheel>=0:devel/py-wheel@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= autoplist concurrent pep517
+
+post-install:
+ ${FIND} ${STAGEDIR}${PYTHON_SITELIBDIR} -name '*.so' -exec ${STRIP_CMD} {} +
+
+.include <bsd.port.mk>
diff --git a/devel/py-mmh3/distinfo b/devel/py-mmh3/distinfo
new file mode 100644
index 000000000000..c3265c5ac32a
--- /dev/null
+++ b/devel/py-mmh3/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1708448824
+SHA256 (mmh3-4.1.0.tar.gz) = a1cf25348b9acd229dda464a094d6170f47d2850a1fcb762a3b6172d2ce6ca4a
+SIZE (mmh3-4.1.0.tar.gz) = 26357
diff --git a/devel/py-mmh3/pkg-descr b/devel/py-mmh3/pkg-descr
new file mode 100644
index 000000000000..e16b72b3349a
--- /dev/null
+++ b/devel/py-mmh3/pkg-descr
@@ -0,0 +1,9 @@
+mmh3 is a Python extension for MurmurHash (MurmurHash3), a set of fast and
+robust non-cryptographic hash functions invented by Austin Appleby.
+
+Combined with probabilistic techniques like a Bloom filter, MinHash, and feature
+hashing, mmh3 allows you to develop high-performance systems in fields such as
+data mining, machine learning, and natural language processing.
+
+Another common use of mmh3 is to calculate favicon hashes used by Shodan, the
+world's first IoT search engine.