aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2023-02-28 16:33:13 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2023-02-28 18:43:46 +0000
commite1444d580be63126059934cbf0925fc0aaadb322 (patch)
treec947b5d576a79744afe393dce1a741d5003e9977
parent01794d818d1ff3716b1730b89dce16ec7919c7b5 (diff)
downloadports-e1444d580be63126059934cbf0925fc0aaadb322.tar.gz
ports-e1444d580be63126059934cbf0925fc0aaadb322.zip
math/costa: Fix build on some systems by removing the -native flag
-rw-r--r--math/costa/Makefile1
-rw-r--r--math/costa/files/patch-CMakeLists.txt11
2 files changed, 12 insertions, 0 deletions
diff --git a/math/costa/Makefile b/math/costa/Makefile
index 12f41b4d51ef..4cd520b6953f 100644
--- a/math/costa/Makefile
+++ b/math/costa/Makefile
@@ -1,6 +1,7 @@
PORTNAME= costa
DISTVERSIONPREFIX= v
DISTVERSION= 2.2
+PORTREVISION= 1
CATEGORIES= math
MAINTAINER= yuri@FreeBSD.org
diff --git a/math/costa/files/patch-CMakeLists.txt b/math/costa/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..72ff9c11ba6e
--- /dev/null
+++ b/math/costa/files/patch-CMakeLists.txt
@@ -0,0 +1,11 @@
+--- CMakeLists.txt.orig 2023-02-28 08:57:54 UTC
++++ CMakeLists.txt
+@@ -58,7 +58,7 @@ adjust_mpiexec_flags()
+ # OpenMP
+ find_package(OpenMP COMPONENTS CXX REQUIRED)
+
+-SET(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -O3 -funroll-loops -march=native -DNDEBUG")
++SET(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -funroll-loops")
+
+ # Bundled dependencies
+ #