aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2024-02-12 13:19:42 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2024-02-12 13:24:57 +0000
commite1584ae1c5af74f4ee54ee8dee74b2650dd20714 (patch)
treefd204a73cecc9e98197a314bc2f8415af1988af1
parent5d01dea4a100a08ff5f7aac3855f19fd74e29060 (diff)
downloadports-e1584ae1c5af74f4ee54ee8dee74b2650dd20714.tar.gz
ports-e1584ae1c5af74f4ee54ee8dee74b2650dd20714.zip
subpackages: fix minor regression
Before subpackages, when running package there where 2 cases: case 1: ${PACKAGES} directory exist: packages are created in the work/pkg directory then copies into ${PACKAGES} directory case 2: ${PACKAGES} does not exist: packages where only created in work/pkg After subpackages in the case 2, the packages get copied into the directory actually running the make package comment. This change makes the framework behave like before subpackages Reported by: Antonio Huete Jimenez (tuxilio from Dragonfly irc channel)
-rw-r--r--Mk/bsd.port.mk2
1 files changed, 2 insertions, 0 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 448056ca1c17..5258bcfeb55b 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -3487,11 +3487,13 @@ ${WRKDIR_PKGFILE${_SP.${sp}}}: ${_PLIST}.${sp} create-manifest ${WRKDIR}/pkg
_EXTRA_PACKAGE_TARGET_DEP+= ${WRKDIR_PKGFILE${_SP.${sp}}}
+. if defined(_HAVE_PACKAGES)
${PKGFILE${_SP.${sp}}}: ${WRKDIR_PKGFILE${_SP.${sp}}}
@${LN} -f ${WRKDIR_PKGFILE${_SP.${sp}}} ${PKGFILE${_SP.${sp}}} 2>/dev/null \
|| ${CP} -f ${WRKDIR_PKGFILE${_SP.${sp}}} ${PKGFILE${_SP.${sp}}}
_EXTRA_PACKAGE_TARGET_DEP+= ${PKGFILE${_SP.${sp}}}
+. endif
. endfor
# This will be the end of the loop