aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDag-Erling Smørgrav <des@FreeBSD.org>2023-10-26 21:15:34 +0000
committerDag-Erling Smørgrav <des@FreeBSD.org>2023-10-26 21:15:34 +0000
commite17a041244b69dfdcfdd526f4b0674991b0e32b4 (patch)
tree1a972edc1ea83986fa8155e97d814c2f87a1ec09
parentf2306d55b1afcffa8ac7528ae022ed236c6e8b34 (diff)
downloadports-e17a041244b69dfdcfdd526f4b0674991b0e32b4.tar.gz
ports-e17a041244b69dfdcfdd526f4b0674991b0e32b4.zip
www/cadaver: Update to 0.24, always use SSL, drop ca_root_nss.
MFH: 2023Q4 Approved by: lev Differential Revision: https://reviews.freebsd.org/D42043
-rw-r--r--www/cadaver/Makefile24
-rw-r--r--www/cadaver/distinfo5
-rw-r--r--www/cadaver/files/patch-Makefile.in12
-rw-r--r--www/cadaver/files/patch-po_Makefile.in.in11
-rw-r--r--www/cadaver/files/patch-src-cmdline.c8
-rw-r--r--www/cadaver/files/patch-src-commands.c38
-rw-r--r--www/cadaver/files/patch-src-ls.c8
-rw-r--r--www/cadaver/files/patch-src-search.c8
-rw-r--r--www/cadaver/files/patch-src-version.c8
-rw-r--r--www/cadaver/files/patch-src__cadaver.c4
-rw-r--r--www/cadaver/pkg-message10
11 files changed, 76 insertions, 60 deletions
diff --git a/www/cadaver/Makefile b/www/cadaver/Makefile
index 5333ad63dcd7..ac1c5b9c63f2 100644
--- a/www/cadaver/Makefile
+++ b/www/cadaver/Makefile
@@ -1,19 +1,17 @@
PORTNAME= cadaver
-PORTVERSION= 0.23.3
-PORTREVISION= 4
+PORTVERSION= 0.24
CATEGORIES= www
-MASTER_SITES= http://www.webdav.org/cadaver/ \
- http://www.tcbug.org/
+MASTER_SITES= https://notroj.github.io/cadaver/
MAINTAINER= ports@FreeBSD.org
COMMENT= Commandline client for DAV
-WWW= http://www.webdav.org/cadaver/
+WWW= https://notroj.github.io/cadaver/
LIB_DEPENDS= libneon.so:www/neon
+USES= ssl
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --enable-netrc
-ALL_TARGET= cadaver
+CONFIGURE_ARGS= --enable-netrc --with-ssl
PLIST_FILES= bin/cadaver \
man/man1/cadaver.1.gz
@@ -34,16 +32,6 @@ LDFLAGS+= -L${LOCALBASE}/lib
USES+= cpe
CPE_VENDOR= webdav
-.if !defined(WITHOUT_OPENSSL)
-USES+= ssl
-CONFIGURE_ARGS+= --with-ssl --with-force-ssl
-post-install:
- #
- #
- @${CAT} ${PKGMESSAGE}
- #
- #
-.endif
OPTIONS_DEFINE= NLS
@@ -53,7 +41,7 @@ OPTIONS_DEFINE= NLS
USES+= gettext iconv
CONFIGURE_ARGS+=${ICONV_CONFIGURE_ARG} \
--with-libintl-prefix=${LOCALBASE}
-LANGS=en@quot es it
+LANGS=en@quot es
.for lang in ${LANGS}
PLIST_FILES+= share/locale/${lang}/LC_MESSAGES/cadaver.mo
.endfor
diff --git a/www/cadaver/distinfo b/www/cadaver/distinfo
index 1f3f9ec4967b..8e332d324543 100644
--- a/www/cadaver/distinfo
+++ b/www/cadaver/distinfo
@@ -1,2 +1,3 @@
-SHA256 (cadaver-0.23.3.tar.gz) = fd4ce68a3230ba459a92bcb747fc6afa91e46d803c1d5ffe964b661793c13fca
-SIZE (cadaver-0.23.3.tar.gz) = 831884
+TIMESTAMP = 1696274043
+SHA256 (cadaver-0.24.tar.gz) = 46cff2f3ebd32cd32836812ca47bcc75353fc2be757f093da88c0dd8f10fd5f6
+SIZE (cadaver-0.24.tar.gz) = 808069
diff --git a/www/cadaver/files/patch-Makefile.in b/www/cadaver/files/patch-Makefile.in
index 09e60593ed29..d286bb4a8430 100644
--- a/www/cadaver/files/patch-Makefile.in
+++ b/www/cadaver/files/patch-Makefile.in
@@ -1,6 +1,7 @@
---- Makefile.in 2008-02-11 05:29:53.000000000 -0500
-+++ Makefile.in 2010-04-16 14:31:42.000000000 -0400
-@@ -42,6 +42,6 @@
+--- Makefile.in.orig 2022-10-30 10:46:52 UTC
++++ Makefile.in
+@@ -41,8 +41,8 @@ SUBDIRS = lib/neon
+ OBJECTS = src/cadaver.o src/common.o src/commands.o src/ls.o \
src/cmdline.o src/options.o src/utils.o src/edit.o \
src/version.o src/search.o
-LIBOBJS = lib/basename.o lib/dirname.o lib/rpmatch.o lib/yesno.o \
@@ -9,7 +10,9 @@
+ lib/getpass.o \
@LIBOBJS@
ALLOBJS = $(OBJECTS) $(LIBOBJS)
-@@ -92,8 +92,8 @@
+
+@@ -91,10 +91,10 @@ Makefile: Makefile.in
+ src/cadaver.o: src/cadaver.c config.h src/common.h \
src/options.h src/cmdline.h src/commands.h src/cadaver.h
src/options.o: src/options.c config.h src/options.h src/cadaver.h src/common.h
-src/cmdline.o: src/cmdline.c src/cmdline.h src/cadaver.h lib/basename.h \
@@ -21,3 +24,4 @@
+ src/options.h src/common.h
src/edit.o: src/edit.c src/cadaver.h src/options.h src/common.h
src/common.o: src/common.c src/common.h config.h
+ src/ls.o: src/ls.c src/commands.h src/cadaver.h config.h
diff --git a/www/cadaver/files/patch-po_Makefile.in.in b/www/cadaver/files/patch-po_Makefile.in.in
new file mode 100644
index 000000000000..8354ceed359f
--- /dev/null
+++ b/www/cadaver/files/patch-po_Makefile.in.in
@@ -0,0 +1,11 @@
+--- po/Makefile.in.in.orig 2022-10-30 10:46:52 UTC
++++ po/Makefile.in.in
+@@ -42,7 +42,7 @@ INSTALL_DATA = @INSTALL_DATA@
+ mkinstalldirs = $(SHELL) @install_sh@ -d
+ install_sh = $(SHELL) @install_sh@
+ MKDIR_P = @MKDIR_P@
+-mkdir_p = @mkdir_p@
++mkdir_p = @MKDIR_P@
+
+ # When building gettext-tools, we prefer to use the built programs
+ # rather than installed programs. However, we can't do that when we
diff --git a/www/cadaver/files/patch-src-cmdline.c b/www/cadaver/files/patch-src-cmdline.c
index e9f9dc8d093d..2b457ae70383 100644
--- a/www/cadaver/files/patch-src-cmdline.c
+++ b/www/cadaver/files/patch-src-cmdline.c
@@ -1,8 +1,10 @@
---- src/cmdline.c 2006-12-28 12:01:51.000000000 -0500
-+++ src/cmdline.c 2010-04-16 14:31:42.000000000 -0400
-@@ -39,5 +39,4 @@
+--- src/cmdline.c.orig 2022-10-30 10:46:52 UTC
++++ src/cmdline.c
+@@ -38,7 +38,6 @@
+
#include "i18n.h"
#include "glob.h"
-#include "basename.h"
#include "common.h"
+ #include "commands.h"
diff --git a/www/cadaver/files/patch-src-commands.c b/www/cadaver/files/patch-src-commands.c
index 74e3f87cbf5b..cf0096160ac9 100644
--- a/www/cadaver/files/patch-src-commands.c
+++ b/www/cadaver/files/patch-src-commands.c
@@ -1,6 +1,7 @@
---- src/commands.c 2008-11-11 03:40:54.000000000 -0500
-+++ src/commands.c 2010-04-16 14:31:42.000000000 -0400
-@@ -71,6 +71,5 @@
+--- src/commands.c.orig 2022-10-30 10:46:52 UTC
++++ src/commands.c
+@@ -70,8 +70,7 @@
+ #include <ne_dates.h>
#include "i18n.h"
-#include "basename.h"
@@ -8,7 +9,9 @@
+#include <libgen.h>
#include "cadaver.h"
#include "commands.h"
-@@ -765,9 +764,9 @@
+ #include "options.h"
+@@ -771,17 +770,17 @@ static char *clever_path(const char *p, const char *sr
+ dest_is_coll = (dest[strlen(dest)-1] == '/');
src_is_coll = (src[strlen(src)-1] == '/');
if (strcmp(dest, ".") == 0) {
- ret = resolve_path(p, base_name(src), false);
@@ -20,44 +23,54 @@
+ ret = resolve_path(parent, basename(src), false);
free(parent);
} else if (!src_is_coll && dest_is_coll) {
-@@ -775,5 +774,5 @@
+ /* Moving a file to a collection... the destination should
* be the basename of file concated with the collection. */
char *tmp = resolve_path(p, dest, true);
- char *enc = escape_path(base_name(src));
+ char *enc = escape_path(basename(src));
ret = ne_concat(tmp, enc, NULL);
free(enc);
-@@ -950,5 +949,5 @@
+ free(tmp);
+@@ -979,7 +978,7 @@ static void execute_get(const char *remote, const char
+ if (local == NULL) {
struct stat st;
/* Choose an appropriate local filename */
- if (stat(base_name(remote), &st) == 0) {
+ if (stat(basename(remote), &st) == 0) {
char buf[BUFSIZ];
/* File already exists... don't overwrite */
-@@ -962,5 +961,5 @@
+ snprintf(buf, BUFSIZ, _("Enter local filename for `%s': "),
+@@ -992,7 +991,7 @@ static void execute_get(const char *remote, const char
+ return;
}
} else {
- filename = ne_strdup(base_name(remote));
+ filename = ne_strdup(basename(remote));
}
} else {
-@@ -1004,5 +1003,5 @@
+ filename = ne_strdup(local);
+@@ -1035,7 +1034,7 @@ static void execute_put(const char *local, const char
+ {
char *real_remote;
if (remote == NULL) {
- real_remote = resolve_path(session.uri.path, base_name(local), false);
+ real_remote = resolve_path(session.uri.path, basename(local), false);
} else {
real_remote = resolve_path(session.uri.path, remote, false);
---- src/edit.c 2008-10-24 07:36:41.000000000 -0400
-+++ src/edit.c 2010-04-16 14:37:24.000000000 -0400
-@@ -117,5 +117,5 @@
+ }
+--- src/edit.c.orig 2022-10-30 10:46:52 UTC
++++ src/edit.c
+@@ -116,7 +116,7 @@ void execute_edit(const char *remote)
+ struct ne_lock *lock = NULL;
char fname[PATH_MAX] = "/tmp/cadaver-edit-XXXXXX";
const char *pnt;
- int fd;
+ int fd, sufx_len;
int is_checkout, is_checkin;
-@@ -141,7 +141,9 @@
+ real_remote = resolve_path(session.uri.path, remote, false);
+@@ -140,9 +140,11 @@ void execute_edit(const char *remote)
+ if (pnt != NULL && strchr(pnt, '/') == NULL) {
strncat(fname, pnt, PATH_MAX);
fname[PATH_MAX-1] = '\0';
- }
@@ -69,3 +82,4 @@
+ fd = mkstemps(fname, sufx_len);
if (fd == -1) {
printf(_("Could not create temporary file %s:\n%s\n"), fname,
+ strerror(errno));
diff --git a/www/cadaver/files/patch-src-ls.c b/www/cadaver/files/patch-src-ls.c
index a63d88325f90..b0f3a34fbff0 100644
--- a/www/cadaver/files/patch-src-ls.c
+++ b/www/cadaver/files/patch-src-ls.c
@@ -1,8 +1,10 @@
---- src/ls.c 2008-10-10 11:29:05.000000000 -0400
-+++ src/ls.c 2010-04-16 14:31:42.000000000 -0400
-@@ -40,5 +40,4 @@
+--- src/ls.c.orig 2022-10-30 10:46:52 UTC
++++ src/ls.c
+@@ -39,7 +39,6 @@
+ #include "i18n.h"
#include "commands.h"
#include "cadaver.h"
-#include "basename.h"
#include "utils.h"
+ struct fetch_context {
diff --git a/www/cadaver/files/patch-src-search.c b/www/cadaver/files/patch-src-search.c
index c3016779c0c8..81fe796b9905 100644
--- a/www/cadaver/files/patch-src-search.c
+++ b/www/cadaver/files/patch-src-search.c
@@ -1,8 +1,10 @@
---- src/search.c 2007-08-22 08:24:56.000000000 -0400
-+++ src/search.c 2010-04-16 14:31:42.000000000 -0400
-@@ -42,5 +42,4 @@
+--- src/search.c.orig 2022-10-30 10:46:52 UTC
++++ src/search.c
+@@ -42,7 +42,6 @@
+ #include "i18n.h"
#include "commands.h"
#include "cadaver.h"
-#include "basename.h"
#include "options.h"
#include "utils.h"
+
diff --git a/www/cadaver/files/patch-src-version.c b/www/cadaver/files/patch-src-version.c
index 3f5c5efbd791..19858f8a18f6 100644
--- a/www/cadaver/files/patch-src-version.c
+++ b/www/cadaver/files/patch-src-version.c
@@ -1,8 +1,10 @@
---- src/version.c 2007-08-22 08:17:27.000000000 -0400
-+++ src/version.c 2010-04-16 14:31:42.000000000 -0400
-@@ -41,5 +41,4 @@
+--- src/version.c.orig 2022-10-30 10:46:52 UTC
++++ src/version.c
+@@ -40,7 +40,6 @@
+ #include "i18n.h"
#include "commands.h"
#include "cadaver.h"
-#include "basename.h"
#include "utils.h"
+ /* Message body for REPORT */
diff --git a/www/cadaver/files/patch-src__cadaver.c b/www/cadaver/files/patch-src__cadaver.c
index 5cae005994ee..e1106e04b63f 100644
--- a/www/cadaver/files/patch-src__cadaver.c
+++ b/www/cadaver/files/patch-src__cadaver.c
@@ -1,5 +1,5 @@
---- src/cadaver.c.orig 2010-10-15 17:01:46.000000000 +0200
-+++ src/cadaver.c 2010-10-15 17:02:29.000000000 +0200
+--- src/cadaver.c.orig 2022-10-30 10:46:52 UTC
++++ src/cadaver.c
@@ -42,6 +42,9 @@
#ifdef HAVE_LOCALE_H
#include <locale.h>
diff --git a/www/cadaver/pkg-message b/www/cadaver/pkg-message
deleted file mode 100644
index c22d2dbe4f84..000000000000
--- a/www/cadaver/pkg-message
+++ /dev/null
@@ -1,10 +0,0 @@
-[
-{ type: install
- message: <<EOM
- For SSL-verification of remote servers, the /etc/ssl/cert.pem
- should exist and point to a reasonable CA-certificate bundle.
-
- Installing security/ca_root_nss is one way to get it.
-EOM
-}
-]