aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-09-29 16:13:35 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-09-29 16:13:35 +0000
commite17f183ac7cb12907ae44e3e4d71258de6e6afda (patch)
tree4c2e77644aa0bfe837b209a682698dcc52935a36
parent290d7ac02c0a71917d48cccef6a366f658327d3d (diff)
downloadports-e17f183ac7cb12907ae44e3e4d71258de6e6afda.tar.gz
ports-e17f183ac7cb12907ae44e3e4d71258de6e6afda.zip
science/libkml: Update to newer snapshot (916a801)
- Re-apply 71a4cedd0383a76f847f0fa1ab32b9209df20959 - Clean up BUILD_DEPENDS: all of them are in the ports tree for years - Bump PORTREVISION of dependent port (graphics/gdal) for shlib change - Bump PORTREVISION for package change Local patches have been merged by upstream in 916a801 [1]. Tested all dependent ports of graphics/gdal in case of potential breakage. - math/openturns and science/paraview are skipped due to ceres-solver breakage - graphics/mapnik is skipped due to potential boost-libs breakage [2][3] Changes: https://github.com/libkml/libkml/commits/master Reference: https://github.com/libkml/libkml/commit/916a801ed3143ab82c07ec108bad271aa441da16 [1] https://pkg-status.freebsd.org/beefy18/data/main-amd64-default/p3b548e384d0b_sfc4a676827/logs/mapnik-3.1.0_3.log [2] https://pkg-status.freebsd.org/beefy16/data/132amd64-default/3b548e384d0b/logs/mapnik-3.1.0_3.log [3] PR: 266221, 266252
-rw-r--r--graphics/gdal/Makefile1
-rw-r--r--science/libkml/Makefile8
-rw-r--r--science/libkml/distinfo6
-rw-r--r--science/libkml/files/patch-examples-domviewer-CMakeLists.txt7
-rw-r--r--science/libkml/files/patch-examples-engine-CMakeLists.txt10
-rw-r--r--science/libkml/files/patch-examples-gpx-CMakeLists.txt10
-rw-r--r--science/libkml/files/patch-examples-gx-CMakeLists.txt11
-rw-r--r--science/libkml/files/patch-examples-hellonet-CMakeLists.txt15
-rw-r--r--science/libkml/files/patch-examples-java-CMakeLists.txt14
-rw-r--r--science/libkml/files/patch-examples-kml-CMakeLists.txt10
-rw-r--r--science/libkml/files/patch-examples-python-CMakeLists.txt10
-rw-r--r--science/libkml/files/patch-examples-regionator-CMakeLists.txt10
-rw-r--r--science/libkml/files/patch-examples-xsd-CMakeLists.txt12
-rw-r--r--science/libkml/pkg-plist13
14 files changed, 15 insertions, 122 deletions
diff --git a/graphics/gdal/Makefile b/graphics/gdal/Makefile
index 73ef643d879a..4ec686323913 100644
--- a/graphics/gdal/Makefile
+++ b/graphics/gdal/Makefile
@@ -1,5 +1,6 @@
PORTNAME= gdal
PORTVERSION= 3.7.2
+PORTREVISION= 1
CATEGORIES= graphics geography
MASTER_SITES= https://download.osgeo.org/gdal/${PORTVERSION}/ \
LOCAL/sunpoet
diff --git a/science/libkml/Makefile b/science/libkml/Makefile
index c59fc16cc70d..e0ea47db04f9 100644
--- a/science/libkml/Makefile
+++ b/science/libkml/Makefile
@@ -1,6 +1,6 @@
PORTNAME= libkml
PORTVERSION= 1.3.0
-PORTREVISION= 25
+PORTREVISION= 26
CATEGORIES= science
MAINTAINER= sunpoet@FreeBSD.org
@@ -10,19 +10,19 @@ WWW= https://github.com/libkml/libkml
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
-BUILD_DEPENDS= boost-libs>=1.44.0:devel/boost-libs
LIB_DEPENDS= libboost_thread.so:devel/boost-libs \
libexpat.so:textproc/expat2 \
liburiparser.so:net/uriparser
-USES= cmake compiler:c11 minizip pathfix
+USES= cmake compiler:c++11-lang minizip pathfix
CMAKE_OFF= BUILD_TESTING WITH_JAVA WITH_PYTHON WITH_SWIG
CMAKE_ON= BUILD_SHARED_LIBS
-USE_CXXSTD= gnu++98
+LDFLAGS+= -lz
USE_LDCONFIG= yes
USE_GITHUB= yes
+GH_TAGNAME= 916a801
OPTIONS_DEFINE= EXAMPLES
diff --git a/science/libkml/distinfo b/science/libkml/distinfo
index 95bb121b0428..f9bcebc8127c 100644
--- a/science/libkml/distinfo
+++ b/science/libkml/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1483245177
-SHA256 (libkml-libkml-1.3.0_GH0.tar.gz) = 8892439e5570091965aaffe30b08631fdf7ca7f81f6495b4648f0950d7ea7963
-SIZE (libkml-libkml-1.3.0_GH0.tar.gz) = 6639857
+TIMESTAMP = 1661599149
+SHA256 (libkml-libkml-1.3.0-916a801_GH0.tar.gz) = 233fffbbe7a7c349421349f5d5cc8e515d20344b6e7261171a092373488bd793
+SIZE (libkml-libkml-1.3.0-916a801_GH0.tar.gz) = 6647901
diff --git a/science/libkml/files/patch-examples-domviewer-CMakeLists.txt b/science/libkml/files/patch-examples-domviewer-CMakeLists.txt
deleted file mode 100644
index 8068aa15fe4c..000000000000
--- a/science/libkml/files/patch-examples-domviewer-CMakeLists.txt
+++ /dev/null
@@ -1,7 +0,0 @@
---- examples/domviewer/CMakeLists.txt.orig 2015-12-21 17:23:05 UTC
-+++ examples/domviewer/CMakeLists.txt
-@@ -1,3 +1,3 @@
- if(INSTALL_EXAMPLES)
-- install( FILES kml-aliases.txt DESTINATION ${KML_EXAMPLES_DIR} COMPONENT Development)
-+ install( FILES domviewer.py DESTINATION ${KML_EXAMPLES_DIR} COMPONENT Development)
- endif()
diff --git a/science/libkml/files/patch-examples-engine-CMakeLists.txt b/science/libkml/files/patch-examples-engine-CMakeLists.txt
deleted file mode 100644
index e72eadcea34d..000000000000
--- a/science/libkml/files/patch-examples-engine-CMakeLists.txt
+++ /dev/null
@@ -1,10 +0,0 @@
-@ -1,9 +0,0 @@
---- examples/engine/CMakeLists.txt.orig 2015-12-21 17:23:05 UTC
-+++ examples/engine/CMakeLists.txt
-@@ -60,5 +60,5 @@ build_example(
-
- if(INSTALL_EXAMPLES)
- file(GLOB eg_files "${CMAKE_CURRENT_SOURCE_DIR}/*.cc")
-- install(FILES ${eg_files} DESTINATION examples/engine)
-+ install(FILES ${eg_files} DESTINATION ${KML_EXAMPLES_DIR}/engine)
- endif(INSTALL_EXAMPLES)
diff --git a/science/libkml/files/patch-examples-gpx-CMakeLists.txt b/science/libkml/files/patch-examples-gpx-CMakeLists.txt
deleted file mode 100644
index 6fb838a3999e..000000000000
--- a/science/libkml/files/patch-examples-gpx-CMakeLists.txt
+++ /dev/null
@@ -1,10 +0,0 @@
-@ -1,9 +0,0 @@
---- examples/gpx/CMakeLists.txt.orig 2015-12-21 17:23:05 UTC
-+++ examples/gpx/CMakeLists.txt
-@@ -9,5 +9,5 @@ build_example(
-
- if(INSTALL_EXAMPLES)
- file(GLOB eg_files "${CMAKE_CURRENT_SOURCE_DIR}/*.cc")
-- install(FILES ${eg_files} DESTINATION examples/gpx)
-+ install(FILES ${eg_files} DESTINATION ${KML_EXAMPLES_DIR}/gpx)
- endif(INSTALL_EXAMPLES)
diff --git a/science/libkml/files/patch-examples-gx-CMakeLists.txt b/science/libkml/files/patch-examples-gx-CMakeLists.txt
deleted file mode 100644
index 63ea5edf78d1..000000000000
--- a/science/libkml/files/patch-examples-gx-CMakeLists.txt
+++ /dev/null
@@ -1,11 +0,0 @@
-@ -1,10 +0,0 @@
---- examples/gx/CMakeLists.txt.orig 2015-12-21 17:23:05 UTC
-+++ examples/gx/CMakeLists.txt
-@@ -12,5 +12,5 @@ if(INSTALL_EXAMPLES)
- file(GLOB eg_files "${CMAKE_CURRENT_SOURCE_DIR}/*.cc")
- install(
- FILES ${eg_files}
-- DESTINATION examples/gx)
-+ DESTINATION ${KML_EXAMPLES_DIR}/gx)
- endif()
-\ No newline at end of file
diff --git a/science/libkml/files/patch-examples-hellonet-CMakeLists.txt b/science/libkml/files/patch-examples-hellonet-CMakeLists.txt
deleted file mode 100644
index b88337891b67..000000000000
--- a/science/libkml/files/patch-examples-hellonet-CMakeLists.txt
+++ /dev/null
@@ -1,15 +0,0 @@
-@ -1,14 +0,0 @@
---- examples/hellonet/CMakeLists.txt.orig 2015-12-21 17:23:05 UTC
-+++ examples/hellonet/CMakeLists.txt
-@@ -78,9 +78,9 @@ if(INSTALL_EXAMPLES)
- file(GLOB eg_files "${CMAKE_CURRENT_SOURCE_DIR}/*.cc")
- install(
- FILES ${eg_files}
-- DESTINATION examples/hellonet)
-+ DESTINATION ${KML_EXAMPLES_DIR}/hellonet)
-
- install(
- FILES README curlfetch.h prompt.h
-- DESTINATION examples/hellonet)
-+ DESTINATION ${KML_EXAMPLES_DIR}/hellonet)
- endif()
diff --git a/science/libkml/files/patch-examples-java-CMakeLists.txt b/science/libkml/files/patch-examples-java-CMakeLists.txt
deleted file mode 100644
index 566b7898ff2f..000000000000
--- a/science/libkml/files/patch-examples-java-CMakeLists.txt
+++ /dev/null
@@ -1,14 +0,0 @@
-@ -1,13 +0,0 @@
---- examples/java/CMakeLists.txt.orig 2015-12-21 17:23:05 UTC
-+++ examples/java/CMakeLists.txt
-@@ -2,8 +2,8 @@ if(INSTALL_EXAMPLES)
- file(GLOB eg_files "${CMAKE_CURRENT_SOURCE_DIR}/*.java")
- install(
- FILES ${eg_files}
-- DESTINATION examples/java) ##compile java
-+ DESTINATION ${KML_EXAMPLES_DIR}/java) ##compile java
- install(
- FILES run.sh
-- DESTINATION examples/java) ##
-+ DESTINATION ${KML_EXAMPLES_DIR}/java) ##
- endif()
diff --git a/science/libkml/files/patch-examples-kml-CMakeLists.txt b/science/libkml/files/patch-examples-kml-CMakeLists.txt
deleted file mode 100644
index ad31765272c4..000000000000
--- a/science/libkml/files/patch-examples-kml-CMakeLists.txt
+++ /dev/null
@@ -1,10 +0,0 @@
-@ -1,9 +0,0 @@
---- examples/kml/CMakeLists.txt.orig 2015-12-21 17:23:05 UTC
-+++ examples/kml/CMakeLists.txt
-@@ -2,5 +2,5 @@ if(INSTALL_EXAMPLES)
- file(GLOB kml_files "${CMAKE_CURRENT_SOURCE_DIR}/*.kml")
- install(
- FILES ${kml_files}
-- DESTINATION examples/kml)
-+ DESTINATION ${KML_EXAMPLES_DIR}/kml)
- endif()
diff --git a/science/libkml/files/patch-examples-python-CMakeLists.txt b/science/libkml/files/patch-examples-python-CMakeLists.txt
deleted file mode 100644
index d0cd531702a3..000000000000
--- a/science/libkml/files/patch-examples-python-CMakeLists.txt
+++ /dev/null
@@ -1,10 +0,0 @@
-@ -1,9 +0,0 @@
---- examples/python/CMakeLists.txt.orig 2015-12-21 17:23:05 UTC
-+++ examples/python/CMakeLists.txt
-@@ -2,5 +2,5 @@ if(INSTALL_EXAMPLES)
- file(GLOB eg_files "${CMAKE_CURRENT_SOURCE_DIR}/*.py")
- install(
- FILES ${eg_files}
-- DESTINATION examples/python) ##compile python
-+ DESTINATION ${KML_EXAMPLES_DIR}/python) ##compile python
- endif()
diff --git a/science/libkml/files/patch-examples-regionator-CMakeLists.txt b/science/libkml/files/patch-examples-regionator-CMakeLists.txt
deleted file mode 100644
index 1bef0d4b1ac4..000000000000
--- a/science/libkml/files/patch-examples-regionator-CMakeLists.txt
+++ /dev/null
@@ -1,10 +0,0 @@
-@ -1,9 +0,0 @@
---- examples/regionator/CMakeLists.txt.orig 2015-12-21 17:23:05 UTC
-+++ examples/regionator/CMakeLists.txt
-@@ -10,5 +10,5 @@ if(INSTALL_EXAMPLES)
- file(GLOB eg_files "${CMAKE_CURRENT_SOURCE_DIR}/*.cc")
- install(
- FILES ${eg_files}
-- DESTINATION examples/regionator)
-+ DESTINATION ${KML_EXAMPLES_DIR}/regionator)
- endif()
diff --git a/science/libkml/files/patch-examples-xsd-CMakeLists.txt b/science/libkml/files/patch-examples-xsd-CMakeLists.txt
deleted file mode 100644
index 665a92dd4bb8..000000000000
--- a/science/libkml/files/patch-examples-xsd-CMakeLists.txt
+++ /dev/null
@@ -1,12 +0,0 @@
-@ -1,11 +0,0 @@
---- examples/xsd/CMakeLists.txt.orig 2015-12-21 17:23:05 UTC
-+++ examples/xsd/CMakeLists.txt
-@@ -1,5 +1,5 @@
- if(INSTALL_EXAMPLES)
-- install(FILES
-- domviewer.py
-- DESTINATION examples/xsd) #compile py
-+ file(GLOB eg_files "${CMAKE_CURRENT_SOURCE_DIR}/*.cc")
-+ install(FILES ${eg_files} DESTINATION ${KML_EXAMPLES_DIR}/xsd)
-+ install(FILES kml-aliases.txt DESTINATION ${KML_EXAMPLES_DIR}/xsd)
- endif()
diff --git a/science/libkml/pkg-plist b/science/libkml/pkg-plist
index d350eb80788f..c84995275ba9 100644
--- a/science/libkml/pkg-plist
+++ b/science/libkml/pkg-plist
@@ -54,6 +54,7 @@ include/kml/dom/gx_tour.h
include/kml/dom/hotspot.h
include/kml/dom/iconstyle.h
include/kml/dom/kml.h
+include/kml/dom/kml22.cc
include/kml/dom/kml22.h
include/kml/dom/kml_cast.h
include/kml/dom/kml_factory.h
@@ -141,22 +142,22 @@ lib/cmake/libkml/LibKMLTargets-%%CMAKE_BUILD_TYPE%%.cmake
lib/cmake/libkml/LibKMLTargets.cmake
lib/libkmlbase.so
lib/libkmlbase.so.1
-lib/libkmlbase.so.1.3.0
+lib/libkmlbase.so.1.3.1
lib/libkmlconvenience.so
lib/libkmlconvenience.so.1
-lib/libkmlconvenience.so.1.3.0
+lib/libkmlconvenience.so.1.3.1
lib/libkmldom.so
lib/libkmldom.so.1
-lib/libkmldom.so.1.3.0
+lib/libkmldom.so.1.3.1
lib/libkmlengine.so
lib/libkmlengine.so.1
-lib/libkmlengine.so.1.3.0
+lib/libkmlengine.so.1.3.1
lib/libkmlregionator.so
lib/libkmlregionator.so.1
-lib/libkmlregionator.so.1.3.0
+lib/libkmlregionator.so.1.3.1
lib/libkmlxsd.so
lib/libkmlxsd.so.1
-lib/libkmlxsd.so.1.3.0
+lib/libkmlxsd.so.1.3.1
libdata/pkgconfig/libkml.pc
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/checklinks.cc
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/circlegen.cc