aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Clausecker <fuz@FreeBSD.org>2023-03-25 23:08:24 +0000
committerRobert Clausecker <fuz@FreeBSD.org>2023-03-27 11:24:59 +0000
commite1b063121abec0d7be8299e1139fabc94fde2e61 (patch)
tree18c54de4f5fe0694e22035ebe27f67ccc3ffd9cc
parente2cdc5d266ab4e0f380b684c61020878d7799007 (diff)
downloadports-e1b063121abec0d7be8299e1139fabc94fde2e61.tar.gz
ports-e1b063121abec0d7be8299e1139fabc94fde2e61.zip
security/gokey: fix build on riscv64
Bump golang.org/x/sys dependency to a version new enough to support riscv64-freebsd. Sponsored by: Berliner Linux User Group e.V. Approved by: portmgr (build fix blanket)
-rw-r--r--security/gokey/Makefile7
-rw-r--r--security/gokey/distinfo4
-rw-r--r--security/gokey/files/patch-go.mod14
-rw-r--r--security/gokey/files/patch-go.sum11
-rw-r--r--security/gokey/files/patch-vendor_modules.txt18
5 files changed, 53 insertions, 1 deletions
diff --git a/security/gokey/Makefile b/security/gokey/Makefile
index 664ac9054013..5fa7c5603b8a 100644
--- a/security/gokey/Makefile
+++ b/security/gokey/Makefile
@@ -12,6 +12,9 @@ LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
USES= go:modules
+USE_GITHUB= nodefault
+GH_TUPLE= golang:sys:v0.6.0:sys
+
GO_MODULE= github.com/cloudflare/gokey
GO_TARGET= ./cmd/gokey
@@ -21,6 +24,10 @@ PORTDOCS= README.md
OPTIONS_DEFINE= DOCS
+pre-build:
+ ${RM} -r ${WRKSRC}/vendor/golang.org/x/sys
+ ${LN} -s ${WRKDIR}/sys-* ${WRKSRC}/vendor/golang.org/x/sys
+
do-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/${PORTDOCS} ${STAGEDIR}${DOCSDIR}
diff --git a/security/gokey/distinfo b/security/gokey/distinfo
index 1e2228ed6ca8..2c8ae8c5be3d 100644
--- a/security/gokey/distinfo
+++ b/security/gokey/distinfo
@@ -1,5 +1,7 @@
-TIMESTAMP = 1672107735
+TIMESTAMP = 1679785309
SHA256 (go/security_gokey/gokey-v0.1.2/v0.1.2.mod) = 950a88925784603d0a9b5af156afc7233601d33ddc237d01d6978f1c2f53e310
SIZE (go/security_gokey/gokey-v0.1.2/v0.1.2.mod) = 167
SHA256 (go/security_gokey/gokey-v0.1.2/v0.1.2.zip) = 44c0e33ce53a39d2c1aadb457478faacc46204e2a60c171d48c4c943d38df639
SIZE (go/security_gokey/gokey-v0.1.2/v0.1.2.zip) = 25411
+SHA256 (go/security_gokey/gokey-v0.1.2/golang-sys-v0.6.0_GH0.tar.gz) = b4f6d17c7a128f76169964b437cb66b3f2dbf9a33361928ec19dfecf7b03fc54
+SIZE (go/security_gokey/gokey-v0.1.2/golang-sys-v0.6.0_GH0.tar.gz) = 1434234
diff --git a/security/gokey/files/patch-go.mod b/security/gokey/files/patch-go.mod
new file mode 100644
index 000000000000..5e7868a42b96
--- /dev/null
+++ b/security/gokey/files/patch-go.mod
@@ -0,0 +1,14 @@
+--- go.mod.orig 2023-03-25 23:03:40 UTC
++++ go.mod
+@@ -1,8 +1,10 @@
+ module github.com/cloudflare/gokey
+
+-go 1.13
++go 1.17
+
+ require (
+ golang.org/x/crypto v0.0.0-20220622213112-05595931fe9d
+ golang.org/x/term v0.0.0-20201126162022-7de9c90e9dd1
+ )
++
++require golang.org/x/sys v0.6.0 // indirect
diff --git a/security/gokey/files/patch-go.sum b/security/gokey/files/patch-go.sum
new file mode 100644
index 000000000000..cff06eac8113
--- /dev/null
+++ b/security/gokey/files/patch-go.sum
@@ -0,0 +1,11 @@
+--- go.sum.orig 2023-03-25 23:03:43 UTC
++++ go.sum
+@@ -5,6 +5,8 @@ golang.org/x/sys v0.0.0-20201119102817-f84b799fce68/go
+ golang.org/x/sys v0.0.0-20210423082822-04245dca01da/go.mod h1:h1NjWce9XRLGQEsW7wpKNCjG9DtNlClVuFLEZdDNbEs=
+ golang.org/x/sys v0.0.0-20210615035016-665e8c7367d1 h1:SrN+KX8Art/Sf4HNj6Zcz06G7VEz+7w9tdXTPOZ7+l4=
+ golang.org/x/sys v0.0.0-20210615035016-665e8c7367d1/go.mod h1:oPkhp1MJrh7nUepCBck5+mAzfO9JrbApNNgaTdGDITg=
++golang.org/x/sys v0.6.0 h1:MVltZSvRTcU2ljQOhs94SXPftV6DCNnZViHeQps87pQ=
++golang.org/x/sys v0.6.0/go.mod h1:oPkhp1MJrh7nUepCBck5+mAzfO9JrbApNNgaTdGDITg=
+ golang.org/x/term v0.0.0-20201126162022-7de9c90e9dd1 h1:v+OssWQX+hTHEmOBgwxdZxK4zHq3yOs8F9J7mk0PY8E=
+ golang.org/x/term v0.0.0-20201126162022-7de9c90e9dd1/go.mod h1:bj7SfCRtBDWHUb9snDiAeCFNEtKQo2Wmx5Cou7ajbmo=
+ golang.org/x/text v0.3.6/go.mod h1:5Zoc/QRtKVWzQhOtBMvqHzDpF6irO9z98xDceosuGiQ=
diff --git a/security/gokey/files/patch-vendor_modules.txt b/security/gokey/files/patch-vendor_modules.txt
new file mode 100644
index 000000000000..e871e87d957c
--- /dev/null
+++ b/security/gokey/files/patch-vendor_modules.txt
@@ -0,0 +1,18 @@
+--- vendor/modules.txt.orig 2023-03-25 23:04:26 UTC
++++ vendor/modules.txt
+@@ -1,11 +1,14 @@
+ # golang.org/x/crypto v0.0.0-20220622213112-05595931fe9d
++## explicit; go 1.17
+ golang.org/x/crypto/ed25519
+ golang.org/x/crypto/hkdf
+ golang.org/x/crypto/pbkdf2
+-# golang.org/x/sys v0.0.0-20210615035016-665e8c7367d1
++# golang.org/x/sys v0.6.0
++## explicit; go 1.17
+ golang.org/x/sys/internal/unsafeheader
+ golang.org/x/sys/plan9
+ golang.org/x/sys/unix
+ golang.org/x/sys/windows
+ # golang.org/x/term v0.0.0-20201126162022-7de9c90e9dd1
++## explicit; go 1.11
+ golang.org/x/term