aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Jobs <andreas.jobs+freebsdbugs@ruhr-uni-bochum.de>2021-10-28 09:53:52 +0000
committerYasuhiro Kimura <yasu@FreeBSD.org>2021-10-28 09:58:11 +0000
commite1d1c6db7411fce9c2c6697057cc4be617a95abe (patch)
tree2398701a1bea996ecca8ef3688f70d8139e1e219
parent1de9073690687a9fb6c3b34564a71b4f2c560e9d (diff)
downloadports-e1d1c6db7411fce9c2c6697057cc4be617a95abe.tar.gz
ports-e1d1c6db7411fce9c2c6697057cc4be617a95abe.zip
mail/postfix-postfwd: Allow setting interface/port in rc.conf
* Switch to DISTVERSION * Pet portlint and portclippy * Reformat Makefile with portfmt PR: 257108
-rw-r--r--mail/postfix-postfwd/Makefile17
-rw-r--r--mail/postfix-postfwd/files/postfwd.in4
2 files changed, 12 insertions, 9 deletions
diff --git a/mail/postfix-postfwd/Makefile b/mail/postfix-postfwd/Makefile
index 448dad812bb4..9f7b61cf5a00 100644
--- a/mail/postfix-postfwd/Makefile
+++ b/mail/postfix-postfwd/Makefile
@@ -1,8 +1,9 @@
# Created by: Sahil Tandon <sahil@tandon.net>
PORTNAME= postfwd
-PORTVERSION= 2.03
DISTVERSIONPREFIX= v
+DISTVERSION= 2.03
+PORTREVISION= 1
CATEGORIES= mail
PKGNAMEPREFIX= postfix-
@@ -16,20 +17,20 @@ RUN_DEPENDS= p5-Net-DNS>=0:dns/p5-Net-DNS \
p5-Net-Server>=0:net/p5-Net-Server
USES= perl5 shebangfix
-
-NO_ARCH= yes
-SUB_FILES= pkg-message
-
-USE_RC_SUBR= ${PORTNAME}
USE_GITHUB= yes
-SHEBANG_FILES= sbin/* tools/*.pl tools/hapolicy/*
USE_PERL5= run
+USE_RC_SUBR= ${PORTNAME}
+
+SHEBANG_FILES= sbin/* tools/*.pl tools/hapolicy/*
+
+NO_ARCH= yes
NO_BUILD= yes
+SUB_FILES= pkg-message
PORTDOCS= *
PORTEXAMPLES= *
-OPTIONS_DEFINE= EXAMPLES DOCS
+OPTIONS_DEFINE= DOCS EXAMPLES
do-install:
${INSTALL_DATA} ${WRKSRC}/etc/${PORTNAME}.cf.sample ${STAGEDIR}${ETCDIR}
diff --git a/mail/postfix-postfwd/files/postfwd.in b/mail/postfix-postfwd/files/postfwd.in
index e4cb4a82f2bd..32bee652e4ea 100644
--- a/mail/postfix-postfwd/files/postfwd.in
+++ b/mail/postfix-postfwd/files/postfwd.in
@@ -23,12 +23,14 @@ load_rc_config $name
: ${postfwd_enable:="NO"}
: ${postfwd_flags="--shortlog --summary=600 --cache=600 --cache-rbl-timeout=3600 --cleanup-requests=1200 --cleanup-rbls=1800 --cleanup-rates=1200"}
+: ${postfwd_interface="127.0.0.1"}
+: ${postfwd_port="10040"}
pidfile=${postfwd_pidfile:="/var/run/${name}.pid"}
required_files=${postfwd_config:="%%PREFIX%%/etc/${name}.conf"}
command=%%PREFIX%%/bin/${name}
-command_args="--daemon --file=${required_files} --pidfile=${pidfile} --interface=127.0.0.1 --port=10040 --user=nobody --group=nobody"
+command_args="--daemon --file=${required_files} --pidfile=${pidfile} --interface=${postfwd_interface} --port=${postfwd_port} --user=nobody --group=nobody"
start_precmd="${name}_check"
status_cmd="${name}_status"