aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2021-05-04 07:17:01 +0000
committerJan Beich <jbeich@FreeBSD.org>2021-05-04 08:02:59 +0000
commite1d7d6fdeb6c69c437f75a25b61885044502b42d (patch)
treea81f77aaba275c414a20ab9bf434482bb4e1df15
parent099fe9dbb0147757fdd74e04c1dd2f981f69074b (diff)
downloadports-e1d7d6fdeb6c69c437f75a25b61885044502b42d.tar.gz
ports-e1d7d6fdeb6c69c437f75a25b61885044502b42d.zip
x11-wm/wayfire: chase upstream tag update
Affects only tests which are neither built nor installed. Changes: https://github.com/WayfireWM/wayfire/compare/6095d3aa...v0.7.1 Reported by: GitHub (watch releases)
-rw-r--r--x11-wm/wayfire/Makefile2
-rw-r--r--x11-wm/wayfire/distinfo10
-rw-r--r--x11-wm/wayfire/files/patch-private-libs10
3 files changed, 13 insertions, 9 deletions
diff --git a/x11-wm/wayfire/Makefile b/x11-wm/wayfire/Makefile
index 68465fbcde71..0c7888768f0d 100644
--- a/x11-wm/wayfire/Makefile
+++ b/x11-wm/wayfire/Makefile
@@ -29,7 +29,7 @@ USE_GL= egl glesv2
USE_GNOME= cairo
USE_XORG= pixman
GH_ACCOUNT= WayfireWM
-GH_TUPLE= WayfireWM:wf-touch:b1075c5:wftouch/subprojects/wf-touch \
+GH_TUPLE= WayfireWM:wf-touch:8974eb0:wftouch/subprojects/wf-touch \
WayfireWM:wf-utils:f45641b:wfutils/subprojects/wf-utils
OPTIONS_DEFINE= SUID X11
diff --git a/x11-wm/wayfire/distinfo b/x11-wm/wayfire/distinfo
index 7397b3e61371..412d1922600b 100644
--- a/x11-wm/wayfire/distinfo
+++ b/x11-wm/wayfire/distinfo
@@ -1,7 +1,7 @@
-TIMESTAMP = 1618996850
-SHA256 (WayfireWM-wayfire-v0.7.1_GH0.tar.gz) = 96cb7820cddbae962ca456fd1989cdaa00cd880b109bf8e9d667b9264a20c257
-SIZE (WayfireWM-wayfire-v0.7.1_GH0.tar.gz) = 363272
-SHA256 (WayfireWM-wf-touch-b1075c5_GH0.tar.gz) = 107fd73280e90c1330adc051b4dada1549a47e221e60d601d23e15b995f8bdc9
-SIZE (WayfireWM-wf-touch-b1075c5_GH0.tar.gz) = 53883
+TIMESTAMP = 1620112621
+SHA256 (WayfireWM-wayfire-v0.7.1_GH0.tar.gz) = af0af9d6623566e2b35d23e9422551a881fea41781478914d16fc9f4e2a14166
+SIZE (WayfireWM-wayfire-v0.7.1_GH0.tar.gz) = 363286
+SHA256 (WayfireWM-wf-touch-8974eb0_GH0.tar.gz) = 3d66a67b35452741135420caf43ba349d35fc64643b8e223e6cdf74dbcef33aa
+SIZE (WayfireWM-wf-touch-8974eb0_GH0.tar.gz) = 9881
SHA256 (WayfireWM-wf-utils-f45641b_GH0.tar.gz) = 2f546333d4b1dfa3ed14caee3682dcc4c7e33164cb255991d918f3ace5f51dd7
SIZE (WayfireWM-wf-utils-f45641b_GH0.tar.gz) = 48453
diff --git a/x11-wm/wayfire/files/patch-private-libs b/x11-wm/wayfire/files/patch-private-libs
index 2948201cae79..e0ee938f31c0 100644
--- a/x11-wm/wayfire/files/patch-private-libs
+++ b/x11-wm/wayfire/files/patch-private-libs
@@ -51,9 +51,9 @@ it private to wayfire package for now.
# -------------------------------------------------------------------------------------------------
# Unit tests
---- subprojects/wf-touch/meson.build.orig 2020-09-20 09:41:37 UTC
+--- subprojects/wf-touch/meson.build.orig 2021-03-19 14:56:39 UTC
+++ subprojects/wf-touch/meson.build
-@@ -5,14 +5,18 @@ project('wf-touch', ['cpp'],
+@@ -6,18 +6,22 @@ project('wf-touch', ['cpp'],
glm = dependency('glm')
wf_touch_inc_dirs = include_directories('.')
@@ -71,5 +71,9 @@ it private to wayfire package for now.
include_directories: wf_touch_inc_dirs, dependencies: glm)
+if not meson.is_subproject()
- subdir('test')
+ doctest = dependency('doctest', required: get_option('tests'))
+
+ if doctest.found()
+ subdir('test')
+endif
+ endif