aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2022-10-01 20:54:25 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2022-10-01 20:59:37 +0000
commite205a8f1f6de623b6ba859bc7927c52d59c5e584 (patch)
treecbd50410d89bf0fd869dd250c83cbabf2c3eae44
parent3f2eb05655a47245c3eee7ccdeba0eef9d8dc193 (diff)
downloadports-e205a8f1f6de623b6ba859bc7927c52d59c5e584.tar.gz
ports-e205a8f1f6de623b6ba859bc7927c52d59c5e584.zip
biology/hyphy: Add tests; Fix ONLY_FOR_ARCHS order
(cherry picked from commit d6b3e9f9c4f0c871c5625927378da900a3d81543)
-rw-r--r--biology/hyphy/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/biology/hyphy/Makefile b/biology/hyphy/Makefile
index 9e96954a676c..a3720c1b468e 100644
--- a/biology/hyphy/Makefile
+++ b/biology/hyphy/Makefile
@@ -13,11 +13,12 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
BROKEN= requires OpenMP support that is missing on this architecture
.endif
-ONLY_FOR_ARCHS= aarch64 amd64 armv7 i386 powerpc64le powerpc64 powerpc
+ONLY_FOR_ARCHS= aarch64 amd64 armv7 i386 powerpc powerpc64 powerpc64le
LIB_DEPENDS= libcurl.so:ftp/curl
-USES= cmake localbase:ldflags
+USES= cmake:insource,testing localbase:ldflags # tests fail in outsource build, see https://github.com/veg/hyphy/issues/1528
+
USE_GITHUB= yes
GH_ACCOUNT= veg
@@ -26,4 +27,6 @@ AVX_DESC= Advanced vector extensions support
AVX_CMAKE_OFF= -DNOAVX:BOOL=ON
+# 2 tests fail, see https://github.com/veg/hyphy/issues/1529
+
.include <bsd.port.mk>