aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2022-04-13 12:47:01 +0000
committerAlex Dupre <ale@FreeBSD.org>2022-04-13 13:56:48 +0000
commite26af9cd588079493e1843ec3e3411c46cdb5757 (patch)
tree7813423b66f8702825c0cc4a7fc3ff2fda640039
parentdd3cc209ddfe645936b3b46ce4112b21de342f51 (diff)
downloadports-e26af9cd588079493e1843ec3e3411c46cdb5757.tar.gz
ports-e26af9cd588079493e1843ec3e3411c46cdb5757.zip
lang/solidity: update to 0.8.13 release.
-rw-r--r--lang/solidity/Makefile2
-rw-r--r--lang/solidity/distinfo6
-rw-r--r--lang/solidity/files/patch-libevmasm_Assembly.cpp11
-rw-r--r--lang/solidity/files/patch-libevmasm_Instruction.h6
-rw-r--r--lang/solidity/files/patch-libevmasm_SemanticInformation.cpp11
-rw-r--r--lang/solidity/files/patch-libevmasm_SimplificationRule.h11
6 files changed, 40 insertions, 7 deletions
diff --git a/lang/solidity/Makefile b/lang/solidity/Makefile
index 8ec9a3f997ba..4a2b8337020f 100644
--- a/lang/solidity/Makefile
+++ b/lang/solidity/Makefile
@@ -1,7 +1,7 @@
# Created by: Alex Dupre <ale@FreeBSD.org>
PORTNAME= solidity
-PORTVERSION= 0.8.12
+PORTVERSION= 0.8.13
CATEGORIES= lang
MASTER_SITES= https://github.com/ethereum/solidity/releases/download/v${PORTVERSION}/
DISTNAME= ${PORTNAME}_${PORTVERSION}
diff --git a/lang/solidity/distinfo b/lang/solidity/distinfo
index d07e4f4f2452..557825a2ffad 100644
--- a/lang/solidity/distinfo
+++ b/lang/solidity/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1645092631
-SHA256 (solidity_0.8.12.tar.gz) = c63c2caf64feaef9fbde7c8d26e3d15aa9b159d08e7213e1e6bd3e4fd06c8308
-SIZE (solidity_0.8.12.tar.gz) = 3147863
+TIMESTAMP = 1648132604
+SHA256 (solidity_0.8.13.tar.gz) = 474c76b30f6de12e1d84171d094a110f4a9dbee8e110313de430e7ebabccb3da
+SIZE (solidity_0.8.13.tar.gz) = 3183155
diff --git a/lang/solidity/files/patch-libevmasm_Assembly.cpp b/lang/solidity/files/patch-libevmasm_Assembly.cpp
new file mode 100644
index 000000000000..41034a4cceaa
--- /dev/null
+++ b/lang/solidity/files/patch-libevmasm_Assembly.cpp
@@ -0,0 +1,11 @@
+--- libevmasm/Assembly.cpp.orig 2022-03-24 17:16:26 UTC
++++ libevmasm/Assembly.cpp
+@@ -48,6 +48,8 @@ using namespace solidity::evmasm;
+ using namespace solidity::langutil;
+ using namespace solidity::util;
+
++#undef MSIZE // remove MSIZE definition from <sys/params.h>, included by boost 1.66.0
++
+ AssemblyItem const& Assembly::append(AssemblyItem _i)
+ {
+ assertThrow(m_deposit >= 0, AssemblyException, "Stack underflow.");
diff --git a/lang/solidity/files/patch-libevmasm_Instruction.h b/lang/solidity/files/patch-libevmasm_Instruction.h
index ddefe0e6d4cf..3b8c13e7d7e6 100644
--- a/lang/solidity/files/patch-libevmasm_Instruction.h
+++ b/lang/solidity/files/patch-libevmasm_Instruction.h
@@ -1,8 +1,8 @@
---- libevmasm/Instruction.h.orig 2020-12-16 17:41:40 UTC
+--- libevmasm/Instruction.h.orig 2022-03-16 14:18:52 UTC
+++ libevmasm/Instruction.h
-@@ -27,6 +27,8 @@
+@@ -26,6 +26,8 @@
+ #include <libsolutil/Common.h>
#include <libsolutil/Assertions.h>
- #include <functional>
+#undef MSIZE // remove MSIZE definition from <sys/params.h>, included by boost 1.66.0
+
diff --git a/lang/solidity/files/patch-libevmasm_SemanticInformation.cpp b/lang/solidity/files/patch-libevmasm_SemanticInformation.cpp
new file mode 100644
index 000000000000..1d7ec7ac648c
--- /dev/null
+++ b/lang/solidity/files/patch-libevmasm_SemanticInformation.cpp
@@ -0,0 +1,11 @@
+--- libevmasm/SemanticInformation.cpp.orig 2022-03-24 17:18:03 UTC
++++ libevmasm/SemanticInformation.cpp
+@@ -29,6 +29,8 @@ using namespace std;
+ using namespace solidity;
+ using namespace solidity::evmasm;
+
++#undef MSIZE // remove MSIZE definition from <sys/params.h>, included by boost 1.66.0
++
+ vector<SemanticInformation::Operation> SemanticInformation::readWriteOperations(Instruction _instruction)
+ {
+ switch (_instruction)
diff --git a/lang/solidity/files/patch-libevmasm_SimplificationRule.h b/lang/solidity/files/patch-libevmasm_SimplificationRule.h
new file mode 100644
index 000000000000..df9e65db7012
--- /dev/null
+++ b/lang/solidity/files/patch-libevmasm_SimplificationRule.h
@@ -0,0 +1,11 @@
+--- libevmasm/SimplificationRule.h.orig 2022-03-24 17:18:35 UTC
++++ libevmasm/SimplificationRule.h
+@@ -25,6 +25,8 @@
+ #include <libsolutil/CommonData.h>
+ #include <functional>
+
++#undef MSIZE // remove MSIZE definition from <sys/params.h>, included by boost 1.66.0
++
+ namespace solidity::evmasm
+ {
+