aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2003-05-06 08:53:15 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2003-05-06 08:53:15 +0000
commite28fda86c6281b3ee8983d01f24d8f6c09d2c2d3 (patch)
tree8bbc2a7cae10aef8afc11c22942df838a732c20d
parent4a43bd9dd9343909eb1a75aa9d067c783466b996 (diff)
downloadports-e28fda86c6281b3ee8983d01f24d8f6c09d2c2d3.tar.gz
ports-e28fda86c6281b3ee8983d01f24d8f6c09d2c2d3.zip
Upgrade to 0.6.1.
PR: ports/51764 Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=80243
-rw-r--r--lang/gforth/Makefile38
-rw-r--r--lang/gforth/distinfo2
-rw-r--r--lang/gforth/files/patch-getopt.c16
-rw-r--r--lang/gforth/pkg-plist377
4 files changed, 242 insertions, 191 deletions
diff --git a/lang/gforth/Makefile b/lang/gforth/Makefile
index 3a5b2f46a839..b7ce33be0845 100644
--- a/lang/gforth/Makefile
+++ b/lang/gforth/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= gforth
-PORTVERSION= 0.5.0
+PORTVERSION= 0.6.1
CATEGORIES= lang
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= gforth
@@ -18,24 +18,20 @@ COMMENT= Fast and portable Forth system
#
STRIP= #none
-
USE_REINPLACE= yes
GNU_CONFIGURE= yes
USE_GMAKE= yes
ALL_TARGET= all info
-
-# PREFIX isn't honored. force it w/ prefix.
-MAKE_ARGS= prefix=${PREFIX}
+PLIST_SUB= PORTVERSION="${PORTVERSION}"
MAN1= gforth.1
# Local variables
#
-INSTALL_INFO?= install-info
-
-INFO_FILES= ${PORTNAME}.info
-INFO_DIR= ${PREFIX}/info
+DOC_FILES= AUTHORS BUGS Benchres COPYING COPYING.DOC \
+ INSTALL INSTALL.BINDIST NEWS README \
+ NEWS.vmgen README.vmgen ToDo
EMACS_FILES= gforth.el
EMACS_DIR= ${PREFIX}/share/emacs/site-lisp
@@ -43,8 +39,8 @@ EMACS_DIR= ${PREFIX}/share/emacs/site-lisp
EMPTY_FILES= siteinit.fs
FORTH_DIR= ${DATADIR}/site-forth
-EMPTY_DIRS= 4stack 6502 8086 avr c165 generic h8 \
- hppa ia64 m68k misc power shboom sparc
+EMPTY_DIRS= 4stack 6502 8086 avr c165 generic h8 hppa \
+ ia64 m68k misc power sharc shboom sparc
ARCH_DIR= ${DATADIR}/${PORTVERSION}/arch
# Post-extract
@@ -53,9 +49,7 @@ ARCH_DIR= ${DATADIR}/${PORTVERSION}/arch
post-extract: remove-info-files
remove-info-files:
-.for file in ${INFO_FILES}
- @${RM} -f ${WRKSRC}/doc/${file}*
-.endfor
+ @${RM} -f ${WRKSRC}/doc/*.info*
# Post-patch
#
@@ -70,17 +64,19 @@ patch-makefiles:
# Post-install
#
-post-install: install-info install-el \
- remove-empty-files remove-empty-dirs
+post-install: install-doc install-el remove-empty-files remove-empty-dirs
-install-info:
-.for file in ${INFO_FILES}
- @${INSTALL_INFO} ${INFO_DIR}/${file} ${INFO_DIR}/dir
+install-doc:
+.if !defined(NOPORTSDOC)
+ @${MKDIR} ${DOCSDIR}
+.for file in ${DOC_FILES}
+ @${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
.endfor
+.endif
install-el:
.for file in ${EMACS_FILES}
- @${INSTALL_DATA} ${WRKSRC}/${file} ${EMACS_DIR}/${file}
+ @${INSTALL_DATA} ${WRKSRC}/${file} ${EMACS_DIR}
.endfor
remove-empty-files:
@@ -94,3 +90,5 @@ remove-empty-dirs:
.endfor
.include <bsd.port.mk>
+
+CONFIGURE_TARGET:= --build=${CONFIGURE_TARGET}
diff --git a/lang/gforth/distinfo b/lang/gforth/distinfo
index 94e64f37e791..dd1aa0b106c3 100644
--- a/lang/gforth/distinfo
+++ b/lang/gforth/distinfo
@@ -1 +1 @@
-MD5 (gforth-0.5.0.tar.gz) = db16b64e9d63934bc4455e9b2aebbe13
+MD5 (gforth-0.6.1.tar.gz) = 91855c11c3989d0ba92139e278f047d0
diff --git a/lang/gforth/files/patch-getopt.c b/lang/gforth/files/patch-getopt.c
new file mode 100644
index 000000000000..9175b4778c42
--- /dev/null
+++ b/lang/gforth/files/patch-getopt.c
@@ -0,0 +1,16 @@
+--- engine/getopt.c.orig Sat Sep 23 20:22:09 2000
++++ engine/getopt.c Fri Mar 16 01:42:49 2001
+@@ -177,12 +177,12 @@
+ REQUIRE_ORDER, PERMUTE, RETURN_IN_ORDER
+ } ordering, default_ordering = PERMUTE;
+
++#include <string.h>
+ #ifdef __GNU_LIBRARY__
+ /* We want to avoid inclusion of string.h with non-GNU libraries
+ because there are many ways it can cause trouble.
+ On some systems, it contains special magic macros that don't work
+ in GCC. */
+-#include <string.h>
+ #define my_index strchr
+ #define my_bcopy(src, dst, n) memcpy ((dst), (src), (n))
+ #else
diff --git a/lang/gforth/pkg-plist b/lang/gforth/pkg-plist
index 00090fc6ef46..219dd628b5a2 100644
--- a/lang/gforth/pkg-plist
+++ b/lang/gforth/pkg-plist
@@ -1,186 +1,223 @@
@comment $FreeBSD$
-bin/gforth-0.5.0
+bin/gforth-%%PORTVERSION%%
@exec ln -fs %f %B/gforth
@unexec rm -f %B/gforth
-bin/gforth-fast-0.5.0
+bin/gforth-fast-%%PORTVERSION%%
@exec ln -fs %f %B/gforth-fast
@unexec rm -f %B/gforth-fast
-bin/gforthmi-0.5.0
+bin/gforth-itc-%%PORTVERSION%%
+@exec ln -fs %f %B/gforth-itc
+@unexec rm -f %B/gforth-itc
+bin/gforthmi-%%PORTVERSION%%
@exec ln -fs %f %B/gforthmi
@unexec rm -f %B/gforthmi
-@unexec install-info --delete %D/info/gforth.info %D/info/dir
+bin/vmgen-%%PORTVERSION%%
+@exec ln -fs %f %B/vmgen
+@unexec rm -f %B/vmgen
+@unexec install-info --quiet --delete %D/info/gforth.info %D/info/dir
info/gforth.info
@exec install-info %D/info/gforth.info %D/info/dir
-lib/gforth/0.5.0/gforth-ditc
-lib/gforth/0.5.0/gforth.fi
+@unexec install-info --quiet --delete %D/info/vmgen.info %D/info/dir
+info/vmgen.info
+@exec install-info %D/info/vmgen.info %D/info/dir
+lib/gforth/%%PORTVERSION%%/gforth-ditc
+lib/gforth/%%PORTVERSION%%/gforth.fi
@exec mkdir -p %D/lib/gforth/site-forth
+%%PORTDOCS%%share/doc/gforth/AUTHORS
+%%PORTDOCS%%share/doc/gforth/BUGS
+%%PORTDOCS%%share/doc/gforth/Benchres
+%%PORTDOCS%%share/doc/gforth/COPYING
+%%PORTDOCS%%share/doc/gforth/COPYING.DOC
+%%PORTDOCS%%share/doc/gforth/INSTALL
+%%PORTDOCS%%share/doc/gforth/INSTALL.BINDIST
+%%PORTDOCS%%share/doc/gforth/NEWS
+%%PORTDOCS%%share/doc/gforth/NEWS.vmgen
+%%PORTDOCS%%share/doc/gforth/README
+%%PORTDOCS%%share/doc/gforth/README.vmgen
+%%PORTDOCS%%share/doc/gforth/ToDo
share/emacs/site-lisp/gforth.el
-share/gforth/0.5.0/TAGS
-share/gforth/0.5.0/add.fs
-share/gforth/0.5.0/ans-report.fs
-share/gforth/0.5.0/ansi.fs
-share/gforth/0.5.0/answords.fs
-share/gforth/0.5.0/arch/386/asm.fs
-share/gforth/0.5.0/arch/386/disasm.fs
-share/gforth/0.5.0/arch/alpha/asm.fs
-share/gforth/0.5.0/arch/alpha/disasm.fs
-share/gforth/0.5.0/arch/mips/asm.fs
-share/gforth/0.5.0/arch/mips/disasm.fs
-share/gforth/0.5.0/arch/mips/insts.fs
-share/gforth/0.5.0/asm/README
-share/gforth/0.5.0/asm/basic.fs
-share/gforth/0.5.0/asm/bitmask.fs
-share/gforth/0.5.0/asm/generic.fs
-share/gforth/0.5.0/asm/numref.fs
-share/gforth/0.5.0/asm/target.fs
-share/gforth/0.5.0/assert.fs
-share/gforth/0.5.0/backtrac.fs
-share/gforth/0.5.0/blocked.fb
-share/gforth/0.5.0/blocks.fs
-share/gforth/0.5.0/bubble.fs
-share/gforth/0.5.0/bufio.fs
-share/gforth/0.5.0/chains.fs
-share/gforth/0.5.0/code.fs
-share/gforth/0.5.0/colorize.fs
-share/gforth/0.5.0/comp-i.fs
-share/gforth/0.5.0/compat/README
-share/gforth/0.5.0/compat/anslocal.fs
-share/gforth/0.5.0/compat/assert.fs
-share/gforth/0.5.0/compat/control.fs
-share/gforth/0.5.0/compat/defer.fs
-share/gforth/0.5.0/compat/exception.fs
-share/gforth/0.5.0/compat/loops.fs
-share/gforth/0.5.0/compat/required.fs
-share/gforth/0.5.0/compat/struct.fs
-share/gforth/0.5.0/compat/vocabulary.fs
-share/gforth/0.5.0/cross.fs
-share/gforth/0.5.0/debug.fs
-share/gforth/0.5.0/debugs.fs
-share/gforth/0.5.0/doc/makedoc.fs
-share/gforth/0.5.0/doskey.fs
-share/gforth/0.5.0/ds2texi.fs
-share/gforth/0.5.0/ec/README
-share/gforth/0.5.0/ec/builttag.fs
-share/gforth/0.5.0/ec/dotx.fs
-share/gforth/0.5.0/ec/mirror.fs
-share/gforth/0.5.0/ec/nesting.fs
-share/gforth/0.5.0/ec/shex.fs
-share/gforth/0.5.0/ekey.fs
-share/gforth/0.5.0/environ.fs
-share/gforth/0.5.0/envos.dos
-share/gforth/0.5.0/envos.fs
-share/gforth/0.5.0/envos.os2
-share/gforth/0.5.0/errors.fs
-share/gforth/0.5.0/etags.fs
-share/gforth/0.5.0/exboot.fs
-share/gforth/0.5.0/except.fs
-share/gforth/0.5.0/extend.fs
-share/gforth/0.5.0/fi2c.fs
-share/gforth/0.5.0/fib.fs
-share/gforth/0.5.0/filedump.fs
-share/gforth/0.5.0/float.fs
-share/gforth/0.5.0/glocals.fs
-share/gforth/0.5.0/glosgen.fs
-share/gforth/0.5.0/gray.fs
-share/gforth/0.5.0/hash.fs
-share/gforth/0.5.0/history.fs
-share/gforth/0.5.0/httpd.fs
-share/gforth/0.5.0/intcomp.fs
-share/gforth/0.5.0/kernel/accept.fs
-share/gforth/0.5.0/kernel/aliases.fs
-share/gforth/0.5.0/kernel/aliases0.fs
-share/gforth/0.5.0/kernel/args.fs
-share/gforth/0.5.0/kernel/basics.fs
-share/gforth/0.5.0/kernel/cbr.fs
-share/gforth/0.5.0/kernel/cloop.fs
-share/gforth/0.5.0/kernel/comp.fs
-share/gforth/0.5.0/kernel/cond-old.fs
-share/gforth/0.5.0/kernel/cond.fs
-share/gforth/0.5.0/kernel/doers.fs
-share/gforth/0.5.0/kernel/errore.fs
-share/gforth/0.5.0/kernel/files.fs
-share/gforth/0.5.0/kernel/getdoers.fs
-share/gforth/0.5.0/kernel/int.fs
-share/gforth/0.5.0/kernel/io.fs
-share/gforth/0.5.0/kernel/kernel.fs
-share/gforth/0.5.0/kernel/license.fs
-share/gforth/0.5.0/kernel/main.fs
-share/gforth/0.5.0/kernel/nio.fs
-share/gforth/0.5.0/kernel/pass.fs
-share/gforth/0.5.0/kernel/paths.fs
-share/gforth/0.5.0/kernel/prim0.fs
-share/gforth/0.5.0/kernel/quotes.fs
-share/gforth/0.5.0/kernel/require.fs
-share/gforth/0.5.0/kernel/saccept.fs
-share/gforth/0.5.0/kernel/tools.fs
-share/gforth/0.5.0/kernel/toolsext.fs
-share/gforth/0.5.0/kernel/vars.fs
-share/gforth/0.5.0/kernl32l.fi
-share/gforth/0.5.0/lib.fs
-share/gforth/0.5.0/locals.fs
-share/gforth/0.5.0/look.fs
-share/gforth/0.5.0/mach16b.fs
-share/gforth/0.5.0/mach16l.fs
-share/gforth/0.5.0/mach32b.fs
-share/gforth/0.5.0/mach32l.fs
-share/gforth/0.5.0/mach64b.fs
-share/gforth/0.5.0/mach64l.fs
-share/gforth/0.5.0/machpc.fs
-share/gforth/0.5.0/make-app.fs
-share/gforth/0.5.0/matrix.fs
-share/gforth/0.5.0/mini-oof.fs
-share/gforth/0.5.0/moof-exm.fs
-share/gforth/0.5.0/moofglos.fs
-share/gforth/0.5.0/more.fs
-share/gforth/0.5.0/objects.fs
-share/gforth/0.5.0/objexamp.fs
-share/gforth/0.5.0/oof.fs
-share/gforth/0.5.0/oofsampl.fs
-share/gforth/0.5.0/other.fs
-share/gforth/0.5.0/prim
-share/gforth/0.5.0/prims2x.fs
-share/gforth/0.5.0/random.fs
-share/gforth/0.5.0/savesys.fs
-share/gforth/0.5.0/search.fs
-share/gforth/0.5.0/see-ext.fs
-share/gforth/0.5.0/see.fs
-share/gforth/0.5.0/siev.fs
-share/gforth/0.5.0/sieve.fs
-share/gforth/0.5.0/sokoban.fs
-share/gforth/0.5.0/source.fs
-share/gforth/0.5.0/startup.fs
-share/gforth/0.5.0/string.fs
-share/gforth/0.5.0/struct.fs
-share/gforth/0.5.0/stuff.fs
-share/gforth/0.5.0/table.fs
-share/gforth/0.5.0/tasker.fs
-share/gforth/0.5.0/termsize.fs
-share/gforth/0.5.0/test/checkans.fs
-share/gforth/0.5.0/test/coretest.fs
-share/gforth/0.5.0/test/dbltest.fs
-share/gforth/0.5.0/test/other.fs
-share/gforth/0.5.0/test/postpone.fs
-share/gforth/0.5.0/test/tester.fs
-share/gforth/0.5.0/tt.fs
-share/gforth/0.5.0/unbuffer.fs
-share/gforth/0.5.0/vt100.fs
-share/gforth/0.5.0/vt100key.fs
-share/gforth/0.5.0/wordinfo.fs
-share/gforth/0.5.0/wordsets.fs
+share/gforth/%%PORTVERSION%%/TAGS
+share/gforth/%%PORTVERSION%%/add.fs
+share/gforth/%%PORTVERSION%%/ans-report.fs
+share/gforth/%%PORTVERSION%%/ansi.fs
+share/gforth/%%PORTVERSION%%/answords.fs
+share/gforth/%%PORTVERSION%%/arch/386/asm.fs
+share/gforth/%%PORTVERSION%%/arch/386/disasm.fs
+share/gforth/%%PORTVERSION%%/arch/alpha/asm.fs
+share/gforth/%%PORTVERSION%%/arch/alpha/disasm.fs
+share/gforth/%%PORTVERSION%%/arch/mips/asm.fs
+share/gforth/%%PORTVERSION%%/arch/mips/disasm.fs
+share/gforth/%%PORTVERSION%%/arch/mips/insts.fs
+share/gforth/%%PORTVERSION%%/asm/README
+share/gforth/%%PORTVERSION%%/asm/basic.fs
+share/gforth/%%PORTVERSION%%/asm/bitmask.fs
+share/gforth/%%PORTVERSION%%/asm/generic.fs
+share/gforth/%%PORTVERSION%%/asm/numref.fs
+share/gforth/%%PORTVERSION%%/asm/target.fs
+share/gforth/%%PORTVERSION%%/assert.fs
+share/gforth/%%PORTVERSION%%/backtrac.fs
+share/gforth/%%PORTVERSION%%/blocked.fb
+share/gforth/%%PORTVERSION%%/blocks.fs
+share/gforth/%%PORTVERSION%%/bubble.fs
+share/gforth/%%PORTVERSION%%/bufio.fs
+share/gforth/%%PORTVERSION%%/chains.fs
+share/gforth/%%PORTVERSION%%/code.fs
+share/gforth/%%PORTVERSION%%/colorize.fs
+share/gforth/%%PORTVERSION%%/comp-i.fs
+share/gforth/%%PORTVERSION%%/compat/README
+share/gforth/%%PORTVERSION%%/compat/anslocal.fs
+share/gforth/%%PORTVERSION%%/compat/assert.fs
+share/gforth/%%PORTVERSION%%/compat/control.fs
+share/gforth/%%PORTVERSION%%/compat/defer.fs
+share/gforth/%%PORTVERSION%%/compat/exception.fs
+share/gforth/%%PORTVERSION%%/compat/loops.fs
+share/gforth/%%PORTVERSION%%/compat/required.fs
+share/gforth/%%PORTVERSION%%/compat/strcomp.fs
+share/gforth/%%PORTVERSION%%/compat/struct.fs
+share/gforth/%%PORTVERSION%%/compat/vocabulary.fs
+share/gforth/%%PORTVERSION%%/cross.fs
+share/gforth/%%PORTVERSION%%/debug.fs
+share/gforth/%%PORTVERSION%%/debugs.fs
+share/gforth/%%PORTVERSION%%/doc/makedoc.fs
+share/gforth/%%PORTVERSION%%/doskey.fs
+share/gforth/%%PORTVERSION%%/ds2texi.fs
+share/gforth/%%PORTVERSION%%/ec/README
+share/gforth/%%PORTVERSION%%/ec/builttag.fs
+share/gforth/%%PORTVERSION%%/ec/dotx.fs
+share/gforth/%%PORTVERSION%%/ec/mirror.fs
+share/gforth/%%PORTVERSION%%/ec/nesting.fs
+share/gforth/%%PORTVERSION%%/ec/shex.fs
+share/gforth/%%PORTVERSION%%/ekey.fs
+share/gforth/%%PORTVERSION%%/environ.fs
+share/gforth/%%PORTVERSION%%/envos.dos
+share/gforth/%%PORTVERSION%%/envos.fs
+share/gforth/%%PORTVERSION%%/envos.os2
+share/gforth/%%PORTVERSION%%/errors.fs
+share/gforth/%%PORTVERSION%%/etags.fs
+share/gforth/%%PORTVERSION%%/exboot.fs
+share/gforth/%%PORTVERSION%%/except.fs
+share/gforth/%%PORTVERSION%%/extend.fs
+share/gforth/%%PORTVERSION%%/fi2c.fs
+share/gforth/%%PORTVERSION%%/fib.fs
+share/gforth/%%PORTVERSION%%/filedump.fs
+share/gforth/%%PORTVERSION%%/fixpath.fs
+share/gforth/%%PORTVERSION%%/float.fs
+share/gforth/%%PORTVERSION%%/glocals.fs
+share/gforth/%%PORTVERSION%%/glosgen.fs
+share/gforth/%%PORTVERSION%%/gray.fs
+share/gforth/%%PORTVERSION%%/hash.fs
+share/gforth/%%PORTVERSION%%/history.fs
+share/gforth/%%PORTVERSION%%/httpd.fs
+share/gforth/%%PORTVERSION%%/intcomp.fs
+share/gforth/%%PORTVERSION%%/kernel/accept.fs
+share/gforth/%%PORTVERSION%%/kernel/aliases.fs
+share/gforth/%%PORTVERSION%%/kernel/aliases0.fs
+share/gforth/%%PORTVERSION%%/kernel/args.fs
+share/gforth/%%PORTVERSION%%/kernel/basics.fs
+share/gforth/%%PORTVERSION%%/kernel/cbr.fs
+share/gforth/%%PORTVERSION%%/kernel/cloop.fs
+share/gforth/%%PORTVERSION%%/kernel/comp.fs
+share/gforth/%%PORTVERSION%%/kernel/cond-old.fs
+share/gforth/%%PORTVERSION%%/kernel/cond.fs
+share/gforth/%%PORTVERSION%%/kernel/doers.fs
+share/gforth/%%PORTVERSION%%/kernel/errore.fs
+share/gforth/%%PORTVERSION%%/kernel/files.fs
+share/gforth/%%PORTVERSION%%/kernel/getdoers.fs
+share/gforth/%%PORTVERSION%%/kernel/groups.fs
+share/gforth/%%PORTVERSION%%/kernel/input.fs
+share/gforth/%%PORTVERSION%%/kernel/int.fs
+share/gforth/%%PORTVERSION%%/kernel/io.fs
+share/gforth/%%PORTVERSION%%/kernel/kernel.fs
+share/gforth/%%PORTVERSION%%/kernel/license.fs
+share/gforth/%%PORTVERSION%%/kernel/main.fs
+share/gforth/%%PORTVERSION%%/kernel/nio.fs
+share/gforth/%%PORTVERSION%%/kernel/pass.fs
+share/gforth/%%PORTVERSION%%/kernel/paths.fs
+share/gforth/%%PORTVERSION%%/kernel/prim0.fs
+share/gforth/%%PORTVERSION%%/kernel/quotes.fs
+share/gforth/%%PORTVERSION%%/kernel/require.fs
+share/gforth/%%PORTVERSION%%/kernel/saccept.fs
+share/gforth/%%PORTVERSION%%/kernel/tools.fs
+share/gforth/%%PORTVERSION%%/kernel/toolsext.fs
+share/gforth/%%PORTVERSION%%/kernel/vars.fs
+share/gforth/%%PORTVERSION%%/kernl32l.fi
+share/gforth/%%PORTVERSION%%/lib.fs
+share/gforth/%%PORTVERSION%%/locals.fs
+share/gforth/%%PORTVERSION%%/locate.fs
+share/gforth/%%PORTVERSION%%/look.fs
+share/gforth/%%PORTVERSION%%/mach16b.fs
+share/gforth/%%PORTVERSION%%/mach16l.fs
+share/gforth/%%PORTVERSION%%/mach32b.fs
+share/gforth/%%PORTVERSION%%/mach32l.fs
+share/gforth/%%PORTVERSION%%/mach64b.fs
+share/gforth/%%PORTVERSION%%/mach64l.fs
+share/gforth/%%PORTVERSION%%/machpc.fs.in
+share/gforth/%%PORTVERSION%%/make-app.fs
+share/gforth/%%PORTVERSION%%/matrix.fs
+share/gforth/%%PORTVERSION%%/mini-oof.fs
+share/gforth/%%PORTVERSION%%/moof-exm.fs
+share/gforth/%%PORTVERSION%%/moofglos.fs
+share/gforth/%%PORTVERSION%%/more.fs
+share/gforth/%%PORTVERSION%%/objects.fs
+share/gforth/%%PORTVERSION%%/objexamp.fs
+share/gforth/%%PORTVERSION%%/oof.fs
+share/gforth/%%PORTVERSION%%/oofsampl.fs
+share/gforth/%%PORTVERSION%%/other.fs
+share/gforth/%%PORTVERSION%%/prim
+share/gforth/%%PORTVERSION%%/prims2x.fs
+share/gforth/%%PORTVERSION%%/proxy.fs
+share/gforth/%%PORTVERSION%%/quotes.fs
+share/gforth/%%PORTVERSION%%/random.fs
+share/gforth/%%PORTVERSION%%/savesys.fs
+share/gforth/%%PORTVERSION%%/search.fs
+share/gforth/%%PORTVERSION%%/see-ext.fs
+share/gforth/%%PORTVERSION%%/see.fs
+share/gforth/%%PORTVERSION%%/siev.fs
+share/gforth/%%PORTVERSION%%/sieve.fs
+share/gforth/%%PORTVERSION%%/simp-see.fs
+share/gforth/%%PORTVERSION%%/sokoban.fs
+share/gforth/%%PORTVERSION%%/source.fs
+share/gforth/%%PORTVERSION%%/startup.fs
+share/gforth/%%PORTVERSION%%/string.fs
+share/gforth/%%PORTVERSION%%/struct.fs
+share/gforth/%%PORTVERSION%%/stuff.fs
+share/gforth/%%PORTVERSION%%/table.fs
+share/gforth/%%PORTVERSION%%/tags.fs
+share/gforth/%%PORTVERSION%%/tasker.fs
+share/gforth/%%PORTVERSION%%/termsize.fs
+share/gforth/%%PORTVERSION%%/test/checkans.fs
+share/gforth/%%PORTVERSION%%/test/coretest.fs
+share/gforth/%%PORTVERSION%%/test/dbltest.fs
+share/gforth/%%PORTVERSION%%/test/float.fs
+share/gforth/%%PORTVERSION%%/test/gforth.fs
+share/gforth/%%PORTVERSION%%/test/other.fs
+share/gforth/%%PORTVERSION%%/test/postpone.fs
+share/gforth/%%PORTVERSION%%/test/signals.fs
+share/gforth/%%PORTVERSION%%/test/string.fs
+share/gforth/%%PORTVERSION%%/test/tester.fs
+share/gforth/%%PORTVERSION%%/tt.fs
+share/gforth/%%PORTVERSION%%/unbuffer.fs
+share/gforth/%%PORTVERSION%%/unix/socket.fs
+share/gforth/%%PORTVERSION%%/vt100.fs
+share/gforth/%%PORTVERSION%%/vt100key.fs
+share/gforth/%%PORTVERSION%%/wordinfo.fs
+share/gforth/%%PORTVERSION%%/wordsets.fs
@exec mkdir -p %D/share/gforth/site-forth
@dirrm share/gforth/site-forth
-@dirrm share/gforth/0.5.0/test
-@dirrm share/gforth/0.5.0/kernel
-@dirrm share/gforth/0.5.0/ec
-@dirrm share/gforth/0.5.0/doc
-@dirrm share/gforth/0.5.0/compat
-@dirrm share/gforth/0.5.0/asm
-@dirrm share/gforth/0.5.0/arch/mips
-@dirrm share/gforth/0.5.0/arch/alpha
-@dirrm share/gforth/0.5.0/arch/386
-@dirrm share/gforth/0.5.0/arch
-@dirrm share/gforth/0.5.0
+@dirrm share/gforth/%%PORTVERSION%%/unix
+@dirrm share/gforth/%%PORTVERSION%%/test
+@dirrm share/gforth/%%PORTVERSION%%/kernel
+@dirrm share/gforth/%%PORTVERSION%%/ec
+@dirrm share/gforth/%%PORTVERSION%%/doc
+@dirrm share/gforth/%%PORTVERSION%%/compat
+@dirrm share/gforth/%%PORTVERSION%%/asm
+@dirrm share/gforth/%%PORTVERSION%%/arch/mips
+@dirrm share/gforth/%%PORTVERSION%%/arch/alpha
+@dirrm share/gforth/%%PORTVERSION%%/arch/386
+@dirrm share/gforth/%%PORTVERSION%%/arch
+@dirrm share/gforth/%%PORTVERSION%%
@dirrm share/gforth
+%%PORTDOCS%%@dirrm share/doc/gforth
@dirrm lib/gforth/site-forth
-@dirrm lib/gforth/0.5.0
+@dirrm lib/gforth/%%PORTVERSION%%
@dirrm lib/gforth