aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2021-11-11 17:01:39 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2021-11-11 17:02:21 +0000
commite3ff5e341324ba4e9f2da13185dee112aea35025 (patch)
treebdf01c2cb4683f4974b1a4d81f416cc5431ef395
parent5064afcb637b187fa64ad030457988840e1f283e (diff)
downloadports-e3ff5e341324ba4e9f2da13185dee112aea35025.tar.gz
ports-e3ff5e341324ba4e9f2da13185dee112aea35025.zip
security/libxcrypt: New port: Extended crypt library for descrypt, md5crypt, bcrypt, and others
-rw-r--r--security/Makefile1
-rw-r--r--security/libxcrypt/Makefile20
-rw-r--r--security/libxcrypt/distinfo3
-rw-r--r--security/libxcrypt/pkg-descr17
-rw-r--r--security/libxcrypt/pkg-plist17
5 files changed, 58 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 106d04725e72..4c63bed128ec 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -337,6 +337,7 @@
SUBDIR += libu2f-host
SUBDIR += libuecc
SUBDIR += libwhisker
+ SUBDIR += libxcrypt
SUBDIR += libyubikey
SUBDIR += libzrtpcppcore
SUBDIR += linux-bitwarden-cli
diff --git a/security/libxcrypt/Makefile b/security/libxcrypt/Makefile
new file mode 100644
index 000000000000..1f6185e61c01
--- /dev/null
+++ b/security/libxcrypt/Makefile
@@ -0,0 +1,20 @@
+PORTNAME= libxcrypt
+DISTVERSIONPREFIX= v
+DISTVERSION= 4.4.26
+CATEGORIES= security
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Extended crypt library for descrypt, md5crypt, bcrypt, and others
+
+LICENSE= LGPL21
+
+USES= autoreconf gmake libtool
+
+USE_GITHUB= yes
+GH_ACCOUNT= besser82
+
+GNU_CONFIGURE= yes
+
+USE_LDCONFIG= yes
+
+.include <bsd.port.mk>
diff --git a/security/libxcrypt/distinfo b/security/libxcrypt/distinfo
new file mode 100644
index 000000000000..02baa268ed10
--- /dev/null
+++ b/security/libxcrypt/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1636649663
+SHA256 (besser82-libxcrypt-v4.4.26_GH0.tar.gz) = e8a544dd19171c1e6191a6044c96cc31496d781ba08b5a00f53310d001d58114
+SIZE (besser82-libxcrypt-v4.4.26_GH0.tar.gz) = 525004
diff --git a/security/libxcrypt/pkg-descr b/security/libxcrypt/pkg-descr
new file mode 100644
index 000000000000..383601e77914
--- /dev/null
+++ b/security/libxcrypt/pkg-descr
@@ -0,0 +1,17 @@
+libxcrypt is a modern library for one-way hashing of passwords. It supports a
+wide variety of both modern and historical hashing methods: yescrypt,
+gost-yescrypt, scrypt, bcrypt, sha512crypt, sha256crypt, md5crypt, SunMD5,
+sha1crypt, NT, bsdicrypt, bigcrypt, and descrypt. It provides the traditional
+Unix crypt and crypt_r interfaces, as well as a set of extended interfaces
+pioneered by Openwall Linux, crypt_rn, crypt_ra, crypt_gensalt,
+crypt_gensalt_rn, and crypt_gensalt_ra.
+
+libxcrypt is intended to be used by login(1), passwd(1), and other similar
+programs; that is, to hash a small number of passwords during an interactive
+authentication dialogue with a human. It is not suitable for use in bulk
+password-cracking applications, or in any other situation where speed is more
+important than careful handling of sensitive data. However, it is intended to be
+fast and lightweight enough for use in servers that must field thousands of
+login attempts per minute.
+
+WWW: https://github.com/besser82/libxcrypt
diff --git a/security/libxcrypt/pkg-plist b/security/libxcrypt/pkg-plist
new file mode 100644
index 000000000000..be5de7b3c85a
--- /dev/null
+++ b/security/libxcrypt/pkg-plist
@@ -0,0 +1,17 @@
+include/crypt.h
+lib/libcrypt.a
+lib/libcrypt.so
+lib/libcrypt.so.2
+lib/libcrypt.so.2.0.0
+libdata/pkgconfig/libcrypt.pc
+libdata/pkgconfig/libxcrypt.pc
+man/man3/crypt.3.gz
+man/man3/crypt_checksalt.3.gz
+man/man3/crypt_gensalt.3.gz
+man/man3/crypt_gensalt_ra.3.gz
+man/man3/crypt_gensalt_rn.3.gz
+man/man3/crypt_preferred_method.3.gz
+man/man3/crypt_r.3.gz
+man/man3/crypt_ra.3.gz
+man/man3/crypt_rn.3.gz
+man/man5/crypt.5.gz