aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKai Knoblich <kai@FreeBSD.org>2023-08-31 05:19:17 +0000
committerKai Knoblich <kai@FreeBSD.org>2023-08-31 05:43:40 +0000
commite405e1b07f406ad9f809e6168afe4d21657ccfbb (patch)
treee85fcd2cee3acc5f943206ee977e43e7e38be1a0
parent096daca93276d8892f6f3705db4e5b04fb864a89 (diff)
downloadports-e405e1b07f406ad9f809e6168afe4d21657ccfbb.tar.gz
ports-e405e1b07f406ad9f809e6168afe4d21657ccfbb.zip
textproc/py-markdown-callouts: New port
This extension for Python Markdown produces the same results as the "admonition" extension, but with a syntax that is much less intrusive and has a very reasonable fallback look for "vanilla" renderers.
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/py-markdown-callouts/Makefile22
-rw-r--r--textproc/py-markdown-callouts/distinfo3
-rw-r--r--textproc/py-markdown-callouts/files/patch-pyproject.toml12
-rw-r--r--textproc/py-markdown-callouts/pkg-descr3
5 files changed, 41 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 46a80495d365..b15fad5f9907 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -1410,6 +1410,7 @@
SUBDIR += py-m2r
SUBDIR += py-mako
SUBDIR += py-markdown
+ SUBDIR += py-markdown-callouts
SUBDIR += py-markdown-include
SUBDIR += py-markdown-it-py
SUBDIR += py-markdown2
diff --git a/textproc/py-markdown-callouts/Makefile b/textproc/py-markdown-callouts/Makefile
new file mode 100644
index 000000000000..d8460d4a6a9a
--- /dev/null
+++ b/textproc/py-markdown-callouts/Makefile
@@ -0,0 +1,22 @@
+PORTNAME= markdown-callouts
+DISTVERSION= 0.3.0
+CATEGORIES= textproc python
+MASTER_SITES= PYPI
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= kai@FreeBSD.org
+COMMENT= Markdown extension: Classier syntax for admonitions
+WWW= https://github.com/oprypin/markdown-callouts
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE.md
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}poetry-core>=0.12:devel/py-poetry-core@${PY_FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}markdown>=3.3.3<4:textproc/py-markdown@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= autoplist pep517
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/textproc/py-markdown-callouts/distinfo b/textproc/py-markdown-callouts/distinfo
new file mode 100644
index 000000000000..981409d53092
--- /dev/null
+++ b/textproc/py-markdown-callouts/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1688225214
+SHA256 (markdown-callouts-0.3.0.tar.gz) = 21e99d72a879663343e232158413e12eeaa9fb78b90e669f41cdbf0962a364fb
+SIZE (markdown-callouts-0.3.0.tar.gz) = 5287
diff --git a/textproc/py-markdown-callouts/files/patch-pyproject.toml b/textproc/py-markdown-callouts/files/patch-pyproject.toml
new file mode 100644
index 000000000000..225fea3423eb
--- /dev/null
+++ b/textproc/py-markdown-callouts/files/patch-pyproject.toml
@@ -0,0 +1,12 @@
+Use the more lightweight py-poetry-core instead py-poetry.
+
+--- pyproject.toml.orig 2022-09-18 20:43:59 UTC
++++ pyproject.toml
+@@ -48,5 +48,5 @@ filterwarnings = ["ignore::DeprecationWarning:.*:",
+ "default::DeprecationWarning:markdown_callouts.*:"]
+
+ [build-system]
+-requires = ["poetry>=0.12"]
+-build-backend = "poetry.masonry.api"
++requires = ["poetry-core>=0.12"]
++build-backend = "poetry.core.masonry.api"
diff --git a/textproc/py-markdown-callouts/pkg-descr b/textproc/py-markdown-callouts/pkg-descr
new file mode 100644
index 000000000000..f2bf76432d65
--- /dev/null
+++ b/textproc/py-markdown-callouts/pkg-descr
@@ -0,0 +1,3 @@
+This extension for Python Markdown produces the same results as the
+"admonition" extension, but with a syntax that is much less intrusive and has
+a very reasonable fallback look for "vanilla" renderers.