aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2021-11-23 10:09:09 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2021-11-23 23:53:28 +0000
commite4a4006f4ccb8277ec94a55f185dcb24476ef529 (patch)
tree955ee26ff29ad89664cfd96adcd1ad20613c18e5
parent5ef1e6c8b30a5982a8f70782817d42948658b60d (diff)
downloadports-e4a4006f4ccb8277ec94a55f185dcb24476ef529.tar.gz
ports-e4a4006f4ccb8277ec94a55f185dcb24476ef529.zip
audio/inscore: Update 1.28 -> 1.31
Reported by: portscout
-rw-r--r--audio/inscore/Makefile3
-rw-r--r--audio/inscore/distinfo6
-rw-r--r--audio/inscore/files/patch-build_CMakeLists.txt25
-rw-r--r--audio/inscore/files/patch-build_Makefile6
-rw-r--r--audio/inscore/files/patch-src_inscore_model_Modules.h6
-rw-r--r--audio/inscore/pkg-plist12
6 files changed, 30 insertions, 28 deletions
diff --git a/audio/inscore/Makefile b/audio/inscore/Makefile
index c01cfabe287e..694a9b7af70c 100644
--- a/audio/inscore/Makefile
+++ b/audio/inscore/Makefile
@@ -1,5 +1,5 @@
PORTNAME= inscore
-PORTVERSION= 1.28
+PORTVERSION= 1.31
CATEGORIES= audio
MAINTAINER= yuri@FreeBSD.org
@@ -23,6 +23,7 @@ GH_TAGNAME= v${PORTVERSION:S/.//}
GH_TUPLE= grame-cncm:guidolib:3cf3d88:guidolib/modules/guidolib # this uses some un-installed parts of the guidolib project, partucularly QGuidoPainter.h
CMAKE_SOURCE_PATH= ${WRKSRC}/build
+CMAKE_ARGS= -DFREEBSD_EXAMPLESDIR=${EXAMPLESDIR} -DFREEBSD_DOCSDIR=${DOCSDIR}
CXXFLAGS+= -I${LOCALBASE}/include/guido -I${LOCALBASE}/include/guidoar
CXXFLAGS_powerpc64= -DOSC_HOST_BIG_ENDIAN
diff --git a/audio/inscore/distinfo b/audio/inscore/distinfo
index 992c9f949b4d..768b11c5fdd6 100644
--- a/audio/inscore/distinfo
+++ b/audio/inscore/distinfo
@@ -1,5 +1,5 @@
-TIMESTAMP = 1635099044
-SHA256 (grame-cncm-inscore-1.28-v128_GH0.tar.gz) = f280d9057d59b140f8d567f9e8ac0ecdd811e2964475a817eb1a54f15d493d8b
-SIZE (grame-cncm-inscore-1.28-v128_GH0.tar.gz) = 443524698
+TIMESTAMP = 1637648784
+SHA256 (grame-cncm-inscore-1.31-v131_GH0.tar.gz) = 57f8074998c31e01fab3031c26a9a24fbe92adc4ff667a22cc9986b2666db2a3
+SIZE (grame-cncm-inscore-1.31-v131_GH0.tar.gz) = 468225470
SHA256 (grame-cncm-guidolib-3cf3d88_GH0.tar.gz) = 0ec8a9e60d76230e69de9e0263b04ffe93d4f2fa660856e2666863cd99f6bea4
SIZE (grame-cncm-guidolib-3cf3d88_GH0.tar.gz) = 42458506
diff --git a/audio/inscore/files/patch-build_CMakeLists.txt b/audio/inscore/files/patch-build_CMakeLists.txt
index 465c184506be..bc17c94dbc15 100644
--- a/audio/inscore/files/patch-build_CMakeLists.txt
+++ b/audio/inscore/files/patch-build_CMakeLists.txt
@@ -1,13 +1,18 @@
---- build/CMakeLists.txt.orig 2021-10-24 18:32:31 UTC
+--- build/CMakeLists.txt.orig 2021-11-08 06:26:08 UTC
+++ build/CMakeLists.txt
-@@ -378,8 +378,8 @@ else()
- set (INSTALL_BIN ${CMAKE_INSTALL_PREFIX}/bin)
+@@ -379,12 +379,12 @@ else()
set (INSTALL_LIB ${CMAKE_INSTALL_PREFIX}/lib)
set (INSTALL_INC ${CMAKE_INSTALL_PREFIX}/include/inscore)
-- set (INSTALL_SAMPLES ${CMAKE_INSTALL_PREFIX}/share/inscore/examples)
-- set (INSTALL_GMN_SAMPLES ${CMAKE_INSTALL_PREFIX}/share/inscore/GMN-Examples)
-+ set (INSTALL_SAMPLES share/examples/inscore)
-+ set (INSTALL_GMN_SAMPLES share/examples/inscore)
- set (INSTALL_BUNDLES ${CMAKE_INSTALL_PREFIX}/share/inscore/bundles)
- set (INSTALL_TOOLS ${CMAKE_INSTALL_PREFIX}/share/inscore/tools)
- set (INSTALL_INTERFACES ${CMAKE_INSTALL_PREFIX}/share/inscore)
+ set (INSTALL_SHARED ${CMAKE_INSTALL_PREFIX}/share)
+- set (INSTALL_SAMPLES ${INSTALL_SHARED}/inscore/examples)
+- set (INSTALL_GMN_SAMPLES ${INSTALL_SHARED}/inscore/GMN-Examples)
++ set (INSTALL_SAMPLES ${FREEBSD_EXAMPLESDIR})
++ set (INSTALL_GMN_SAMPLES ${FREEBSD_EXAMPLESDIR}/GMN-Examples)
+ set (INSTALL_BUNDLES ${INSTALL_SHARED}/inscore/bundles)
+ set (INSTALL_TOOLS ${INSTALL_SHARED}/inscore/tools)
+ set (INSTALL_INTERFACES ${INSTALL_SHARED}/inscore)
+- set (INSTALL_DOC ${INSTALL_SHARED}/inscore/doc)
++ set (INSTALL_DOC ${FREEBSD_DOCSDIR})
+ endif()
+ set (installtargets ${viewer} ${ibundle} ${libtarget})
+
diff --git a/audio/inscore/files/patch-build_Makefile b/audio/inscore/files/patch-build_Makefile
index 780da7561b9a..473e626e97cb 100644
--- a/audio/inscore/files/patch-build_Makefile
+++ b/audio/inscore/files/patch-build_Makefile
@@ -1,6 +1,6 @@
---- build/Makefile.orig 2021-02-23 07:13:54 UTC
+--- build/Makefile.orig 2021-11-08 06:26:08 UTC
+++ build/Makefile
-@@ -38,7 +38,7 @@ endif
+@@ -28,7 +28,7 @@ MAKEFILE ?= Makefile # used to check the dependency
GENERATOR ?=
all :
@@ -8,4 +8,4 @@
+ #$(MAKE) modules
$(MAKE) inscore
- test:
+ test: PATH := /Users/Shared/Qt/5.15.2/5.15.2/ios/bin:$(PATH)
diff --git a/audio/inscore/files/patch-src_inscore_model_Modules.h b/audio/inscore/files/patch-src_inscore_model_Modules.h
index a414b0e69073..f06ab9ba9e13 100644
--- a/audio/inscore/files/patch-src_inscore_model_Modules.h
+++ b/audio/inscore/files/patch-src_inscore_model_Modules.h
@@ -1,4 +1,4 @@
---- src/inscore/model/Modules.h.orig 2021-02-23 07:27:14 UTC
+--- src/inscore/model/Modules.h.orig 2021-11-08 06:26:08 UTC
+++ src/inscore/model/Modules.h
@@ -56,7 +56,7 @@
@@ -7,5 +7,5 @@
-# define HASQGuidoImporter true
+# define HASQGuidoImporter false
# define HASFileDownloader true
- # define HASWSSupport true
- # define HASHTTPSupport true
+ //#ifndef ANDROID
+ #if 1
diff --git a/audio/inscore/pkg-plist b/audio/inscore/pkg-plist
index 25ead7df9dbd..4373705301b6 100644
--- a/audio/inscore/pkg-plist
+++ b/audio/inscore/pkg-plist
@@ -5,16 +5,12 @@ include/inscore/INScore.h
include/inscore/message.h
lib/libINScore.so
lib/libINScore.so.1
-lib/libINScore.so.1.2.8
+lib/libINScore.so.1.3.1
+share/applications/inscore.desktop
share/fonts/inscore/Carlito-Regular.ttf
share/fonts/inscore/guido2.ttf
-%%DATADIR%%/doc/Guido/GMNRefCard.pdf
-%%DATADIR%%/doc/Guido/GUIDO-Music-Notation-Format.pdf
-%%DATADIR%%/doc/Guido/RefCardsParams.pdf
-%%DATADIR%%/doc/Guido/RefCardsTags.pdf
-%%DATADIR%%/doc/Guido/readme.txt
-%%DATADIR%%/doc/INScore-refcard-1.12.pdf
-%%DATADIR%%/doc/INScoreLang.pdf
+share/icons/hicolor/128x128/apps/inscore.png
+share/icons/hicolor/48x48/apps/inscore.png
%%DATADIR%%/interfaces/Csound/CsoundCommandline/01Hello.csd
%%DATADIR%%/interfaces/Csound/CsoundCommandline/02Receive.csd
%%DATADIR%%/interfaces/Csound/CsoundCommandline/03Demo.csd