aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKai Knoblich <kai@FreeBSD.org>2021-12-31 11:12:35 +0000
committerKai Knoblich <kai@FreeBSD.org>2021-12-31 11:12:35 +0000
commite5913d07d3c8c6cd57b2bd19bad76c08fc5070a6 (patch)
tree0d312cbdb725891ab82eae9e5e0e47cf5bead650
parent36838f55657bcb53157eb88b9dcb5aaa97797b36 (diff)
downloadports-e5913d07d3c8c6cd57b2bd19bad76c08fc5070a6.tar.gz
ports-e5913d07d3c8c6cd57b2bd19bad76c08fc5070a6.zip
emulators/ucon64: Update to 2.2.2 [1]
* Remove two upstreamed patches and rebase existing patches. * Assume maintainership. Changelog: https://ucon64.sourceforge.io/ucon64/changes.html PR: 260544 Reported by: Daniël Hörchner (via e-mail) [1]
-rw-r--r--emulators/ucon64/Makefile17
-rw-r--r--emulators/ucon64/distinfo6
-rw-r--r--emulators/ucon64/files/patch-Makefile23
-rw-r--r--emulators/ucon64/files/patch-backup_libcd64_Makefile18
-rw-r--r--emulators/ucon64/files/patch-libdiscmage_Makefile.in21
-rw-r--r--emulators/ucon64/files/patch-libdiscmage_misc.c17
-rw-r--r--emulators/ucon64/files/patch-misc_misc.c17
7 files changed, 40 insertions, 79 deletions
diff --git a/emulators/ucon64/Makefile b/emulators/ucon64/Makefile
index c77dc487bbf2..db722f0e2d35 100644
--- a/emulators/ucon64/Makefile
+++ b/emulators/ucon64/Makefile
@@ -1,22 +1,20 @@
PORTNAME= ucon64
-PORTVERSION= 2.2.1
+PORTVERSION= 2.2.2
CATEGORIES= emulators
MASTER_SITES= SF/${PORTNAME:tl}/${PORTNAME:tl}/${PORTNAME:tl}-${PORTVERSION}
DISTNAME= ${PORTNAME}-${PORTVERSION}-src
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= kai@FreeBSD.org
COMMENT= Multipurpose video game ROM image and backup utility
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/../license.html # only available as HTML file
-USES= gmake
+USES= compiler gmake
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
-MAKE_ARGS= CC="${CC}"
-
WRKSRC_SUBDIR= src
PLIST_FILES= bin/ucon64
@@ -42,6 +40,13 @@ PARALLEL_CONFIGURE_ENABLE= parallel
USB_CONFIGURE_WITH= libusb
ZLIB_CONFIGURE_WITH= zlib
+.include <bsd.port.pre.mk>
+
+# GCC is assumed if "CC=cc" is set thus set CC accordingly if clang is used.
+.if ${COMPILER_TYPE} == clang && !defined(USE_GCC)
+CONFIGURE_ENV+= CC=clang
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g' ${WRKSRC}/ucon64.c
@${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g' ${WRKSRC}/ucon64_misc.c
@@ -54,4 +59,4 @@ do-install-DISCMAGE-on:
${INSTALL_LIB} ${WRKSRC}/libdiscmage/discmage.so \
${STAGEDIR}${PREFIX}/lib/libdiscmage.so
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/emulators/ucon64/distinfo b/emulators/ucon64/distinfo
index 77676543d977..810d701158bf 100644
--- a/emulators/ucon64/distinfo
+++ b/emulators/ucon64/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1608717049
-SHA256 (ucon64-2.2.1-src.tar.gz) = e814f427a59866e16fe757bf4af51004ac68be29cabd78944590878f1df73f79
-SIZE (ucon64-2.2.1-src.tar.gz) = 1476080
+TIMESTAMP = 1639593980
+SHA256 (ucon64-2.2.2-src.tar.gz) = e100ad4a30f6c19abde98e361c6a0ecac4e40477f54cfb75498c5ccd21fb3a18
+SIZE (ucon64-2.2.2-src.tar.gz) = 1481087
diff --git a/emulators/ucon64/files/patch-Makefile b/emulators/ucon64/files/patch-Makefile
index 89eea3ba5508..551a053a8e0a 100644
--- a/emulators/ucon64/files/patch-Makefile
+++ b/emulators/ucon64/files/patch-Makefile
@@ -1,16 +1,13 @@
-Remove some hardcoded optimization/warnings flags. This will become obsolete
-with the next release.
+Remove hardcoded optimization flags.
---- Makefile.orig 2020-12-26 22:51:37 UTC
+--- Makefile.orig 2021-12-17 09:54:12 UTC
+++ Makefile
-@@ -9,8 +9,8 @@ endif
-
- CC=gcc
+@@ -11,7 +11,7 @@ endif
CFLAGS0:=$(CFLAGS)
--CFLAGS+=-I. -Wall -W -Wno-implicit-fallthrough -Wno-format-truncation \
---Wno-stringop-overflow -O3 -fsigned-char
-+CFLAGS+=-I. -Wall -W -Wno-implicit-fallthrough \
-+-fsigned-char
- # Enable -Wstringop-overflow[=type] when it is no longer a broken, partial
- # implementation with false positives for trivial cases.
- LDFLAGS0:=$(LDFLAGS)
+ include config.mak
+
+-CFLAGS+=-I. -Wall -W -Wno-implicit-fallthrough -O3 -fsigned-char
++CFLAGS+=-I. -Wall -W -Wno-implicit-fallthrough -fsigned-char
+ ifneq ($(findstring clang,$(CC)),clang)
+ CFLAGS+=-Wno-format-truncation -Wno-stringop-overflow
+ endif
diff --git a/emulators/ucon64/files/patch-backup_libcd64_Makefile b/emulators/ucon64/files/patch-backup_libcd64_Makefile
index bf3837116f20..e6beda82572b 100644
--- a/emulators/ucon64/files/patch-backup_libcd64_Makefile
+++ b/emulators/ucon64/files/patch-backup_libcd64_Makefile
@@ -1,19 +1,13 @@
-Remove some hardcoded optimization/warnings flags. This will become obsolete
-with the next release.
+Remove hardcoded optimization flags.
---- backup/libcd64/Makefile.orig 2020-12-26 22:52:19 UTC
+--- backup/libcd64/Makefile.orig 2021-12-17 09:47:00 UTC
+++ backup/libcd64/Makefile
-@@ -1,11 +1,11 @@
- CC=gcc
-
- # I think we only use gnu99 instead of c99 due to va_args extensions.
--CFLAGS+=-I. -Wall -W -Wno-format-truncation -std=gnu99
-+CFLAGS+=-I. -Wall -W -std=gnu99
+@@ -10,7 +10,7 @@ endif
ifdef DEBUG
CFLAGS+=-pg -g -pedantic -ansi -DDEBUG
else
--CFLAGS+=-O6 -funroll-loops -fexpensive-optimizations
+-CFLAGS+=-O3 -funroll-loops
+CFLAGS+=-funroll-loops
+ ifneq ($(findstring clang,$(CC)),clang)
+ CFLAGS+=-fexpensive-optimizations
endif
-
- ifndef DJGPP
diff --git a/emulators/ucon64/files/patch-libdiscmage_Makefile.in b/emulators/ucon64/files/patch-libdiscmage_Makefile.in
index 8d34351d58e2..93c901800733 100644
--- a/emulators/ucon64/files/patch-libdiscmage_Makefile.in
+++ b/emulators/ucon64/files/patch-libdiscmage_Makefile.in
@@ -1,14 +1,13 @@
-Remove some hardcoded optimization/warnings flags. This will become obsolete
-with the next release.
+Remove hardcoded optimization flags.
---- libdiscmage/Makefile.in.orig 2020-12-26 22:53:30 UTC
+--- libdiscmage/Makefile.in.orig 2021-12-17 09:58:17 UTC
+++ libdiscmage/Makefile.in
-@@ -22,7 +22,7 @@ INSTALL_DATA=@INSTALL_DATA@
-
+@@ -23,7 +23,7 @@ INSTALL_DATA=@INSTALL_DATA@
+ ifeq ($(CC),cc)
CC=@CC@
- CFLAGS0:=$(CFLAGS) -I. -Wall -W -Wno-implicit-fallthrough \
---Wno-format-truncation -Wno-stringop-overflow -O3 @DEFS@
-+@DEFS@
- CFLAGS=$(CFLAGS0) -DDLL
- ifdef DLOPEN
- CFLAGS+=-DDLOPEN
+ endif
+-CFLAGS0:=$(CFLAGS) -I. -Wall -W -Wno-implicit-fallthrough -O3 @DEFS@
++CFLAGS0:=$(CFLAGS) -I. -Wall -W -Wno-implicit-fallthrough @DEFS@
+ ifneq ($(findstring clang,$(CC)),clang)
+ CFLAGS0+=-Wno-format-truncation -Wno-stringop-overflow
+ endif
diff --git a/emulators/ucon64/files/patch-libdiscmage_misc.c b/emulators/ucon64/files/patch-libdiscmage_misc.c
deleted file mode 100644
index 078715c63b0c..000000000000
--- a/emulators/ucon64/files/patch-libdiscmage_misc.c
+++ /dev/null
@@ -1,17 +0,0 @@
-Fixes a crash in change_mem2() on 64-bit platforms. That function is used for
-patching functionality.
-
-This patch is already incorporated at upstream and will become obsolete with
-the next release.
-
---- libdiscmage/misc.c.orig 2020-07-03 08:13:04 UTC
-+++ libdiscmage/misc.c
-@@ -1874,7 +1874,7 @@ change_mem2 (char *buf, size_t bufsize, char *searchst
-
- if (strpos == pos_1st_esc)
- setindex = 0; // reset argument pointer
-- if (pos_1st_esc == (unsigned int) -1)
-+ if (pos_1st_esc == (size_t) -1)
- pos_1st_esc = strpos;
-
- set = sets[setindex].data; // get next set of characters
diff --git a/emulators/ucon64/files/patch-misc_misc.c b/emulators/ucon64/files/patch-misc_misc.c
deleted file mode 100644
index 60d5743baa63..000000000000
--- a/emulators/ucon64/files/patch-misc_misc.c
+++ /dev/null
@@ -1,17 +0,0 @@
-Fixes a crash in change_mem2() on 64-bit platforms. That function is used for
-patching functionality.
-
-This patch is already incorporated at upstream and will become obsolete with
-the next release.
-
---- misc/misc.c.orig 2020-07-03 08:09:50 UTC
-+++ misc/misc.c
-@@ -501,7 +501,7 @@ change_mem2 (char *buf, size_t bufsize, char *searchst
-
- if (strpos == pos_1st_esc)
- setindex = 0; // reset argument pointer
-- if (pos_1st_esc == (unsigned int) -1)
-+ if (pos_1st_esc == (size_t) -1)
- pos_1st_esc = strpos;
-
- set = sets[setindex].data; // get next set of characters