aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2021-02-11 15:21:52 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2021-02-11 15:21:52 +0000
commite5e5976dee4bbc68aa4f84b0e2f53c1e0eca1376 (patch)
treef4e5ef5b97ca3074c7c96915248370cefee93614
parent4e718555291d61f8d2e68f672afa90a49008ad4b (diff)
downloadports-e5e5976dee4bbc68aa4f84b0e2f53c1e0eca1376.tar.gz
ports-e5e5976dee4bbc68aa4f84b0e2f53c1e0eca1376.zip
Force -fcommon to unbreak the build against modern compilers: this code
is old and entangled enough so fixing it properly does not look tenable.
Notes
Notes: svn path=/head/; revision=564958
-rw-r--r--games/xoids/Makefile5
-rw-r--r--games/xorgramana/Makefile3
-rw-r--r--games/xorgramana/files/patch-Makefile2
-rw-r--r--games/xtic/Makefile7
4 files changed, 6 insertions, 11 deletions
diff --git a/games/xoids/Makefile b/games/xoids/Makefile
index b37e7b6b911a..f2d0784a60f4 100644
--- a/games/xoids/Makefile
+++ b/games/xoids/Makefile
@@ -10,13 +10,12 @@ MASTER_SITES= XCONTRIB/games
MAINTAINER= ports@FreeBSD.org
COMMENT= X Window Asteroids style game with full color pixmaps
-BROKEN_FreeBSD_13= duplicate symbol: Big_O
-BROKEN_FreeBSD_14= duplicate symbol: Big_O
NOT_FOR_ARCHS= mips64
NOT_FOR_ARCHS_REASON= unknown architecture
USES= imake xorg
-USE_XORG= xpm
+USE_XORG= x11 xpm
+CFLAGS+= -fcommon
PLIST_FILES= bin/xoids \
man/man6/xoids.6.gz
diff --git a/games/xorgramana/Makefile b/games/xorgramana/Makefile
index 0cf996184f8d..37b8e3dd5f90 100644
--- a/games/xorgramana/Makefile
+++ b/games/xorgramana/Makefile
@@ -12,9 +12,6 @@ DISTNAME= XorGramana-${PORTVERSION}
MAINTAINER= amdmi3@FreeBSD.org
COMMENT= Logic word puzzle game set inside a series of mazes
-BROKEN_FreeBSD_13= duplicate symbol: player
-BROKEN_FreeBSD_14= duplicate symbol: player
-
USES= gl gmake sdl tar:bzip2
USE_SDL= sdl image
USE_GL= glu
diff --git a/games/xorgramana/files/patch-Makefile b/games/xorgramana/files/patch-Makefile
index d894f89096d1..7c5e4f15d84c 100644
--- a/games/xorgramana/files/patch-Makefile
+++ b/games/xorgramana/files/patch-Makefile
@@ -17,7 +17,7 @@
+SDL_LDFLAGS := $(shell ${SDL_CONFIG} --libs)
-CFLAGS := -Wall -g2 $(SDL_CFLAGS) -lGLU -lSDL_image -DDATADIR=\"$(SHAREDIR)\"
-+CFLAGS += -Wall $(SDL_CFLAGS) -DDATADIR=\"$(SHAREDIR)\"
++CFLAGS += -Wall -fcommon $(SDL_CFLAGS) -DDATADIR=\"$(SHAREDIR)\"
# -DPLAYER_XY_DEBUG
# -DMAP_DEBUG
diff --git a/games/xtic/Makefile b/games/xtic/Makefile
index 67d68b365b12..c3fb8ef5c0f0 100644
--- a/games/xtic/Makefile
+++ b/games/xtic/Makefile
@@ -11,11 +11,10 @@ DISTNAME= ${PORTNAME}${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= X version of a simple but tricky board game
-BROKEN_FreeBSD_13= duplicate symbol: board
-BROKEN_FreeBSD_14= duplicate symbol: board
-
USES= imake xorg
-USE_XORG= xaw
+USE_XORG= ice sm x11 xaw xext xmu xpm xt
+CFLAGS+= -fcommon
+
PLIST_FILES= bin/xtic man/man1/xtic.1.gz
post-patch: