aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2013-09-16 17:38:50 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2013-09-16 17:38:50 +0000
commite5ec23072ba2eeb1704beca3935f3a3446693b85 (patch)
treef8887608d6aa31142ba354fedadcd5e7e4374287
parent9060754677d9a1e46b0a498a81c31dfe9672e205 (diff)
downloadports-e5ec23072ba2eeb1704beca3935f3a3446693b85.tar.gz
ports-e5ec23072ba2eeb1704beca3935f3a3446693b85.zip
- Fix build with clang (Respect CC)
- Make it respect LOCALBASE - Trim Makefile headers - Convert LIB_DEPENDS to new format and remove ABI version number - USES gmake PR: ports/181615 Submitted by: Me Approved by: Maintainer timeout
Notes
Notes: svn path=/head/; revision=327426
-rw-r--r--audio/wavegain/Makefile5
-rw-r--r--audio/wavegain/files/patch-Makefile.linux10
2 files changed, 10 insertions, 5 deletions
diff --git a/audio/wavegain/Makefile b/audio/wavegain/Makefile
index 282afcb8b530..ade0db9e7efc 100644
--- a/audio/wavegain/Makefile
+++ b/audio/wavegain/Makefile
@@ -10,7 +10,7 @@ DISTNAME= ${PORTNAME}-${PORTVERSION}srcs${EXTRACT_SUFFIX}
MAINTAINER= darcsis@gmail.com
COMMENT= A program that applies ReplayGain to wave files
-LIB_DEPENDS= sndfile.1:${PORTSDIR}/audio/libsndfile
+LIB_DEPENDS= libsndfile.so:${PORTSDIR}/audio/libsndfile
USES= gmake
USE_ZIP= yes
@@ -26,6 +26,9 @@ WRKSRC= ${WRKDIR}/WaveGain-${PORTVERSION}
BROKEN= Does not compile on ia64, powerpc, or sparc64
.endif
+post-patch:
+ @${REINPLACE_CMD} -e "s|%%LOCALBASE%%|${LOCALBASE}|" ${WRKSRC}/Makefile.linux
+
do-configure:
@cd ${WRKSRC} && ${CP} Makefile.linux Makefile
diff --git a/audio/wavegain/files/patch-Makefile.linux b/audio/wavegain/files/patch-Makefile.linux
index 822b14270ceb..047b9d073750 100644
--- a/audio/wavegain/files/patch-Makefile.linux
+++ b/audio/wavegain/files/patch-Makefile.linux
@@ -1,9 +1,11 @@
---- Makefile.linux 2005-11-30 11:17:14.000000000 +0800
-+++ Makefile.linux 2008-05-24 22:14:34.000000000 +0800
-@@ -1,5 +1,5 @@
+--- Makefile.linux.orig 2005-11-30 12:17:14.000000000 +0100
++++ Makefile.linux 2013-08-28 13:02:43.817494398 +0200
+@@ -1,5 +1,7 @@
++CC ?= cc
++
all:
- gcc *.c -o wavegain -DHAVE_CONFIG_H -lm -lsndfile
-+ gcc *.c -o wavegain -DHAVE_CONFIG_H -lm -lsndfile -L/usr/local/lib
++ ${CC} *.c -o wavegain -DHAVE_CONFIG_H -lm -lsndfile -L%%LOCALBASE%%/lib
install:
install -d /usr/bin/