aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNuno Teixeira <eduardo@FreeBSD.org>2023-12-27 00:01:39 +0000
committerNuno Teixeira <eduardo@FreeBSD.org>2023-12-27 00:13:28 +0000
commite61a868efa0c33c77d1d3400df3f0e059f277dd7 (patch)
tree77e6d20d2c48f25cdc53292e27d1e100abf3f97b
parent7f99f1041c0fe82b0cde1012f0ea67ccfc27144c (diff)
downloadports-e61a868efa0c33c77d1d3400df3f0e059f277dd7.tar.gz
ports-e61a868efa0c33c77d1d3400df3f0e059f277dd7.zip
games/exult{,-devel}: Silence cast warnings on clang >=16
Apply upstream recommendation to silence cast warnings observed on clang 16 and 17 until a fix is provided. (impact: testport log size from ~70MB to ~700KB)
-rw-r--r--games/exult/Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/games/exult/Makefile b/games/exult/Makefile
index 0b069d866db1..c864e1986cc5 100644
--- a/games/exult/Makefile
+++ b/games/exult/Makefile
@@ -79,4 +79,12 @@ post-install-DOCS-on:
${INSTALL_DATA} ${WRKSRC}/${i} ${STAGEDIR}${DOCSDIR}
.endfor
+.include <bsd.port.options.mk>
+
+# Silence cast warnings from GTK callbacks:
+# https://github.com/exult/exult/issues/416
+.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400091
+CFLAGS+= -Wno-cast-function-type-strict
+.endif
+
.include <bsd.port.mk>