aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-01-11 16:48:42 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-01-11 18:43:45 +0000
commite626b632cd5cd548ada8ac54fc0d323ab206f9a0 (patch)
treefa4bcd82fae203b783776b5c2c5613d1711157e3
parent40640416dfac2c6d5f74a3048fc61aa332f6fbfe (diff)
downloadports-e626b632cd5cd548ada8ac54fc0d323ab206f9a0.tar.gz
ports-e626b632cd5cd548ada8ac54fc0d323ab206f9a0.zip
security/rubygem-digest: Add rubygem-digest 3.1.0
Digest provides a framework for message digest libraries. You may want to look at OpenSSL::Digest as it supports more algorithms. A cryptographic hash function is a procedure that takes data and returns a fixed bit string: the hash value, also known as digest. Hash functions are also called one-way functions, it is easy to compute a digest from a message, but it is infeasible to generate a message from a digest. WWW: https://github.com/ruby/digest
-rw-r--r--security/Makefile1
-rw-r--r--security/rubygem-digest/Makefile18
-rw-r--r--security/rubygem-digest/distinfo3
-rw-r--r--security/rubygem-digest/pkg-descr10
4 files changed, 32 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 2da5037ce760..cc3a4b116c21 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -1082,6 +1082,7 @@
SUBDIR += rubygem-devise-two-factor-rails60
SUBDIR += rubygem-devise-two-factor-rails61
SUBDIR += rubygem-devise_pam_authenticatable2
+ SUBDIR += rubygem-digest
SUBDIR += rubygem-digest-crc
SUBDIR += rubygem-doorkeeper
SUBDIR += rubygem-doorkeeper-openid_connect
diff --git a/security/rubygem-digest/Makefile b/security/rubygem-digest/Makefile
new file mode 100644
index 000000000000..eb47f2fff158
--- /dev/null
+++ b/security/rubygem-digest/Makefile
@@ -0,0 +1,18 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+
+PORTNAME= digest
+PORTVERSION= 3.1.0
+CATEGORIES= security rubygems
+MASTER_SITES= RG
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Framework for message digest libraries
+
+LICENSE= BSD2CLAUSE RUBY
+LICENSE_COMB= dual
+LICENSE_FILE_BSD2CLAUSE=${WRKSRC}/LICENSE.txt
+
+USES= gem
+USE_RUBY= yes
+
+.include <bsd.port.mk>
diff --git a/security/rubygem-digest/distinfo b/security/rubygem-digest/distinfo
new file mode 100644
index 000000000000..71af31a50703
--- /dev/null
+++ b/security/rubygem-digest/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1641045732
+SHA256 (rubygem/digest-3.1.0.gem) = 69cc7c26adc807f7073e8fd02b9e1a772ead93c3b8290ee58142f8f5fafe7c03
+SIZE (rubygem/digest-3.1.0.gem) = 40448
diff --git a/security/rubygem-digest/pkg-descr b/security/rubygem-digest/pkg-descr
new file mode 100644
index 000000000000..c9e7a7edc45a
--- /dev/null
+++ b/security/rubygem-digest/pkg-descr
@@ -0,0 +1,10 @@
+Digest provides a framework for message digest libraries.
+
+You may want to look at OpenSSL::Digest as it supports more algorithms.
+
+A cryptographic hash function is a procedure that takes data and returns a fixed
+bit string: the hash value, also known as digest. Hash functions are also called
+one-way functions, it is easy to compute a digest from a message, but it is
+infeasible to generate a message from a digest.
+
+WWW: https://github.com/ruby/digest