aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2022-12-17 20:45:01 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2022-12-17 23:10:16 +0000
commite66cf64fcf9beea7e3937491d113bbbee50bf263 (patch)
tree680189f1889b5d3f971bc15167feec8a4312f306
parentd2a712f7c12ae14b03c48b4098a7d84d6b0744ca (diff)
downloadports-e66cf64fcf9beea7e3937491d113bbbee50bf263.tar.gz
ports-e66cf64fcf9beea7e3937491d113bbbee50bf263.zip
devel/ccls: lock llvm-version at 9
LLVM_DEFAULT will be bumped to 15, this port fails with: [...] /wrkdirs/usr/ports/devel/ccls/work/ccls-0.20210330/src/indexer.cc:530:21: error: use of undeclared identifier 'isIdentifierBody'; did you mean 'IdentifierLoc'? ((i && isIdentifierBody(name[i - 1])) || ^ [...] PR: 263456
-rw-r--r--devel/ccls/Makefile7
1 files changed, 3 insertions, 4 deletions
diff --git a/devel/ccls/Makefile b/devel/ccls/Makefile
index cbc49efeea63..e1a03cfebde2 100644
--- a/devel/ccls/Makefile
+++ b/devel/ccls/Makefile
@@ -10,15 +10,14 @@ LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= rapidjson>=1.1.0_4:devel/rapidjson
-LIB_DEPENDS= libclang-cpp.so:devel/llvm${LLVM_DEFAULT}
-USES= cmake compiler:c++17-lang localbase
+USES= cmake compiler:c++17-lang llvm:max=9,lib localbase
USE_GITHUB= yes
GH_ACCOUNT= MaskRay
CMAKE_ARGS= -DCCLS_VERSION:STRING="${DISTVERSION}" \
- -DClang_DIR:PATH="${LOCALBASE}/llvm${LLVM_DEFAULT}/lib/cmake/clang" \
- -DLLVM_DIR:PATH="${LOCALBASE}/llvm${LLVM_DEFAULT}/lib/cmake/llvm"
+ -DClang_DIR:PATH="${LLVM_PREFIX}/lib/cmake/clang" \
+ -DLLVM_DIR:PATH="${LLVM_PREFIX}/lib/cmake/llvm"
CXXFLAGS+= -DNDEBUG
PLIST_FILES= bin/ccls