aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2022-01-20 21:53:36 +0000
committerJan Beich <jbeich@FreeBSD.org>2022-02-19 21:26:39 +0000
commite69f027f3fee012fecaacbb7986e75f532c5dbef (patch)
treea99f6c8af8a1cce24e6f6ea779e8f5bfc913dbdb
parent0a51988395c3b95c0bc9d2c41381d82f525a288c (diff)
downloadports-e69f027f3fee012fecaacbb7986e75f532c5dbef.tar.gz
ports-e69f027f3fee012fecaacbb7986e75f532c5dbef.zip
graphics/imlib2-jxl: add new port
This is a loader for imlib2 that adds support for reading and writing JPEG XL files. This lets you view them using feh, for example. It relies on libjxl for encoding and decoding the images. All JPEG XL files are supported, with the following limitations: * All images are internally converted to ARGB with 8 bits per sample, in an sRGB colorspace - this is a limitation of imlib2. * For animated JXLs, only the first frame is decoded. https://github.com/alistair7/imlib2-jxl
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/imlib2-jxl/Makefile37
-rw-r--r--graphics/imlib2-jxl/distinfo3
-rw-r--r--graphics/imlib2-jxl/pkg-descr10
4 files changed, 51 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 21a7454b8c7e..b5761def4acf 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -363,6 +363,7 @@
SUBDIR += imageworsener
SUBDIR += imc
SUBDIR += imlib2
+ SUBDIR += imlib2-jxl
SUBDIR += imlib2-webp
SUBDIR += imlib2_loaders
SUBDIR += impressive
diff --git a/graphics/imlib2-jxl/Makefile b/graphics/imlib2-jxl/Makefile
new file mode 100644
index 000000000000..f3a054521aca
--- /dev/null
+++ b/graphics/imlib2-jxl/Makefile
@@ -0,0 +1,37 @@
+PORTNAME= imlib2-jxl
+DISTVERSIONPREFIX= v
+DISTVERSION= 0.1.1
+CATEGORIES= graphics
+
+MAINTAINER= jbeich@FreeBSD.org
+COMMENT= JPEG XL loader for imlib2
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE-BSD-ab
+
+LIB_DEPENDS= libImlib2.so:graphics/imlib2 \
+ libjxl.so:graphics/libjxl
+
+USES= gmake pkgconfig
+USE_GITHUB= yes
+GH_ACCOUNT= alistair7
+MAKE_ENV= RELEASE_CFLAGS="${CFLAGS}"
+ALL_TARGET= # empty
+PLIST_FILES= lib/imlib2/loaders/jxl.so
+
+OPTIONS_DEFINE= LCMS2
+OPTIONS_DEFAULT=LCMS2
+
+LCMS2_LIB_DEPENDS= liblcms2.so:graphics/lcms2
+
+post-patch-LCMS2-off:
+ @${REINPLACE_CMD} -e '/-DIMLIB2JXL_USE_LCMS/d' \
+ -e 's/`pkg-config[^`]*lcms[^`]*`//' \
+ ${WRKSRC}/Makefile
+
+do-install:
+ ${MKDIR} ${STAGEDIR}${PREFIX}/${PLIST_FILES:M*.so:H}
+ ${INSTALL_LIB} ${WRKSRC}/${PLIST_FILES:M*.so:T} \
+ ${STAGEDIR}${PREFIX}/${PLIST_FILES:M*.so:H}
+
+.include <bsd.port.mk>
diff --git a/graphics/imlib2-jxl/distinfo b/graphics/imlib2-jxl/distinfo
new file mode 100644
index 000000000000..64e175fc75f6
--- /dev/null
+++ b/graphics/imlib2-jxl/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1642715616
+SHA256 (alistair7-imlib2-jxl-v0.1.1_GH0.tar.gz) = 25d220e4638948174d5e76c66e2f0441ee41e0758fa63f065cdfd51bb76c1465
+SIZE (alistair7-imlib2-jxl-v0.1.1_GH0.tar.gz) = 24731
diff --git a/graphics/imlib2-jxl/pkg-descr b/graphics/imlib2-jxl/pkg-descr
new file mode 100644
index 000000000000..fae72e9cc89a
--- /dev/null
+++ b/graphics/imlib2-jxl/pkg-descr
@@ -0,0 +1,10 @@
+This is a loader for imlib2 that adds support for reading and writing
+JPEG XL files. This lets you view them using feh, for example. It
+relies on libjxl for encoding and decoding the images.
+
+All JPEG XL files are supported, with the following limitations:
+* All images are internally converted to ARGB with 8 bits per sample,
+ in an sRGB colorspace - this is a limitation of imlib2.
+* For animated JXLs, only the first frame is decoded.
+
+WWW: https://github.com/alistair7/imlib2-jxl