aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEdward Tomasz Napierala <trasz@FreeBSD.org>2008-03-04 12:18:18 +0000
committerEdward Tomasz Napierala <trasz@FreeBSD.org>2008-03-04 12:18:18 +0000
commite6e05aaaf54a4a25123966449444365809a1cf3e (patch)
treed09c94bee46b2b2adb6e69f07d8c4112ef60fc34
parentf3556c9e419ff8ab6817fdc1945efdff82e28264 (diff)
downloadports-e6e05aaaf54a4a25123966449444365809a1cf3e.tar.gz
ports-e6e05aaaf54a4a25123966449444365809a1cf3e.zip
- Update to 2.7.1.
Notes
Notes: svn path=/head/; revision=208427
-rw-r--r--audio/ripperx/Makefile7
-rw-r--r--audio/ripperx/distinfo6
-rw-r--r--audio/ripperx/files/patch-src-Makefile.in11
-rw-r--r--audio/ripperx/files/patch-src-config_rw.c12
-rw-r--r--audio/ripperx/files/patch-src-ripper_encoder_manipulation.c24
-rw-r--r--audio/ripperx/pkg-plist3
6 files changed, 37 insertions, 26 deletions
diff --git a/audio/ripperx/Makefile b/audio/ripperx/Makefile
index 2c2a98e369a6..2320636c1345 100644
--- a/audio/ripperx/Makefile
+++ b/audio/ripperx/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= ripperx
-PORTVERSION= 2.7.0
-PORTREVISION= 1
+PORTVERSION= 2.7.1
CATEGORIES= audio
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ripperx
@@ -20,7 +19,9 @@ LIB_DEPENDS= id3:${PORTSDIR}/audio/id3lib
RUN_DEPENDS= cdparanoia:${PORTSDIR}/audio/cdparanoia
GNU_CONFIGURE= yes
+CFLAGS+= -L${LOCALBASE}/lib
USE_GMAKE= yes
-USE_GNOME= gtk12
+USE_GNOME= gtk20 gnomehack
+MAN1= ripperX.1
.include <bsd.port.mk>
diff --git a/audio/ripperx/distinfo b/audio/ripperx/distinfo
index b6cfeab2e12c..42317407afa3 100644
--- a/audio/ripperx/distinfo
+++ b/audio/ripperx/distinfo
@@ -1,3 +1,3 @@
-MD5 (ripperX-2.7.0.tar.gz) = bf69f2cbfb52551ac18e713e9894f306
-SHA256 (ripperX-2.7.0.tar.gz) = af97a0e0951bd6cb7f72e3d0f3c1effbb17832102aac4c5a75910ff2bbca0b7e
-SIZE (ripperX-2.7.0.tar.gz) = 172818
+MD5 (ripperX-2.7.1.tar.gz) = 3cc768935654dd71d82e36ebd277f060
+SHA256 (ripperX-2.7.1.tar.gz) = 50fe2e9c82ad7536c14bef78969bd140bf0937acbe27b9039953efaa3e76cd5f
+SIZE (ripperX-2.7.1.tar.gz) = 486377
diff --git a/audio/ripperx/files/patch-src-Makefile.in b/audio/ripperx/files/patch-src-Makefile.in
deleted file mode 100644
index 46c3c892e304..000000000000
--- a/audio/ripperx/files/patch-src-Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/Makefile.in.orig Wed Jan 3 20:11:27 2007
-+++ src/Makefile.in Wed Jan 3 20:11:33 2007
-@@ -11,7 +11,7 @@
-
- CC = @CC@
- CFLAGS = @CFLAGS@
--LDFLAGS = @LDFLAGS@ @LIBS@ -lutil -lid3
-+LDFLAGS = @LDFLAGS@ @LIBS@ -lutil -lid3 -lstdc++
- INSTALL = @INSTALL@
-
- CFILES = main.c\
diff --git a/audio/ripperx/files/patch-src-config_rw.c b/audio/ripperx/files/patch-src-config_rw.c
index af918d87bef3..c292b0367de1 100644
--- a/audio/ripperx/files/patch-src-config_rw.c
+++ b/audio/ripperx/files/patch-src-config_rw.c
@@ -1,14 +1,14 @@
---- src/config_rw.c.orig Wed Jan 3 20:37:27 2007
-+++ src/config_rw.c Wed Jan 3 20:38:12 2007
-@@ -84,9 +84,9 @@
+--- src/config_rw.c.orig 2008-01-28 06:00:09.000000000 +0100
++++ src/config_rw.c 2008-02-21 19:01:31.000000000 +0100
+@@ -87,9 +87,9 @@
{ "Encoder::Plugin", config.encoder.plugin,
STRING, 0, "ripperX_plugin-lame" },
{ "CdPlayer::Play_command", config.cd_player.play_command,
-- STRING, 0, "cdplay play %" },
+- STRING, 0, "cdplay %" },
+ STRING, 0, "cdcontrol play %" },
{ "CdPlayer::Stop_command", config.cd_player.stop_command,
-- STRING, 0, "cdplay stop" },
+- STRING, 0, "cdstop" },
+ STRING, 0, "cdcontrol stop" },
{ "WavPlayer::Command", config.wav_player.command,
- STRING, 0, "splay %" },
+ STRING, 0, "play %" },
{ "Mp3Player::Command", config.mp3_player.command,
diff --git a/audio/ripperx/files/patch-src-ripper_encoder_manipulation.c b/audio/ripperx/files/patch-src-ripper_encoder_manipulation.c
index d8ad8cbb587d..1e5866004572 100644
--- a/audio/ripperx/files/patch-src-ripper_encoder_manipulation.c
+++ b/audio/ripperx/files/patch-src-ripper_encoder_manipulation.c
@@ -1,6 +1,6 @@
---- src/ripper_encoder_manipulation.c.orig Tue Dec 26 22:16:04 2006
-+++ src/ripper_encoder_manipulation.c Tue Dec 26 22:16:17 2006
-@@ -11,7 +11,6 @@
+--- src/ripper_encoder_manipulation.c.orig 2008-02-02 18:51:29.000000000 +0100
++++ src/ripper_encoder_manipulation.c 2008-02-22 16:15:16.000000000 +0100
+@@ -16,7 +16,6 @@
#include <fcntl.h>
#include <sys/wait.h>
#include <sys/ioctl.h>
@@ -8,3 +8,21 @@
#include "ripper_encoder_manipulation.h"
#include "misc_utils.h"
+@@ -335,7 +334,7 @@
+ dup2( pty_fd0, 0 );
+ dup2( tty_fd1, 1 );
+
+- setpgrp();
++ setpgid(0, 0);
+ execvp( plugin_argv[ 0 ], plugin_argv );
+
+ dup2( stderr_fd, 2 );
+@@ -368,7 +367,7 @@
+ dup2( tty_fd0, 1 );
+ dup2( tty_fd0, 2 );
+
+- setpgrp();
++ setpgid(0, 0);
+ execvp( program_argv[ 0 ], program_argv );
+
+ dup2( stderr_fd, 2 );
diff --git a/audio/ripperx/pkg-plist b/audio/ripperx/pkg-plist
index 230ca31a4905..78381a8751cd 100644
--- a/audio/ripperx/pkg-plist
+++ b/audio/ripperx/pkg-plist
@@ -11,3 +11,6 @@ bin/ripperX_plugin-mp3enc
bin/ripperX_plugin-oggenc
bin/ripperX_plugin-flac
bin/ripperX_plugin-toolame
+bin/ripperX_plugin-musepack
+bin/ripperX_plugin_tester
+libdata/pkgconfig/ripperX.pc