aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-05-13 11:27:25 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-05-13 11:39:10 +0000
commite742e9fc52dcc50a9d48bfd7c8689f6617c7471a (patch)
tree7d073ec1f1d30ad0dd1d03ea2100620f54e5f016
parent48947271f6016500a4cfc241bb557e07a9e07005 (diff)
downloadports-e742e9fc52dcc50a9d48bfd7c8689f6617c7471a.tar.gz
ports-e742e9fc52dcc50a9d48bfd7c8689f6617c7471a.zip
security/py-argon2-cffi-bindings: Add py-argon2-cffi-bindings 21.2.0
argon2-cffi-bindings provides low-level CFFI bindings to the Argon2 password hashing algorithm including a vendored version of them. WWW: https://github.com/hynek/argon2-cffi-bindings
-rw-r--r--security/Makefile1
-rw-r--r--security/py-argon2-cffi-bindings/Makefile36
-rw-r--r--security/py-argon2-cffi-bindings/distinfo3
-rw-r--r--security/py-argon2-cffi-bindings/pkg-descr4
4 files changed, 44 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 0bbae56783c1..43213c26d58f 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -822,6 +822,7 @@
SUBDIR += py-ailment
SUBDIR += py-angr
SUBDIR += py-argon2-cffi
+ SUBDIR += py-argon2-cffi-bindings
SUBDIR += py-artifacts
SUBDIR += py-asyncssh
SUBDIR += py-authlib
diff --git a/security/py-argon2-cffi-bindings/Makefile b/security/py-argon2-cffi-bindings/Makefile
new file mode 100644
index 000000000000..97f9eab6f125
--- /dev/null
+++ b/security/py-argon2-cffi-bindings/Makefile
@@ -0,0 +1,36 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+
+PORTNAME= argon2-cffi-bindings
+PORTVERSION= 21.2.0
+CATEGORIES= security python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Low-level CFFI bindings for Argon2
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cffi>=1.0.1:devel/py-cffi@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}setuptools_scm>=6.2:devel/py-setuptools_scm@${PY_FLAVOR}
+LIB_DEPENDS= libargon2.so:security/libargon2
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cffi>=1.0.1:devel/py-cffi@${PY_FLAVOR}
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>=0,1:devel/py-pytest@${PY_FLAVOR}
+
+USES= localbase python:3.6+
+USE_PYTHON= autoplist concurrent distutils
+
+MAKE_ENV= ARGON2_CFFI_USE_SYSTEM=1
+
+post-patch:
+# Clean up bundled libraries
+ @${RM} -r ${WRKSRC}/extras/
+
+post-install:
+ ${FIND} ${STAGEDIR}${PYTHON_SITELIBDIR} -name '*.so' -exec ${STRIP_CMD} {} +
+
+do-test:
+ cd ${WRKSRC} && ${SETENV} PYTHONPATH=${STAGEDIR}${PYTHON_SITELIBDIR} ${PYTHON_CMD} -m pytest -rs -v
+
+.include <bsd.port.mk>
diff --git a/security/py-argon2-cffi-bindings/distinfo b/security/py-argon2-cffi-bindings/distinfo
new file mode 100644
index 000000000000..e8e1573db616
--- /dev/null
+++ b/security/py-argon2-cffi-bindings/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1652122533
+SHA256 (argon2-cffi-bindings-21.2.0.tar.gz) = bb89ceffa6c791807d1305ceb77dbfacc5aa499891d2c55661c6459651fc39e3
+SIZE (argon2-cffi-bindings-21.2.0.tar.gz) = 1779911
diff --git a/security/py-argon2-cffi-bindings/pkg-descr b/security/py-argon2-cffi-bindings/pkg-descr
new file mode 100644
index 000000000000..8ebdf73c3aa5
--- /dev/null
+++ b/security/py-argon2-cffi-bindings/pkg-descr
@@ -0,0 +1,4 @@
+argon2-cffi-bindings provides low-level CFFI bindings to the Argon2 password
+hashing algorithm including a vendored version of them.
+
+WWW: https://github.com/hynek/argon2-cffi-bindings