aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Engberg <diizzy@FreeBSD.org>2023-04-27 10:16:02 +0000
committerDaniel Engberg <diizzy@FreeBSD.org>2023-04-27 12:01:43 +0000
commite7617d92c598c78e58423cc26e7351815ac3fad2 (patch)
treec72020538d803356364bd59465f816c0a774777c
parent216705c9f4294c38fc76ae306d37c833218155ff (diff)
multimedia/motion: Move to FFmpeg 4
Fails to build with FFmpeg 6 PR: 270295 Approved by: 270194 Sponsored by: Blinkinblox
-rw-r--r--multimedia/motion/Makefile10
1 files changed, 8 insertions, 2 deletions
diff --git a/multimedia/motion/Makefile b/multimedia/motion/Makefile
index 7db84987c47a..3ea18cac70c9 100644
--- a/multimedia/motion/Makefile
+++ b/multimedia/motion/Makefile
@@ -28,6 +28,11 @@ USE_RC_SUBR= ${PORTNAME}
GNU_CONFIGURE= yes
+CFLAGS+= -I${LOCALBASE}/ffmpeg4/include
+LDFLAGS+= -L${LOCALBASE}/ffmpeg4/lib
+CONFIGURE_ENV+= PKG_CONFIG_PATH="${LOCALBASE}/ffmpeg4/libdata/pkgconfig"
+MAKE_ENV+= PKG_CONFIG_PATH="${LOCALBASE}/ffmpeg4/libdata/pkgconfig"
+
# Standard bsd.port.mk variables
SUB_FILES= pkg-message
@@ -55,8 +60,9 @@ VIDEO_DESC= Video capture driver (Netcam support only if none selected)
WEBCAMD_DESC= Webcams using webcamd
BKTR_CONFIGURE_WITH= bktr
-FFMPEG_LIB_DEPENDS= libavformat.so:multimedia/ffmpeg
-FFMPEG_CONFIGURE_ON= --with-ffmpeg=${LOCALBASE}
+
+FFMPEG_LIB_DEPENDS= libavformat.so.58:multimedia/ffmpeg4
+FFMPEG_CONFIGURE_ON= --with-ffmpeg=${LOCALBASE}/ffmpeg4
FFMPEG_CONFIGURE_OFF= --without-ffmpeg
MYSQL_USES= mysql