aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2024-04-17 18:16:28 +0000
committerJan Beich <jbeich@FreeBSD.org>2024-04-17 18:30:12 +0000
commite77e727c8846067f8095dae4810bc108a2ca32a1 (patch)
tree2e77e29bc493d765f2c417b12f9d5430acb97e0e
parent484cdffa84dd9b2f693fc0696c646b6bb614c9cb (diff)
downloadports-e77e727c8846067f8095dae4810bc108a2ca32a1.tar.gz
ports-e77e727c8846067f8095dae4810bc108a2ca32a1.zip
x11-wm/hyprland: convert to cmake:indirect
-rw-r--r--x11-wm/hyprland/Makefile6
1 files changed, 2 insertions, 4 deletions
diff --git a/x11-wm/hyprland/Makefile b/x11-wm/hyprland/Makefile
index 46a06fbb62e0..0b1d86d828b5 100644
--- a/x11-wm/hyprland/Makefile
+++ b/x11-wm/hyprland/Makefile
@@ -10,8 +10,7 @@ WWW= https://hyprland.org/
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
-BUILD_DEPENDS= cmake:devel/cmake-core \
- evdev-proto>0:devel/evdev-proto \
+BUILD_DEPENDS= evdev-proto>0:devel/evdev-proto \
wayland-protocols>=1.25:graphics/wayland-protocols
LIB_DEPENDS= libhyprlang.so:devel/hyprlang \
libtomlplusplus.so:devel/tomlplusplus \
@@ -22,7 +21,7 @@ LIB_DEPENDS= libhyprlang.so:devel/hyprlang \
libinput.so:x11/libinput \
libxkbcommon.so:x11/libxkbcommon
-USES= compiler:c++11-lib gl gnome meson pkgconfig xorg
+USES= cmake:indirect compiler:c++11-lib gl gnome meson pkgconfig xorg
USE_GITHUB= yes
USE_GL= egl opengl
USE_GNOME= cairo pango
@@ -99,7 +98,6 @@ update-hash:
USES+= llvm:min=16,build,export
PATH:= ${LLVM_PREFIX}/bin:${PATH} # XXX _CMAKE_TOOLCHAIN_SUFFIX vs. devel/llvm*
CONFIGURE_ENV+= CC="${CC}" CXX="${CXX}" CPP="${CPP}"
-CMAKE_BIN= ${LOCALBASE}/bin/cmake
# XXX Move into separate port and standardize via USES
GH_TUPLE+= llvm:llvm-project:llvmorg-16.0.1:libcxx