aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2022-04-27 13:22:04 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2022-04-27 13:22:04 +0000
commite7af5e32b40796da3f0c252941d5f427f7519234 (patch)
treeeeca0c9f1285fdf91c5c69a9eee51725fd8c8ce2
parentcf150ef9e2f6547b609c43a05365b66d8f5f5104 (diff)
downloadports-e7af5e32b40796da3f0c252941d5f427f7519234.tar.gz
ports-e7af5e32b40796da3f0c252941d5f427f7519234.zip
biology/hhsuite: check for omp.h on all architectures
-rw-r--r--biology/hhsuite/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/biology/hhsuite/Makefile b/biology/hhsuite/Makefile
index b0c6425e0e19..0c655ea1561a 100644
--- a/biology/hhsuite/Makefile
+++ b/biology/hhsuite/Makefile
@@ -20,6 +20,12 @@ GH_PROJECT= hh-suite
LDFLAGS+= -Wl,-rpath,${LOCALBASE}/mpi/openmpi/lib -L${LOCALBASE}/mpi/openmpi/lib -lmpi # force linking to openmpi, and not to mpich
+.if !exists(/usr/include/omp.h)
+PLIST_SUB+= OPENMP="@comment "
+.else
+PLIST_SUB+= OPENMP=""
+.endif
+
.include <bsd.port.options.mk>
.if ${ARCH} == aarch64
@@ -30,10 +36,4 @@ CMAKE_ON= HAVE_SSE2
CMAKE_ON= HAVE_POWER8
.endif
-.if ${ARCH} == powerpc
-PLIST_SUB+= OPENMP="@comment "
-.else
-PLIST_SUB+= OPENMP=""
-.endif
-
.include <bsd.port.mk>