aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2011-06-21 16:30:22 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2011-06-21 16:30:22 +0000
commite80845eff218aee98c7578e038f70f4f3c92553a (patch)
treef038a785cac7911638991b4f81820b9e2d17f679
parent2b3a95fed8de8a5b9c6875c53e199a4663ec999f (diff)
downloadports-e80845eff218aee98c7578e038f70f4f3c92553a.tar.gz
ports-e80845eff218aee98c7578e038f70f4f3c92553a.zip
Add upstream patch to fix build with !gcc
Submitted by: Raphael Kubo da Costa via area51
Notes
Notes: svn path=/head/; revision=276007
-rw-r--r--x11/qimageblitz/files/patch-blitz-CMakeLists.txt13
1 files changed, 13 insertions, 0 deletions
diff --git a/x11/qimageblitz/files/patch-blitz-CMakeLists.txt b/x11/qimageblitz/files/patch-blitz-CMakeLists.txt
new file mode 100644
index 000000000000..8864943edb16
--- /dev/null
+++ b/x11/qimageblitz/files/patch-blitz-CMakeLists.txt
@@ -0,0 +1,13 @@
+Index: blitz/CMakeLists.txt
+===================================================================
+--- blitz/CMakeLists.txt (revision 1203425)
++++ blitz/CMakeLists.txt (revision 1203426)
+@@ -33,7 +33,7 @@
+ if(NOT APPLE AND NOT WIN32)
+ set( blitz_LIB_SRCS ${blitz_LIB_SRCS} asm_scale.S )
+ add_custom_command(OUTPUT ${CMAKE_CURRENT_BINARY_DIR}/asm_scale.o
+- COMMAND gcc -c ${CMAKE_CURRENT_SOURCE_DIR}/asm_scale.S
++ COMMAND ${CMAKE_C_COMPILER} -c ${CMAKE_CURRENT_SOURCE_DIR}/asm_scale.S
+ DEPENDS ${CMAKE_CURRENT_SOURCE_DIR}/asm_scale.S )
+ set( blitz_LIB_EXTRA_SRCS ${CMAKE_CURRENT_BINARY_DIR}/asm_scale.o )
+ set(HAVE_EXTERNAL_ASM TRUE)