aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRuslan Makhmatkhanov <rm@FreeBSD.org>2013-02-18 18:22:10 +0000
committerRuslan Makhmatkhanov <rm@FreeBSD.org>2013-02-18 18:22:10 +0000
commite8ac1da70e84e02d9acbcb6f487628e1675fad5f (patch)
tree7b21dda1ebfc906d1fb420d121761cc9559b68e6
parent806174181bc82566f0178b0fc58ac444a3c3dd79 (diff)
downloadports-e8ac1da70e84e02d9acbcb6f487628e1675fad5f.tar.gz
ports-e8ac1da70e84e02d9acbcb6f487628e1675fad5f.zip
- fix build with newer math/gmp in ports tree. Newer versions of gmp do not
define __gmp_const. This patch addresses the compile time errors with an ifndef. while here: - trim Makefile header - remove indefinite article from COMMENT - remove deprecated attribution from pkg-descr and make tab -> space change in WWW field PR: 176229 Submitted by: Timothy Beyer <beyert@cs.ucr.edu> Approved by: maintainer (implicit, because the port was broken)
Notes
Notes: svn path=/head/; revision=312515
-rw-r--r--lang/mlton/Makefile8
-rw-r--r--lang/mlton/files/patch-runtime_gc_int-inf.c13
-rw-r--r--lang/mlton/pkg-descr4
3 files changed, 16 insertions, 9 deletions
diff --git a/lang/mlton/Makefile b/lang/mlton/Makefile
index e57b00e64ee4..85fedba9c679 100644
--- a/lang/mlton/Makefile
+++ b/lang/mlton/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: mlton
-# Date created: 1 Oct 2002
-# Whom: Stephen Weeks <sweeks@sweeks.com>
-#
+# Created by: Stephen Weeks <sweeks@sweeks.com>
# $FreeBSD$
-#
# Because MLton is written in SML, it needs an SML compiler to build.
# It is easiest to use another (earlier) binary version of MLton as
@@ -22,7 +18,7 @@ EXTRACT_ONLY= ${SRC_DIST}
# Other maintainer is Geoffrey Mainland (mainland@apeiron.net)
MAINTAINER= jesper.louis.andersen@gmail.com
-COMMENT= An optimizing Standard ML compiler
+COMMENT= Optimizing Standard ML compiler
LIB_DEPENDS= gmp.10:${PORTSDIR}/math/gmp
RUN_DEPENDS= bash:${PORTSDIR}/shells/bash
diff --git a/lang/mlton/files/patch-runtime_gc_int-inf.c b/lang/mlton/files/patch-runtime_gc_int-inf.c
new file mode 100644
index 000000000000..fd325e159ead
--- /dev/null
+++ b/lang/mlton/files/patch-runtime_gc_int-inf.c
@@ -0,0 +1,13 @@
+--- runtime/gc/int-inf.c.orig 2010-06-11 06:35:14.000000000 -0700
++++ runtime/gc/int-inf.c 2013-02-17 15:45:47.000000000 -0800
+@@ -6,6 +6,10 @@
+ * See the file MLton-LICENSE for details.
+ */
+
++#ifndef __gmp_const
++# define __gmp_const const
++#endif
++
+ /*
+ * Test if a intInf is a fixnum.
+ */ \ No newline at end of file
diff --git a/lang/mlton/pkg-descr b/lang/mlton/pkg-descr
index 8896cab1a7fa..ddbd83db8504 100644
--- a/lang/mlton/pkg-descr
+++ b/lang/mlton/pkg-descr
@@ -4,6 +4,4 @@ code, has a fast C FFI, profiling, and many useful libraries,
including an interface to the GNU multiprecision library. For more
information, go to the MLton home page.
-WWW: http://mlton.org/
-
-Stephen Weeks <sweeks@sweeks.com>
+WWW: http://mlton.org/