aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2021-09-01 11:46:22 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2021-09-01 11:46:24 +0000
commite9148ce0453ccc8db5af73084b56eaaa914f07e3 (patch)
treedb82b0ac60499732bb740a65055eaf9bfa970259
parente7ae31e2b9f1e56082369105f0c224a41a5de1e6 (diff)
downloadports-e9148ce0453ccc8db5af73084b56eaaa914f07e3.tar.gz
ports-e9148ce0453ccc8db5af73084b56eaaa914f07e3.zip
Cleanup: for ports under s* categories, drop redundant GH_* knobs.
-rw-r--r--science/py-pydicom/Makefile1
-rw-r--r--security/ct-submit/Makefile8
-rw-r--r--security/git-secret/Makefile1
-rw-r--r--security/gost-engine/Makefile8
-rw-r--r--security/openvpn-auth-ldap/Makefile7
-rw-r--r--security/pam_script/Makefile9
-rw-r--r--security/sedutil/Makefile2
-rw-r--r--sysutils/boot-extract/Makefile2
-rw-r--r--sysutils/cbsd-mq-api/Makefile2
-rw-r--r--sysutils/cbsd-mq-router/Makefile2
-rw-r--r--sysutils/containerd/Makefile2
-rw-r--r--sysutils/direnv/Makefile2
-rw-r--r--sysutils/dnf/Makefile1
-rw-r--r--sysutils/dtc/Makefile6
-rw-r--r--sysutils/ftwin/Makefile7
-rw-r--r--sysutils/fusefs-xfuse/Makefile1
-rw-r--r--sysutils/ganglia-webfrontend/Makefile1
-rw-r--r--sysutils/hatop/Makefile1
-rw-r--r--sysutils/ioc/Makefile5
-rw-r--r--sysutils/mackerel-agent/Makefile1
-rw-r--r--sysutils/nvme-cli/Makefile6
-rw-r--r--sysutils/oc/Makefile1
-rw-r--r--sysutils/openzfs-kmod/Makefile1
-rw-r--r--sysutils/openzfs/Makefile1
-rw-r--r--sysutils/pax-utils/Makefile2
-rw-r--r--sysutils/pc-networkmanager/Makefile1
-rw-r--r--sysutils/py-python-nomad/Makefile7
-rw-r--r--sysutils/py-tarsnapper/Makefile1
-rw-r--r--sysutils/sensu-go/Makefile1
-rw-r--r--sysutils/terraform-docs/Makefile5
-rw-r--r--sysutils/trueos-libqt5/Makefile1
-rw-r--r--sysutils/xdu/Makefile1
32 files changed, 21 insertions, 76 deletions
diff --git a/science/py-pydicom/Makefile b/science/py-pydicom/Makefile
index e643a158a57c..6cac80651cfa 100644
--- a/science/py-pydicom/Makefile
+++ b/science/py-pydicom/Makefile
@@ -13,7 +13,6 @@ LICENSE= MIT
USES= python:3.6+ shebangfix
USE_GITHUB= yes
-GH_ACCOUNT= pydicom
USE_PYTHON= distutils autoplist
NO_ARCH= yes
diff --git a/security/ct-submit/Makefile b/security/ct-submit/Makefile
index 408455d22745..01b669e0b6c1 100644
--- a/security/ct-submit/Makefile
+++ b/security/ct-submit/Makefile
@@ -11,12 +11,10 @@ COMMENT= Submission utility for transparency logs
LICENSE= ISCL
LICENSE_FILE= ${WRKSRC}/LICENSE
-USES= go
-
+USES= go
USE_GITHUB= yes
-GH_ACCOUNT= grahamedgecombe
-GH_PROJECT= ct-submit
-GH_TAGNAME= 7bb2541
+GH_ACCOUNT= grahamedgecombe
+GH_TAGNAME= 7bb2541
PLIST_FILES= bin/ct-submit
diff --git a/security/git-secret/Makefile b/security/git-secret/Makefile
index 562eef4c8222..d2352facb264 100644
--- a/security/git-secret/Makefile
+++ b/security/git-secret/Makefile
@@ -12,7 +12,6 @@ RUN_DEPENDS= bash:shells/bash gawk:lang/gawk git:devel/git gpg2:security/gnupg
USE_GITHUB= yes
GH_ACCOUNT= sobolevn
-GH_PROJECT= git-secret
GH_TAGNAME= 94d5ae4
NO_ARCH= yes
diff --git a/security/gost-engine/Makefile b/security/gost-engine/Makefile
index de9320035037..efe3f8160bce 100644
--- a/security/gost-engine/Makefile
+++ b/security/gost-engine/Makefile
@@ -15,17 +15,15 @@ BROKEN_SSL_REASON_libressl= needs features only available in OpenSSL 1.1.1+
BROKEN_SSL_REASON_libressl-devel=needs features only available in OpenSSL 1.1.1+
USES= cmake ssl
+USE_GITHUB= yes
+GH_PROJECT= engine
+GH_TAGNAME= 7ed64cd
ENGINESDIR?= ${PREFIX}/lib/engines-1.1
CMAKE_ARGS+= -DOPENSSL_ROOT_DIR=${OPENSSLBASE} \
-DOPENSSL_ENGINES_DIR=${ENGINESDIR}
-USE_GITHUB= yes
-GH_ACCOUNT= gost-engine
-GH_PROJECT= engine
-GH_TAGNAME= 7ed64cd
-
SUB_FILES= pkg-message
OPTIONS_DEFINE= DOCS
diff --git a/security/openvpn-auth-ldap/Makefile b/security/openvpn-auth-ldap/Makefile
index efc9758af4cb..fddd09bfd5a2 100644
--- a/security/openvpn-auth-ldap/Makefile
+++ b/security/openvpn-auth-ldap/Makefile
@@ -21,7 +21,8 @@ BUILD_DEPENDS= re2c:devel/re2c \
# appears to document issues on some systems when --with-openssl
# is missing.
USES= autoreconf objc ssl tar:xz
-
+USE_GITHUB= yes
+GH_ACCOUNT= threerings
GNU_CONFIGURE= yes
USE_OPENLDAP= yes
CONFIGURE_ARGS+= --with-openldap=${LOCALBASE} \
@@ -29,10 +30,6 @@ CONFIGURE_ARGS+= --with-openldap=${LOCALBASE} \
--with-objc-runtime=GNU \
--with-openssl=${OPENSSLBASE}
-USE_GITHUB= yes
-GH_ACCOUNT= threerings
-GH_PROJECT= openvpn-auth-ldap
-
PORTDOCS= README
PORTEXAMPLES= auth-ldap.conf
PLIST_FILES= lib/openvpn-auth-ldap.so
diff --git a/security/pam_script/Makefile b/security/pam_script/Makefile
index af693265ec7d..8f13569b83f3 100644
--- a/security/pam_script/Makefile
+++ b/security/pam_script/Makefile
@@ -9,16 +9,13 @@ COMMENT= PAM script module allows to hook user space scripts on PAM events
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/COPYING
-USES= autoreconf libtool shebangfix
+USES= autoreconf libtool shebangfix
+GNU_CONFIGURE= yes
USE_GITHUB= yes
-
-SHEBANG_FILES= etc/tally
-
GH_ACCOUNT= jeroennijhof
-GH_PROJECT= pam_script
GH_TAGNAME= 1.1.9
+SHEBANG_FILES= etc/tally
-GNU_CONFIGURE= yes
PATCHDIR= ${.CURDIR}/files
do-install:
diff --git a/security/sedutil/Makefile b/security/sedutil/Makefile
index 577a4dbbff79..862927bca0e0 100644
--- a/security/sedutil/Makefile
+++ b/security/sedutil/Makefile
@@ -8,10 +8,8 @@ COMMENT= Self Encrypting Drive utility
LICENSE= GPLv3+
USES= gmake pkgconfig
-
USE_GITHUB= yes
GH_ACCOUNT= kendmerry
-GH_PROJECT= sedutil
GH_TAGNAME= 3122ba0
BUILD_WRKSRC= ${WRKSRC}/freebsd/CLI
diff --git a/sysutils/boot-extract/Makefile b/sysutils/boot-extract/Makefile
index 25db6f63f213..821253dbdc4a 100644
--- a/sysutils/boot-extract/Makefile
+++ b/sysutils/boot-extract/Makefile
@@ -8,10 +8,8 @@ COMMENT= Android Boot image extraction tool
LICENSE= GPLv2
USES= gmake
-
USE_GITHUB= yes
GH_ACCOUNT= csimmonds
-GH_PROJECT= boot-extract
GH_TAGNAME= 486995f
PLIST_FILES= bin/boot-extract
diff --git a/sysutils/cbsd-mq-api/Makefile b/sysutils/cbsd-mq-api/Makefile
index 1dd9d2fef92d..b73bd6e44c23 100644
--- a/sysutils/cbsd-mq-api/Makefile
+++ b/sysutils/cbsd-mq-api/Makefile
@@ -8,10 +8,8 @@ COMMENT= Simplified API for creating and destroying CBSD virtual environments
LICENSE= BSD2CLAUSE
USES= go
-
USE_GITHUB= yes
GH_ACCOUNT= cbsd
-GH_PROJECT= cbsd-mq-api
GH_TUPLE= beanstalkd:go-beanstalk:3bed00be7a17:beanstalkd/src/github.com/beanstalkd/go-beanstalk \
gorilla:mux:d07530f46e1e:gorilla_mux/vendor/github.com/gorilla/mux \
golang:crypto:5ff15b29337e:golang_crypto/vendor/golang.org/x/crypto
diff --git a/sysutils/cbsd-mq-router/Makefile b/sysutils/cbsd-mq-router/Makefile
index b2fd501d4c3f..32fb1dfad860 100644
--- a/sysutils/cbsd-mq-router/Makefile
+++ b/sysutils/cbsd-mq-router/Makefile
@@ -10,10 +10,8 @@ LICENSE= BSD2CLAUSE
RUN_DEPENDS= beanstalkd:net/beanstalkd
USES= go
-
USE_GITHUB= yes
GH_ACCOUNT= cbsd
-GH_PROJECT= cbsd-mq-router
USE_RC_SUBR= cbsd-mq-router
PLIST_FILES= bin/cbsd-mq-router "@sample etc/cbsd-mq-router.json.sample"
diff --git a/sysutils/containerd/Makefile b/sysutils/containerd/Makefile
index 6e66cd4ead87..4f3c4c94ffdd 100644
--- a/sysutils/containerd/Makefile
+++ b/sysutils/containerd/Makefile
@@ -13,9 +13,7 @@ BUILD_DEPENDS= bash:shells/bash \
go:lang/go
USES= cpe gmake
-
USE_GITHUB= yes
-GH_ACCOUNT= containerd
GH_SUBDIR= src/github.com/containerd/containerd
CPE_VENDOR= linuxfoundation
diff --git a/sysutils/direnv/Makefile b/sysutils/direnv/Makefile
index 5914a51e44e7..aa8ec532f9ef 100644
--- a/sysutils/direnv/Makefile
+++ b/sysutils/direnv/Makefile
@@ -12,9 +12,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= bash:shells/bash
USES= gmake go:modules
-
USE_GITHUB= yes
-GH_ACCOUNT= direnv
GH_SUBDIR= src/github.com/direnv/direnv
MAKE_ENV= GOPATH=${WRKSRC}
MAKEFILE= GNUmakefile
diff --git a/sysutils/dnf/Makefile b/sysutils/dnf/Makefile
index 3a2ed4337748..eb5a905166cd 100644
--- a/sysutils/dnf/Makefile
+++ b/sysutils/dnf/Makefile
@@ -16,7 +16,6 @@ RUN_DEPENDS= libcomps>0:misc/libcomps \
USES= cmake gettext-tools python
USE_GITHUB= yes
GH_ACCOUNT= rpm-software-management
-GH_PROJECT= dnf
CMAKE_OFF= FREEBSD_INSTALL_DOC
CMAKE_ARGS= -DPYTHON_DESIRED=${PYTHON_MAJOR_VER}
diff --git a/sysutils/dtc/Makefile b/sysutils/dtc/Makefile
index c4a3250ab70f..3091ee08bc8e 100644
--- a/sysutils/dtc/Makefile
+++ b/sysutils/dtc/Makefile
@@ -14,16 +14,14 @@ LICENSE= GPLv2
LIB_DEPENDS= libyaml.so:textproc/libyaml
USES= bison compiler:c11 gmake pkgconfig shebangfix
+USE_GITHUB= yes
+GH_ACCOUNT= dgibson
USE_LDCONFIG= yes
SHEBANG_FILES= dtdiff
TEST_TARGET= check
TEST_ENV= STATSZ="stat -f %Uz"
-USE_GITHUB= yes
-GH_ACCOUNT= dgibson
-GH_PROJECT= dtc
-
MAKE_ARGS+= PREFIX=${PREFIX} NO_PYTHON=yes \
INSTALL_PROGRAM="${INSTALL_PROGRAM}" \
INSTALL_LIB="${INSTALL_LIB}"
diff --git a/sysutils/ftwin/Makefile b/sysutils/ftwin/Makefile
index 80194bf72180..1785b21b6c87 100644
--- a/sysutils/ftwin/Makefile
+++ b/sysutils/ftwin/Makefile
@@ -16,14 +16,11 @@ LIB_DEPENDS= libapr-1.so:devel/apr1 \
libpuzzle.so:graphics/libpuzzle
USES= autoreconf bdb libarchive pkgconfig tar:bzip2
-
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-archive=${LOCALBASE}
USE_GITHUB= yes
GH_ACCOUNT= fpesce
-GH_PROJECT= ftwin
GH_TAGNAME= 3355fd9
-
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-archive=${LOCALBASE}
MAKE_ARGS= CFLAGS="${CFLAGS}"
PORTDOCS= AUTHORS EXAMPLES TODO CHANGES KNOWN_BUGS VERSION README
diff --git a/sysutils/fusefs-xfuse/Makefile b/sysutils/fusefs-xfuse/Makefile
index 03f1d85da0e2..015d63eb349c 100644
--- a/sysutils/fusefs-xfuse/Makefile
+++ b/sysutils/fusefs-xfuse/Makefile
@@ -15,7 +15,6 @@ USES= cargo fuse
USE_GITHUB= yes
GH_ACCOUNT= KhaledEmaraDev
-GH_PROJECT= xfuse
GH_TAGNAME= 9c8824
CARGO_CRATES= ansi_term-0.11.0 \
diff --git a/sysutils/ganglia-webfrontend/Makefile b/sysutils/ganglia-webfrontend/Makefile
index 4126715b5690..790a05c7d193 100644
--- a/sysutils/ganglia-webfrontend/Makefile
+++ b/sysutils/ganglia-webfrontend/Makefile
@@ -13,7 +13,6 @@ RUN_DEPENDS= ${LOCALBASE}/sbin/gmond:sysutils/ganglia-monitor-core
USES= php:web
USE_GITHUB= yes
-GH_ACCOUNT= ganglia
GH_PROJECT= ganglia-web
USE_PHP= filter gd session xml
diff --git a/sysutils/hatop/Makefile b/sysutils/hatop/Makefile
index 4de7eba3ed31..4356f25f7c5a 100644
--- a/sysutils/hatop/Makefile
+++ b/sysutils/hatop/Makefile
@@ -15,7 +15,6 @@ RUN_DEPENDS= ${LOCALBASE}/sbin/haproxy:net/haproxy
USES= python shebangfix
USE_GITHUB= yes
GH_ACCOUNT= jhunt
-GH_PROJECT= hatop
SHEBANG_FILES= bin/hatop
NO_ARCH= yes
diff --git a/sysutils/ioc/Makefile b/sysutils/ioc/Makefile
index aa7124e7d2c7..c48b1adf21db 100644
--- a/sysutils/ioc/Makefile
+++ b/sysutils/ioc/Makefile
@@ -15,16 +15,13 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}click>0:devel/py-click@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}texttable>0:textproc/py-texttable@${PY_FLAVOR}
USES= python:3.6+
-
USE_GITHUB= yes
GH_ACCOUNT= bsdci
-GH_PROJECT= ioc
+USE_RC_SUBR= ioc
NO_ARCH= yes
NO_BUILD= yes
-USE_RC_SUBR= ioc
-
post-patch:
@${REINPLACE_CMD} -e "s#LIB_DIR =.*#LIB_DIR = \"${PREFIX}/lib/ioc\"#" ${WRKSRC}/bin/ioc
diff --git a/sysutils/mackerel-agent/Makefile b/sysutils/mackerel-agent/Makefile
index d1be9a3458c9..196c7a4a26f2 100644
--- a/sysutils/mackerel-agent/Makefile
+++ b/sysutils/mackerel-agent/Makefile
@@ -14,7 +14,6 @@ USE_RC_SUBR= mackerel_agent
USE_GITHUB= yes
GH_ACCOUNT= mackerelio
-GH_PROJECT= mackerel-agent
GH_TUPLE= \
BurntSushi:toml:v0.3.1:burntsushi_toml/vendor/github.com/BurntSushi/toml \
Djarvur:go-err113:aea10b59be24:djarvur_go_err113/vendor/github.com/Djarvur/go-err113 \
diff --git a/sysutils/nvme-cli/Makefile b/sysutils/nvme-cli/Makefile
index 170a8a3520f6..ad0aab3a4900 100644
--- a/sysutils/nvme-cli/Makefile
+++ b/sysutils/nvme-cli/Makefile
@@ -15,12 +15,10 @@ ONLY_FOR_ARCHS= amd64
BROKEN_FreeBSD_11= Uses newer API than in 11.x
USES= gmake
-
-PLIST_FILES= sbin/nvme
-
USE_GITHUB= yes
GH_ACCOUNT= bsdimp
-GH_PROJECT= nvme-cli
GH_TAGNAME= c92d871
+PLIST_FILES= sbin/nvme
+
.include <bsd.port.mk>
diff --git a/sysutils/oc/Makefile b/sysutils/oc/Makefile
index 565a703c72a9..4ad31ac9a925 100644
--- a/sysutils/oc/Makefile
+++ b/sysutils/oc/Makefile
@@ -23,7 +23,6 @@ PLIST_FILES= bin/oc
USE_GITHUB= yes
GH_ACCOUNT= openshift
-GH_PROJECT= oc
GH_SUBDIR= src/github.com/openshift/oc
GIT_COMMIT= ddd7170fca667fef6397f5f27f7a5a41d7769b75
diff --git a/sysutils/openzfs-kmod/Makefile b/sysutils/openzfs-kmod/Makefile
index cf9884c5ab7d..bdcc19845418 100644
--- a/sysutils/openzfs-kmod/Makefile
+++ b/sysutils/openzfs-kmod/Makefile
@@ -13,7 +13,6 @@ BROKEN_i386= build fails
USES= cpe kmod
USE_GITHUB= yes
-GH_ACCOUNT= openzfs
GH_PROJECT= zfs
GH_TAGNAME= 7eebcd2be
KMODTARGET?= openzfs.ko
diff --git a/sysutils/openzfs/Makefile b/sysutils/openzfs/Makefile
index 47f047dad966..880604355d5d 100644
--- a/sysutils/openzfs/Makefile
+++ b/sysutils/openzfs/Makefile
@@ -24,7 +24,6 @@ TESTS_DESC= Install the ZFS Test Suite
OPTIONS_SUB= yes
USE_GITHUB= yes
-GH_ACCOUNT= openzfs
GH_PROJECT= zfs
GH_TAGNAME= 7eebcd2be
diff --git a/sysutils/pax-utils/Makefile b/sysutils/pax-utils/Makefile
index d07648321cc3..54d3289ebbe8 100644
--- a/sysutils/pax-utils/Makefile
+++ b/sysutils/pax-utils/Makefile
@@ -15,9 +15,7 @@ BUILD_DEPENDS= xmlto:textproc/xmlto
USES= gmake tar:xz
USE_GITHUB= yes
-
GH_ACCOUNT= gentoo
-GH_PROJECT= pax-utils
PLIST_FILES= bin/dumpelf \
bin/pspax \
diff --git a/sysutils/pc-networkmanager/Makefile b/sysutils/pc-networkmanager/Makefile
index dacb0a5fa167..71a85b655fb9 100644
--- a/sysutils/pc-networkmanager/Makefile
+++ b/sysutils/pc-networkmanager/Makefile
@@ -27,7 +27,6 @@ QMAKE_ARGS= CONFIG+="configure"
USE_GITHUB= yes
GH_ACCOUNT= trueos
-GH_PROJECT= pc-networkmanager
GH_TAGNAME= ae50abf3ba522a7685f275157455f6d424453bb2
.include <bsd.port.mk>
diff --git a/sysutils/py-python-nomad/Makefile b/sysutils/py-python-nomad/Makefile
index 18ca58c04a6d..e538b9d422b8 100644
--- a/sysutils/py-python-nomad/Makefile
+++ b/sysutils/py-python-nomad/Makefile
@@ -12,12 +12,9 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}requests>=2.20.0:www/py-requests@${PY_FLAVOR}
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}requests>=2.20.0:www/py-requests@${PY_FLAVOR}
-USES= python:3.3+
-
+USES= python
USE_GITHUB= yes
GH_ACCOUNT= jrxFive
-GH_PROJECT= python-nomad
-
-USE_PYTHON= distutils autoplist
+USE_PYTHON= autoplist distutils
.include <bsd.port.mk>
diff --git a/sysutils/py-tarsnapper/Makefile b/sysutils/py-tarsnapper/Makefile
index b62c0fc06a06..6d6b631716b2 100644
--- a/sysutils/py-tarsnapper/Makefile
+++ b/sysutils/py-tarsnapper/Makefile
@@ -16,7 +16,6 @@ USE_PYTHON= distutils autoplist
USE_GITHUB= yes
GH_ACCOUNT= miracle2k
-GH_PROJECT= tarsnapper
RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}argparse>0:devel/py-argparse@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}dateutil>0:devel/py-dateutil@${PY_FLAVOR} \
diff --git a/sysutils/sensu-go/Makefile b/sysutils/sensu-go/Makefile
index 41256b7e47a3..1d680c070ef9 100644
--- a/sysutils/sensu-go/Makefile
+++ b/sysutils/sensu-go/Makefile
@@ -13,7 +13,6 @@ BUILD_DEPENDS= bash:shells/bash
USES= go
USE_GITHUB= yes
-GH_PROJECT= sensu-go
GH_ACCOUNT= sensu
GO_PKGNAME= github.com/${GH_ACCOUNT}/${GH_PROJECT}
diff --git a/sysutils/terraform-docs/Makefile b/sysutils/terraform-docs/Makefile
index 540715390af9..61d7f7b4e348 100644
--- a/sysutils/terraform-docs/Makefile
+++ b/sysutils/terraform-docs/Makefile
@@ -9,11 +9,8 @@ COMMENT= Generate documentation from Terraform modules
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
-USES= go:modules
-
+USES= go:modules
USE_GITHUB= yes
-GH_ACCOUNT= terraform-docs
-
GH_TUPLE= \
BurntSushi:toml:v0.3.1:burntsushi_toml/vendor/github.com/BurntSushi/toml \
agext:levenshtein:v1.2.2:agext_levenshtein/vendor/github.com/agext/levenshtein \
diff --git a/sysutils/trueos-libqt5/Makefile b/sysutils/trueos-libqt5/Makefile
index fbfef8aae029..c121cd4622a5 100644
--- a/sysutils/trueos-libqt5/Makefile
+++ b/sysutils/trueos-libqt5/Makefile
@@ -27,7 +27,6 @@ QMAKE_ARGS= CONFIG+="configure"
USE_GITHUB= yes
GH_ACCOUNT= trueos
-GH_PROJECT= trueos-libqt5
GH_TAGNAME= 9e92b465d823185c9b96f2017e06f2a06b6143fa
.include <bsd.port.mk>
diff --git a/sysutils/xdu/Makefile b/sysutils/xdu/Makefile
index eef8541aacc0..a7e8bc98ffe6 100644
--- a/sysutils/xdu/Makefile
+++ b/sysutils/xdu/Makefile
@@ -10,7 +10,6 @@ COMMENT= Graphically display output of du
USE_GITHUB= yes
GH_ACCOUNT= vlasovskikh
-GH_PROJECT= xdu
USES= imake xorg
USE_XORG= ice sm x11 xaw xext xmu xpm xt