aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2011-02-13 21:10:33 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2011-02-13 21:10:33 +0000
commite92a8be79995da4e43004b558e4b69b2adb97f7a (patch)
tree3f96bc645135ad786867a73116ac664b37847b4a
parent1b7b99fc38cc23e756be332091c75ff20a382da2 (diff)
downloadports-e92a8be79995da4e43004b558e4b69b2adb97f7a.tar.gz
ports-e92a8be79995da4e43004b558e4b69b2adb97f7a.zip
Update to 2.13.4.
* Check for duplicate MANx macros [1] * Add a warning if the wrong CPAN URL is used for the WWW URL [2] * Remove an obsolete CPAN warning [3] PR: 154069 [1] 154149 [2] 154724 [3] Submitted by: skreuzer [2] milki@rescomp.berkeley.edu [3]
Notes
Notes: svn path=/head/; revision=269095
-rw-r--r--ports-mgmt/portlint/Makefile2
-rw-r--r--ports-mgmt/portlint/src/portlint.pl23
2 files changed, 14 insertions, 11 deletions
diff --git a/ports-mgmt/portlint/Makefile b/ports-mgmt/portlint/Makefile
index 898b393dbd0d..faf9415f691e 100644
--- a/ports-mgmt/portlint/Makefile
+++ b/ports-mgmt/portlint/Makefile
@@ -8,7 +8,7 @@
#
PORTNAME= portlint
-PORTVERSION= 2.13.3
+PORTVERSION= 2.13.4
CATEGORIES= ports-mgmt
MASTER_SITES= # none
DISTFILES= # none
diff --git a/ports-mgmt/portlint/src/portlint.pl b/ports-mgmt/portlint/src/portlint.pl
index 6cc821277aa0..a551e6ee40d9 100644
--- a/ports-mgmt/portlint/src/portlint.pl
+++ b/ports-mgmt/portlint/src/portlint.pl
@@ -17,7 +17,7 @@
# OpenBSD and NetBSD will be accepted.
#
# $FreeBSD$
-# $MCom: portlint/portlint.pl,v 1.207 2011/01/10 04:42:45 marcus Exp $
+# $MCom: portlint/portlint.pl,v 1.211 2011/02/13 21:09:18 marcus Exp $
#
use strict;
@@ -52,7 +52,7 @@ $portdir = '.';
# version variables
my $major = 2;
my $minor = 13;
-my $micro = 3;
+my $micro = 4;
sub l { '[{(]'; }
sub r { '[)}]'; }
@@ -636,6 +636,10 @@ sub checkdescr {
&perror("WARN", $file, -1, "WWW URL, $wwwurl should begin ".
"with \"http://\" or \"https://\".");
}
+ if ($wwwurl =~ m|^http://search.cpan.org/~|) {
+ &perror("WARN", $file, -1, "consider changing WWW URL to ".
+ "http://search.cpan.org/dist/$makevar{PORTNAME}");
+ }
}
$linecnt++;
$longlines++ if ($maxchars{$file} < length);
@@ -2523,14 +2527,6 @@ DIST_SUBDIR EXTRACT_ONLY
}
- if ($makevar{MASTER_SITE_SUBDIR}) {
- print "OK: Checking MASTER_SITE_SUBDIR.\n" if ($verbose);
- if ($makevar{MASTER_SITE_SUBDIR} =~ m|\.\./*authors|) {
- &perror("WARN", $file, -1, "MASTER_SITE_SUBDIR uses ../authors ".
- "SUBDIR. Use one of the MASTER_SITE*CPAN macros instead.");
- }
- }
-
$pkg_version = $makevar{PKG_VERSION};
if ($makevar{CONFLICTS}) {
@@ -2890,6 +2886,13 @@ FETCH_DEPENDS DEPENDS_TARGET
}
foreach my $i (split(//, $manchapters)) {
next if ($i eq '');
+ print "XXX: Checking MAN $i\n";
+ my @mansecs = grep(/MAN\U$i\E=\s*(.*)/, split(/\n/, $tmp));
+ if (scalar @mansecs > 1) {
+ &perror("FATAL", $file, -1, "duplicate MAN$i macro. ".
+ "Only the last MAN$i macro will be processed. Use ".
+ "MAN$i+=... instead to append man pages.");
+ }
if ($tmp =~ /MAN\U$i\E=\s*([^\n]*)\n/) {
@mman = grep($_ !~ /^\s*$/, split(/\s+/, $1));
@pman = grep($_ !~ /^\s*$/,