aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEric Camachat <eric@camachat.org>2023-04-03 07:27:34 +0000
committerFernando ApesteguĂ­a <fernape@FreeBSD.org>2023-04-05 05:38:52 +0000
commite933541b2131d644ce243630544bcf210fb4be84 (patch)
treeb27f87df7eb936dc2b81aa4b245f14fed8d3889c
parent1ad04ed2aeb34b6fa3c1021ad40ef5d2d558032e (diff)
downloadports-e933541b2131d644ce243630544bcf210fb4be84.tar.gz
ports-e933541b2131d644ce243630544bcf210fb4be84.zip
devel/samurai: Fix if LOCALBASE is not /usr/local
PR: 270590 Reported by: eric@camachat.org
-rw-r--r--devel/samurai/Makefile1
-rw-r--r--devel/samurai/files/patch-Makefile10
2 files changed, 8 insertions, 3 deletions
diff --git a/devel/samurai/Makefile b/devel/samurai/Makefile
index 089286118fff..04044a4c8118 100644
--- a/devel/samurai/Makefile
+++ b/devel/samurai/Makefile
@@ -1,5 +1,6 @@
PORTNAME= samurai
DISTVERSION= 1.2-16
+PORTREVISION= 1
DISTVERSIONSUFFIX= -gca5a6ba
CATEGORIES= devel
#MASTER_SITES= https://github.com/michaelforney/samurai/releases/download/${DISTVERSION}/
diff --git a/devel/samurai/files/patch-Makefile b/devel/samurai/files/patch-Makefile
index 3e5b39578c0d..2945261336bd 100644
--- a/devel/samurai/files/patch-Makefile
+++ b/devel/samurai/files/patch-Makefile
@@ -1,7 +1,11 @@
---- Makefile.orig 2020-12-17 01:31:33 UTC
+--- Makefile.orig 2021-04-10 18:44:40 UTC
+++ Makefile
-@@ -3,7 +3,7 @@
- PREFIX=/usr/local
+@@ -1,10 +1,10 @@
+ .POSIX:
+ .PHONY: all install clean
+
+-PREFIX=/usr/local
++PREFIX=${LOCALBASE}
BINDIR=$(PREFIX)/bin
MANDIR=$(PREFIX)/share/man
-ALL_CFLAGS=$(CFLAGS) -std=c99 -Wall -Wextra -Wpedantic -Wno-unused-parameter