aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2024-02-29 12:36:19 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2024-02-29 12:52:38 +0000
commite942ad46900f623ba33c901d1be1fcdc4bcb1f06 (patch)
treece67bbd8bfd41c8b21b3bd72046a4c5aa51a9608
parent93f7319162b5723f1f9db8365e83fdde414609ea (diff)
www/cgichk: Remove expired port
www/cgichk
-rw-r--r--MOVED1
-rw-r--r--www/Makefile1
-rw-r--r--www/cgichk/Makefile28
-rw-r--r--www/cgichk/distinfo2
-rw-r--r--www/cgichk/files/patch-Makefile11
-rw-r--r--www/cgichk/files/patch-cgichk.c56
-rw-r--r--www/cgichk/files/patch-cgichk.h37
-rw-r--r--www/cgichk/files/patch-config.c19
-rw-r--r--www/cgichk/files/patch-misc.c32
-rw-r--r--www/cgichk/files/patch-net.c45
-rw-r--r--www/cgichk/pkg-descr2
-rw-r--r--www/cgichk/pkg-plist2
12 files changed, 1 insertions, 235 deletions
diff --git a/MOVED b/MOVED
index 1232488582bd..658be9dbbdb5 100644
--- a/MOVED
+++ b/MOVED
@@ -3029,3 +3029,4 @@ security/fl0p||2024-02-29|Has expired: Abandonware, last release in 2006 and no
security/libzrtpcppcore||2024-02-29|Has expired: Obscure protocol that never got any traction, superseded by SRTP
security/pbc||2024-02-29|Has expired: Abandonware, last release in 2013 and no development since
security/poly1305aes||2024-02-29|Has expired: Fails to build on Tier 1 and most other platforms
+www/cgichk||2024-02-29|Has expired: Deprecated utility that checks a list of URLs and lacks HTTPS support
diff --git a/www/Makefile b/www/Makefile
index abd8f1dd9a23..c0ad78b5d5da 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -97,7 +97,6 @@
SUBDIR += cgi-lib
SUBDIR += cgi-lib.pl
SUBDIR += cgicc
- SUBDIR += cgichk
SUBDIR += cgiwrap
SUBDIR += checkbot
SUBDIR += chems
diff --git a/www/cgichk/Makefile b/www/cgichk/Makefile
deleted file mode 100644
index d65143f96867..000000000000
--- a/www/cgichk/Makefile
+++ /dev/null
@@ -1,28 +0,0 @@
-PORTNAME= cgichk
-PORTVERSION= 2.60
-PORTREVISION= 1
-CATEGORIES= www
-MASTER_SITES= https://BSDforge.com/projects/source/www/cgichk/
-
-LICENSE= GPLv2
-
-MAINTAINER= ports@FreeBSD.org
-COMMENT= Web site vulnerability scanner
-
-DEPRECATED= Deprecated utility that checks a list of URLs and lacks HTTPS support
-EXPIRATION_DATE=2024-02-29
-
-WRKSRC= ${WRKDIR}/${PORTNAME}
-ALL_TARGET= cgichk
-
-post-patch:
- ${REINPLACE_CMD} -e "s/^(CC|CFLAGS).+//g" ${WRKSRC}/Makefile
- ${REINPLACE_CMD} -e \
- "s@/etc/@${PREFIX}/etc/@g; s/#include <getopt.h>//g;" \
- ${WRKSRC}/cgichk.h
-
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/cgichk ${STAGEDIR}${PREFIX}/bin
- ${INSTALL_DATA} ${WRKSRC}/cgichk.cfg ${STAGEDIR}${PREFIX}/etc/cgichk.cfg.sample
-
-.include <bsd.port.mk>
diff --git a/www/cgichk/distinfo b/www/cgichk/distinfo
deleted file mode 100644
index 8cd4496a84f3..000000000000
--- a/www/cgichk/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-SHA256 (cgichk-2.60.tar.gz) = 4d52fd7692c65eb1e4e009982f29eac1e0d98714418c0f16d4d41de5de181e62
-SIZE (cgichk-2.60.tar.gz) = 15972
diff --git a/www/cgichk/files/patch-Makefile b/www/cgichk/files/patch-Makefile
deleted file mode 100644
index b3c8ec69a982..000000000000
--- a/www/cgichk/files/patch-Makefile
+++ /dev/null
@@ -1,11 +0,0 @@
---- Makefile.orig 2011-09-06 11:10:37.000000000 +0800
-+++ Makefile 2011-09-06 11:10:42.000000000 +0800
-@@ -1,7 +1,7 @@
- # Where cgichk goes when user decides to install
- INSTALLDIR=/usr/local/bin
-
--CC = gcc
-+CC ?= gcc
- OPTIONS = $(WINCRAP)
- CFLAGS = -O2 -s $(OPTIONS)
- OUTPUT = cgichk
diff --git a/www/cgichk/files/patch-cgichk.c b/www/cgichk/files/patch-cgichk.c
deleted file mode 100644
index 3061c03f19db..000000000000
--- a/www/cgichk/files/patch-cgichk.c
+++ /dev/null
@@ -1,56 +0,0 @@
---- cgichk.c.orig 2001-04-06 16:36:25.000000000 +0800
-+++ cgichk.c 2011-09-06 11:29:49.000000000 +0800
-@@ -58,7 +58,7 @@ void check_dir_only()
- CPRINT(" \r");
- CPRINT(" Looking for /%s\r", r->v[count]);
-
-- if (result = http_has(temp,0))
-+ if ((result = http_has(temp,0)))
- {
- CPRINT(" \r");
- PRINT(" Found /%s (%d) \n", r->v[count], result);
-@@ -77,7 +77,7 @@ void check_hole(char *hole)
- CPRINT(" \r");
- CPRINT(" Looking for %s\r", hole);
-
-- if (result = http_has(hole,0))
-+ if ((result = http_has(hole,0)))
- {
- CPRINT(" \r");
- PRINT(" Found %s (%d)\n",hole, result);
-@@ -131,7 +131,7 @@ void check_interest()
-
- CPRINT(" Looking for /%s \r", r->v[y]);
-
-- if (result = http_has(temp,0)) // See if the directory exists, so no wasted time
-+ if ((result = http_has(temp,0))) // See if the directory exists, so no wasted time
- {
- PRINT(" Found %s (%d) \n", temp, result);
- BEEP();
-@@ -144,7 +144,7 @@ void check_interest()
- CPRINT(" \r");
- CPRINT(" Looking for /%s \r", temp);
-
-- if (result = http_has(temp,0))
-+ if ((result = http_has(temp,0)))
- {
- PRINT(" ---> /%s (%d)\n", temp, result);
- BEEP();
-@@ -289,7 +289,7 @@ void get_commandline(int argc, char *arg
-
- parms.URL = (char*) strdup(argv[optind]);
-
-- breakup_url(parms.URL, domain, 1024, &parms.port, 80, dir, 1024);
-+ breakup_url(parms.URL, domain, 1024, (int *)&parms.port, 80, dir, 1024);
- }
- /*----------------------------------------------------------------*/
- void mainloop()
-@@ -343,7 +343,7 @@ int main(int argc, char *argv[])
- {
- char *env = NULL;
-
-- if (env = getenv(PROXY_ENV))
-+ if ((env = getenv(PROXY_ENV)))
- {
- proxy.host = (char *) malloc(strlen(env));
- breakup_url(env, proxy.host, strlen(env), &proxy.port, 8000, NULL, 0);
diff --git a/www/cgichk/files/patch-cgichk.h b/www/cgichk/files/patch-cgichk.h
deleted file mode 100644
index 4bf9b8e455d7..000000000000
--- a/www/cgichk/files/patch-cgichk.h
+++ /dev/null
@@ -1,37 +0,0 @@
---- cgichk.h.orig 2001-04-06 16:36:25.000000000 +0800
-+++ cgichk.h 2011-09-06 11:30:51.000000000 +0800
-@@ -19,13 +19,17 @@
-
- #include <stdio.h>
- #include <stdlib.h>
-+#include <string.h>
-+#include <sys/types.h>
- #include <sys/socket.h>
- #include <netinet/in.h>
-+#include <arpa/inet.h>
- #include <netdb.h>
- #include <stdarg.h>
- #include <getopt.h>
- #include <time.h>
- #include <unistd.h>
-+#include <ctype.h>
-
- #ifdef DEBUG
- #define MEMWATCH
-@@ -125,3 +129,16 @@ extern struct in_addr addr;
- extern struct sockaddr_in _sin;
- extern struct hostent *he;
-
-+void waitafew(unsigned int del);
-+void PRINT(char *arg, ...);
-+void CPRINT(char *arg, ...);
-+void close_config(result_t *r);
-+void read_config(result_t *r, char *section);
-+int setup_socket(char *host, int port);
-+void PerformWhois(char *domain);
-+result_t *open_config(char *fn);
-+void read_head();
-+int http_has(char *file, int result);
-+void free_strings(result_t *r);
-+void breakup_url(char *_url, char *_host, int hl, int *_port, int defport, char *_path, int pl);
-+char *cgichk_strnstr(const char *HAYSTACK, const char *NEEDLE);
diff --git a/www/cgichk/files/patch-config.c b/www/cgichk/files/patch-config.c
deleted file mode 100644
index 718d8cbc04c4..000000000000
--- a/www/cgichk/files/patch-config.c
+++ /dev/null
@@ -1,19 +0,0 @@
---- config.c.orig 2011-09-06 11:18:17.000000000 +0800
-+++ config.c 2011-09-06 11:18:33.000000000 +0800
-@@ -30,14 +30,14 @@ result_t *open_config(char *fn)
- }
-
- // ...try defaults, current dir...
-- if (r->F = fopen("./cgichk.cfg", "rb"))
-+ if ((r->F = fopen("./cgichk.cfg", "rb")))
- {
- resultfile = (char *) strdup("./cgichk.cfg");
- return r;
- }
-
- // ...and then config dir
-- if (r->F = fopen(CONFIG_PATH, "rb"))
-+ if ((r->F = fopen(CONFIG_PATH, "rb")))
- {
- resultfile = (char *) strdup(CONFIG_PATH);
- return r;
diff --git a/www/cgichk/files/patch-misc.c b/www/cgichk/files/patch-misc.c
deleted file mode 100644
index 57e5b17daa8f..000000000000
--- a/www/cgichk/files/patch-misc.c
+++ /dev/null
@@ -1,32 +0,0 @@
---- misc.c.orig 2001-04-06 16:36:25.000000000 +0800
-+++ misc.c 2011-09-06 11:17:27.000000000 +0800
-@@ -83,16 +83,16 @@ void breakup_url( char *_url,
-
- *_port = defport;
-
-- if ( t = (char *)strstr(u, "://") ) // skip past http bit
-+ if ((t = (char *)strstr(u, "://"))) // skip past http bit
- u = t + 3;
-
- // parse hostname and port
-
-- if (t = (char *)index(u, ':')) // does host have a port #?
-+ if ((t = (char *)index(u, ':'))) // does host have a port #?
- hasport = 1;
-
-- if (t = (char *)index(u, '/')) // does host have path?
-- (char *)haspath = 1;
-+ if ((t = (char *)index(u, '/'))) // does host have path?
-+ haspath = 1;
-
- if (hasport)
- t = (char *)index(u, ':');
-@@ -209,7 +209,7 @@ char *lowerstr(char *str)
- return str;
- }
- /*----------------------------------------------------------------*/
--char *strnstr(const char *HAYSTACK, const char *NEEDLE)
-+char *cgichk_strnstr(const char *HAYSTACK, const char *NEEDLE)
- {
- char *h, *n, *res;
-
diff --git a/www/cgichk/files/patch-net.c b/www/cgichk/files/patch-net.c
deleted file mode 100644
index 396a82092287..000000000000
--- a/www/cgichk/files/patch-net.c
+++ /dev/null
@@ -1,45 +0,0 @@
---- net.c.orig 2001-04-06 16:36:25.000000000 +0800
-+++ net.c 2011-09-06 11:35:01.000000000 +0800
-@@ -9,6 +9,7 @@ proxy_t proxy = {NULL, 8000};
- /*----------------------------------------------------------------*/
- int setup_socket(char *host, int port)
- {
-+ struct in_addr addr;
- unsigned long start;
- unsigned long end;
- unsigned long counter;
-@@ -24,8 +25,8 @@ int setup_socket(char *host, int port)
- }
-
- //start = inet_addr(host);
-- inet_aton(host, &start); // rather than inet_addr, etc.
-- counter = ntohl(start);
-+ inet_aton(host, &addr); // rather than inet_addr, etc.
-+ counter = ntohl(addr.s_addr);
-
- sock = socket(AF_INET, SOCK_STREAM, 0);
- bcopy(he->h_addr, (char *) &_sin.sin_addr, he->h_length);
-@@ -150,10 +151,10 @@ int http_has(char *file, int result)
- {
- if (parms.no_false_200_search == FALSE)
- {
-- if (strnstr(httpbuff, "file not found") ||
-- strnstr(httpbuff, "error 404") ||
-- strnstr(httpbuff, "document has moved") ||
-- strnstr(httpbuff, "page you have requested") ) // Wise?
-+ if (cgichk_strnstr(httpbuff, "file not found") ||
-+ cgichk_strnstr(httpbuff, "error 404") ||
-+ cgichk_strnstr(httpbuff, "document has moved") ||
-+ cgichk_strnstr(httpbuff, "page you have requested") ) // Wise?
- {
- err = HTTP_NOEXIST;
- }
-@@ -161,7 +162,7 @@ int http_has(char *file, int result)
- // If user spcified an additional string to search for, check for that too.
- if (parms.alt_fake_404_string)
- {
-- if (strnstr(httpbuff, parms.alt_fake_404_string))
-+ if (cgichk_strnstr(httpbuff, parms.alt_fake_404_string))
- {
- err = HTTP_NOEXIST;
- }
diff --git a/www/cgichk/pkg-descr b/www/cgichk/pkg-descr
deleted file mode 100644
index 38e8fc631b92..000000000000
--- a/www/cgichk/pkg-descr
+++ /dev/null
@@ -1,2 +0,0 @@
-cgichk is a security utility which can scan web sites for potential
-vulnerabilities.
diff --git a/www/cgichk/pkg-plist b/www/cgichk/pkg-plist
deleted file mode 100644
index be9bd9e4fd92..000000000000
--- a/www/cgichk/pkg-plist
+++ /dev/null
@@ -1,2 +0,0 @@
-bin/cgichk
-@sample etc/cgichk.cfg.sample