aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicola Vitale <nivit@FreeBSD.org>2022-12-05 13:28:40 +0000
committerNicola Vitale <nivit@FreeBSD.org>2022-12-05 13:31:19 +0000
commite94cfe13757e0cd1fc20bf1e4f182881666935dd (patch)
treea837bba0b26f136e00f585a98f9383378e3fbc63
parentc62a96fb1a5e1e798ac30d775a4ce6f73a097c91 (diff)
downloadports-e94cfe13757e0cd1fc20bf1e4f182881666935dd.tar.gz
ports-e94cfe13757e0cd1fc20bf1e4f182881666935dd.zip
x11/gnome-pie: Update to 0.7.3
- Change LICENSE type [1] - Reorder variables in Makefile - Add new library dependencies - Fix shebang in the script that compiles locales - Fix behaviour of options NLS/MANPAGES/DOCS whe on/off - Update some patches Ref: https://github.com/Schneegans/Gnome-Pie/commit/9526a83c8cdc644828e4db8ecd9b832942939b44 [1]
-rw-r--r--x11/gnome-pie/Makefile44
-rw-r--r--x11/gnome-pie/distinfo5
-rw-r--r--x11/gnome-pie/files/patch-resources_gnome-pie.desktop (renamed from x11/gnome-pie/files/patch-resources__gnome-pie.desktop)2
-rw-r--r--x11/gnome-pie/files/patch-resources_locale_it_LC__MESSAGES_it.po47
-rw-r--r--x11/gnome-pie/files/patch-src_CMakeLists.txt46
-rw-r--r--x11/gnome-pie/files/patch-src__CMakeLists.txt43
-rw-r--r--x11/gnome-pie/files/patch-src__gui__themeList.vala11
-rw-r--r--x11/gnome-pie/files/patch-src__utilities__color.vala47
-rw-r--r--x11/gnome-pie/files/patch-src_actions_action.vala11
-rw-r--r--x11/gnome-pie/files/patch-src_actions_actionRegistry.vala (renamed from x11/gnome-pie/files/patch-src__actions__actionRegistry.vala)8
-rw-r--r--x11/gnome-pie/files/patch-src_gui_indicator.vala (renamed from x11/gnome-pie/files/patch-src__gui__indicator.vala)13
-rw-r--r--x11/gnome-pie/files/patch-src_utilities_bindingManager.vala (renamed from x11/gnome-pie/files/patch-src__utilities__bindingManager.vala)8
-rw-r--r--x11/gnome-pie/files/patch-src_utilities_paths.vala (renamed from x11/gnome-pie/files/patch-src__utilities__paths.vala)30
-rw-r--r--x11/gnome-pie/pkg-message (renamed from x11/gnome-pie/files/pkg-message.in)6
-rw-r--r--x11/gnome-pie/pkg-plist63
15 files changed, 208 insertions, 176 deletions
diff --git a/x11/gnome-pie/Makefile b/x11/gnome-pie/Makefile
index 319d06784764..d936b40d7240 100644
--- a/x11/gnome-pie/Makefile
+++ b/x11/gnome-pie/Makefile
@@ -1,51 +1,53 @@
PORTNAME= gnome-pie
-PORTVERSION= 0.5.7
+PORTVERSION= 0.7.3
DISTVERSIONPREFIX= v
-PORTREVISION= 4
CATEGORIES= x11
MAINTAINER= nivit@FreeBSD.org
COMMENT= Circular application launcher
WWW= https://schneegans.github.io/gnome-pie.html
-LICENSE= GPLv3+
+LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/COPYING
-RUN_DEPENDS= gnome-settings-daemon>=2.32.1_4:sysutils/gnome-settings-daemon
LIB_DEPENDS= libbamf3.so:sysutils/bamf \
libgee-0.8.so:devel/libgee \
+ libharfbuzz.so:print/harfbuzz \
libunique-1.0.so:x11-toolkits/unique
+RUN_DEPENDS= gnome-settings-daemon>=2.32.1_4:sysutils/gnome-settings-daemon
-USES= cmake gnome pkgconfig vala:build xorg
+USES= cmake desktop-file-utils gnome libarchive pkgconfig \
+ vala:build xorg
USE_GITHUB= yes
-USE_GNOME= cairo gnomemenus3 gtk30 librsvg2 libwnck3
-USE_XORG= xtst
-
-DOCS_CMAKE_ON= -DINSTALL_DOCS:BOOL=ON
-
GH_ACCOUNT= Simmesimme
GH_PROJECT= Gnome-Pie
+USE_GNOME= cairo gnomemenus3 gtk30 librsvg2 libwnck3 libxml2
+USE_XORG= x11 xtst
-MANPAGES_CMAKE_OFF= -DNO_INSTALL_MANPAGES:BOOL=ON
+SHEBANG_FILES= resources/locale/compile-po.sh
-NLS_CMAKE_BOOL= INSTALL_NLS
-NLS_USES= gettext
+REINPLACE_ARGS= -i ''
+PLIST_SUB= DESKTOPDIR=${DESKTOPDIR}
+OPTIONS_DEFINE= DOCS MANPAGES NLS
OPTIONS_DEFAULT= MANPAGES
-OPTIONS_DEFINE= DOCS MANPAGES NLS
-OPTIONS_SUB= yes
-
-PLIST_SUB= DESKTOPDIR=${DESKTOPDIR}
+OPTIONS_SUB= yes
-REINPLACE_ARGS= -i ''
+DOCS_CMAKE_BOOL= INSTALL_DOCS
+MANPAGES_CMAKE_BOOL= INSTALL_MANPAGES
+NLS_BUILD_DEPENDS= bash:shells/bash
+NLS_USES= gettext shebangfix
+NLS_CMAKE_BOOL= INSTALL_NLS
post-patch:
${REINPLACE_CMD} -e 's,%%DATADIR%%,${DATADIR},1' \
-e 's,%%DESKTOPDIR%%,${DESKTOPDIR},1' \
-e 's,%%PREFIX%%,${PREFIX},1' \
- -e '/has_resize_grip/d' ${WRKSRC}/src/actions/actionRegistry.vala \
+ ${WRKSRC}/src/actions/actionRegistry.vala \
${WRKSRC}/src/gui/indicator.vala \
- ${WRKSRC}/src/utilities/paths.vala \
- ${WRKSRC}/resources/ui/*.ui
+ ${WRKSRC}/src/utilities/paths.vala
+
+post-build-NLS-on:
+ (cd ${WRKSRC}/resources/locale && ./compile-po.sh)
.include <bsd.port.mk>
diff --git a/x11/gnome-pie/distinfo b/x11/gnome-pie/distinfo
index a157f79b745b..b610070ea68e 100644
--- a/x11/gnome-pie/distinfo
+++ b/x11/gnome-pie/distinfo
@@ -1,2 +1,3 @@
-SHA256 (Simmesimme-Gnome-Pie-v0.5.7_GH0.tar.gz) = 5eb9bcc95a15aee870d1411960383a88fa6275d6f3b35db07c2c76c7584a09de
-SIZE (Simmesimme-Gnome-Pie-v0.5.7_GH0.tar.gz) = 224405
+TIMESTAMP = 1669716529
+SHA256 (Simmesimme-Gnome-Pie-v0.7.3_GH0.tar.gz) = e5d35462d72a1418555deafd3219f62e68acb28b763a55929c89be992f9c0a85
+SIZE (Simmesimme-Gnome-Pie-v0.7.3_GH0.tar.gz) = 234119
diff --git a/x11/gnome-pie/files/patch-resources__gnome-pie.desktop b/x11/gnome-pie/files/patch-resources_gnome-pie.desktop
index 09394a3fa129..48a86cc97af6 100644
--- a/x11/gnome-pie/files/patch-resources__gnome-pie.desktop
+++ b/x11/gnome-pie/files/patch-resources_gnome-pie.desktop
@@ -1,4 +1,4 @@
---- resources/gnome-pie.desktop.orig 2015-01-23 11:49:05 UTC
+--- resources/gnome-pie.desktop.orig 2021-07-17 09:00:37 UTC
+++ resources/gnome-pie.desktop
@@ -4,5 +4,5 @@ Name=Gnome-Pie
Comment=Cakes don't lie.
diff --git a/x11/gnome-pie/files/patch-resources_locale_it_LC__MESSAGES_it.po b/x11/gnome-pie/files/patch-resources_locale_it_LC__MESSAGES_it.po
new file mode 100644
index 000000000000..bb274a27ed27
--- /dev/null
+++ b/x11/gnome-pie/files/patch-resources_locale_it_LC__MESSAGES_it.po
@@ -0,0 +1,47 @@
+--- resources/locale/it/LC_MESSAGES/it.po.orig 2021-07-17 09:00:37 UTC
++++ resources/locale/it/LC_MESSAGES/it.po
+@@ -21,7 +21,7 @@ msgstr ""
+
+ #: ../ui/pie_options.ui:53
+ msgid "Activation Settings"
+-msgstr "Impostazioni di attivazione""
++msgstr "Impostazioni di attivazione"
+
+ #: ../ui/pie_options.ui:153
+ msgid "Unamed Pie"
+@@ -248,8 +248,8 @@ msgid ""
+ "For manual and advanced configuration click on the plus sign."
+ msgstr "Inizia ad aggiungere fette! </ B> Questo può essere fatto trascinando roba nella "
+ "più il segno sotto. Puoi provare molto! Ad esempio, i lanciatori di applicazioni o"
+-"cartelle. Sono possibili anche gli URL del tuo browser ... \ n"
+-"\ N"
++"cartelle. Sono possibili anche gli URL del tuo browser...\n"
++"\n"
+ "Per la configurazione manuale e avanzata fare clic sul segno più."
+
+ #: ../ui/preferences.ui:655
+@@ -540,7 +540,7 @@ msgstr "_Inoformazioni su"
+
+ #: ../../src/gui/indicator.vala:150
+ msgid "_Quit"
+-msgstr _Abbandona"
++msgstr "_Abbandona"
+
+ #: ../../src/gui/newsWindow.vala:64
+ msgid "_Close"
+@@ -603,13 +603,13 @@ msgstr "Mezza torta"
+
+ #: ../../src/themes/theme.vala:169
+ msgid "Successfully exported the theme \"%s\"!"
+-msgstr "Esportato correttamente il tema \ "% s \"!"
++msgstr "Esportato correttamente il tema \"%s\"!"
+
+ #: ../../src/themes/theme.vala:176
+ msgid ""
+ "An error occurred while exporting the theme \"%s\"! Please check the console "
+ "output."
+-msgstr "Si è verificato un errore durante l'esportazione del tema \ "% s \"! Si prega di controllare la console "
++msgstr "Si è verificato un errore durante l'esportazione del tema \"%s\"! Si prega di controllare la console "
+ "Uscita."
+
+ #: ../../src/actionGroups/windowListGroup.vala:34
diff --git a/x11/gnome-pie/files/patch-src_CMakeLists.txt b/x11/gnome-pie/files/patch-src_CMakeLists.txt
new file mode 100644
index 000000000000..61b3e7cc6a8b
--- /dev/null
+++ b/x11/gnome-pie/files/patch-src_CMakeLists.txt
@@ -0,0 +1,46 @@
+--- src/CMakeLists.txt.orig 2021-07-17 09:00:37 UTC
++++ src/CMakeLists.txt
+@@ -27,6 +27,7 @@ install(
+ ${CMAKE_INSTALL_PREFIX}/bin
+ )
+
++if (INSTALL_DOCS)
+ # install credits
+ install(
+ FILES
+@@ -34,17 +35,21 @@ install(
+ DESTINATION
+ ${CMAKE_INSTALL_PREFIX}/share/doc/gnome-pie
+ )
++endif()
+
++if (INSTALL_NLS)
+ # install locales
+ install(
+ DIRECTORY
+ ${CMAKE_SOURCE_DIR}/resources/locale
+ DESTINATION
+ ${CMAKE_INSTALL_PREFIX}/share
++ PATTERN *.orig EXCLUDE
+ PATTERN *.po EXCLUDE
+ PATTERN *.pot EXCLUDE
+ PATTERN *.sh EXCLUDE
+ )
++endif()
+
+ # install themes
+ install(
+@@ -79,6 +84,7 @@ install(
+ ${CMAKE_INSTALL_PREFIX}/share/applications
+ )
+
++if (INSTALL_MANPAGES)
+ # install manpage
+ install(
+ FILES
+@@ -86,4 +92,5 @@ install(
+ DESTINATION
+ ${CMAKE_INSTALL_PREFIX}/share/man/man1
+ )
++endif()
+
diff --git a/x11/gnome-pie/files/patch-src__CMakeLists.txt b/x11/gnome-pie/files/patch-src__CMakeLists.txt
deleted file mode 100644
index abdeb06fd5a5..000000000000
--- a/x11/gnome-pie/files/patch-src__CMakeLists.txt
+++ /dev/null
@@ -1,43 +0,0 @@
---- src/CMakeLists.txt.orig 2015-01-23 11:49:05 UTC
-+++ src/CMakeLists.txt
-@@ -39,6 +39,7 @@ install(
- ${CMAKE_INSTALL_PREFIX}/bin
- )
-
-+if (INSTALL_DOCS)
- # install credits
- install(
- FILES
-@@ -46,7 +47,9 @@ install(
- DESTINATION
- ${CMAKE_INSTALL_PREFIX}/share/doc/gnome-pie
- )
-+endif()
-
-+if (INSTALL_NLS)
- # install locales
- install(
- DIRECTORY
-@@ -57,6 +60,7 @@ install(
- PATTERN *.pot EXCLUDE
- PATTERN *.sh EXCLUDE
- )
-+endif()
-
- # install themes
- install(
-@@ -91,11 +95,12 @@ install(
- ${CMAKE_INSTALL_PREFIX}/share/applications
- )
-
-+if (NOT NO_INSTALL_MANPAGES)
- # install manpage
- install(
- FILES
- ${CMAKE_SOURCE_DIR}/resources/gnome-pie.1
- DESTINATION
-- ${CMAKE_INSTALL_PREFIX}/share/man/man1
-+ ${CMAKE_INSTALL_PREFIX}/man/man1
- )
--
-+endif()
diff --git a/x11/gnome-pie/files/patch-src__gui__themeList.vala b/x11/gnome-pie/files/patch-src__gui__themeList.vala
deleted file mode 100644
index 2d83d49ceafb..000000000000
--- a/x11/gnome-pie/files/patch-src__gui__themeList.vala
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/gui/themeList.vala.orig 2015-01-23 11:49:05 UTC
-+++ src/gui/themeList.vala
-@@ -81,7 +81,7 @@ class ThemeList : Gtk.TreeView {
-
- this.on_select_new();
-
-- Config.global.theme.load();
-+ //Config.global.theme.load();
- Config.global.theme.load_images();
- return false;
- });
diff --git a/x11/gnome-pie/files/patch-src__utilities__color.vala b/x11/gnome-pie/files/patch-src__utilities__color.vala
deleted file mode 100644
index 21006e82db4a..000000000000
--- a/x11/gnome-pie/files/patch-src__utilities__color.vala
+++ /dev/null
@@ -1,47 +0,0 @@
---- src/utilities/color.vala.orig 2018-01-12 22:06:16.414101000 +0100
-+++ src/utilities/color.vala 2018-01-12 22:12:55.215652000 +0100
-@@ -41,7 +41,7 @@
- /////////////////////////////////////////////////////////////////////
-
- public Color() {
-- Color.from_rgb(1.0f, 1.0f, 1.0f);
-+ this.from_rgb(1.0f, 1.0f, 1.0f);
- }
-
- /////////////////////////////////////////////////////////////////////
-@@ -49,7 +49,7 @@
- /////////////////////////////////////////////////////////////////////
-
- public Color.from_rgb(float red, float green, float blue) {
-- Color.from_rgba(red, green, blue, 1.0f);
-+ this.from_rgba(red, green, blue, 1.0f);
- }
-
- /////////////////////////////////////////////////////////////////////
-@@ -68,7 +68,7 @@
- /////////////////////////////////////////////////////////////////////
-
- public Color.from_gdk(Gdk.RGBA color) {
-- Color.from_rgba(
-+ this.from_rgba(
- (float)color.red,
- (float)color.green,
- (float)color.blue,
-@@ -83,7 +83,7 @@
- public Color.from_string(string hex_string) {
- var color = Gdk.RGBA();
- color.parse(hex_string);
-- Color.from_gdk(color);
-+ this.from_gdk(color);
- }
-
- /////////////////////////////////////////////////////////////////////
-@@ -121,7 +121,7 @@
- }
- }
-
-- Color.from_rgb((float)(rtotal/total), (float)(gtotal/total), (float)(btotal/total));
-+ this.from_rgb((float)(rtotal/total), (float)(gtotal/total), (float)(btotal/total));
-
- if (s > 0.15f) s = 0.65f;
-
diff --git a/x11/gnome-pie/files/patch-src_actions_action.vala b/x11/gnome-pie/files/patch-src_actions_action.vala
deleted file mode 100644
index 710cc1200c1a..000000000000
--- a/x11/gnome-pie/files/patch-src_actions_action.vala
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/actions/action.vala.orig 2015-01-23 11:49:05 UTC
-+++ src/actions/action.vala
-@@ -63,7 +63,7 @@ public abstract class Action : GLib.Object {
- /// C'tor, initializes all members.
- /////////////////////////////////////////////////////////////////////
-
-- public Action(string name, string icon, bool is_quickaction) {
-+ Action(string name, string icon, bool is_quickaction) {
- GLib.Object(name : name, icon : icon, is_quickaction : is_quickaction);
- }
-
diff --git a/x11/gnome-pie/files/patch-src__actions__actionRegistry.vala b/x11/gnome-pie/files/patch-src_actions_actionRegistry.vala
index 1485eafb5edf..2526b6a3f5df 100644
--- a/x11/gnome-pie/files/patch-src__actions__actionRegistry.vala
+++ b/x11/gnome-pie/files/patch-src_actions_actionRegistry.vala
@@ -1,11 +1,11 @@
---- src/actions/actionRegistry.vala.orig 2015-01-23 11:49:05 UTC
+--- src/actions/actionRegistry.vala.orig 2021-07-17 09:00:37 UTC
+++ src/actions/actionRegistry.vala
-@@ -108,7 +108,7 @@ public class ActionRegistry : GLib.Objec
+@@ -114,7 +114,7 @@ public class ActionRegistry : GLib.Object {
case "application":
var file_name = uri.split("//")[1];
-
+
- var desktop_file = GLib.File.new_for_path("/usr/share/applications/" + file_name);
-+ var desktop_file = GLib.File.new_for_path("%%DATADIR%%/applications/" + file_name);
++ var desktop_file = GLib.File.new_for_path("%%DESKTOPDIR%%" + file_name);
if (desktop_file.query_exists())
return new_for_desktop_file(desktop_file.get_path());
diff --git a/x11/gnome-pie/files/patch-src__gui__indicator.vala b/x11/gnome-pie/files/patch-src_gui_indicator.vala
index fd478437973e..56739922550e 100644
--- a/x11/gnome-pie/files/patch-src__gui__indicator.vala
+++ b/x11/gnome-pie/files/patch-src_gui_indicator.vala
@@ -1,15 +1,15 @@
---- src/gui/indicator.vala.orig 2015-01-23 11:49:05 UTC
+--- src/gui/indicator.vala.orig 2021-07-17 09:00:37 UTC
+++ src/gui/indicator.vala
@@ -79,7 +79,7 @@ public class Indicator : GLib.Object {
- string path = "";
+ string path = "";
try {
- path = GLib.Path.get_dirname(GLib.FileUtils.read_link("/proc/self/exe"))+"/resources";
-+ path = "%%DATADIR%%/resources";
++ path = "%%DATADIR%%/resouces";
} catch (GLib.FileError e) {
warning("Failed to get path of executable!");
}
-@@ -90,10 +90,7 @@ public class Indicator : GLib.Object {
+@@ -91,11 +91,7 @@ public class Indicator : GLib.Object {
#else
this.indicator = new Gtk.StatusIcon();
try {
@@ -17,7 +17,8 @@
- GLib.Path.get_dirname(GLib.FileUtils.read_link("/proc/self/exe"))+"/resources",
- icon + ".svg"
- ));
-+ var file = GLib.File.new_for_path(GLib.Path.build_filename("%%PREFIX%%/share/icons/hicolor/scalable/apps/", icon + ".svg"));
-
+-
++ var file = GLib.File.new_for_path(GLib.Path.build_filename("%%PREFIX%%/share/icons/hicolor/scalable/apps/", icon + ".svg"));
if (!file.query_exists())
this.indicator.set_from_icon_name(icon);
+ else
diff --git a/x11/gnome-pie/files/patch-src__utilities__bindingManager.vala b/x11/gnome-pie/files/patch-src_utilities_bindingManager.vala
index 8c37885e90f5..aa2e12859774 100644
--- a/x11/gnome-pie/files/patch-src__utilities__bindingManager.vala
+++ b/x11/gnome-pie/files/patch-src_utilities_bindingManager.vala
@@ -1,6 +1,6 @@
---- src/utilities/bindingManager.vala.orig 2015-01-23 11:49:05 UTC
+--- src/utilities/bindingManager.vala.orig 2021-07-17 09:00:37 UTC
+++ src/utilities/bindingManager.vala
-@@ -228,12 +228,12 @@ public class BindingManager : GLib.Objec
+@@ -341,12 +341,12 @@ public class BindingManager : GLib.Object {
private Gdk.FilterReturn event_filter(Gdk.XEvent gdk_xevent, Gdk.Event gdk_event) {
@@ -15,5 +15,5 @@
- #endif
+ //#endif
- if(xevent->type == X.EventType.KeyPress) {
- foreach(var binding in bindings) {
+
+ if (xevent->type == X.EventType.KeyPress) {
diff --git a/x11/gnome-pie/files/patch-src__utilities__paths.vala b/x11/gnome-pie/files/patch-src_utilities_paths.vala
index c287e7cb1e2e..a46fd5a84e1a 100644
--- a/x11/gnome-pie/files/patch-src__utilities__paths.vala
+++ b/x11/gnome-pie/files/patch-src_utilities_paths.vala
@@ -1,6 +1,6 @@
---- src/utilities/paths.vala.orig 2015-02-10 20:42:17 UTC
+--- src/utilities/paths.vala.orig 2021-07-17 09:00:37 UTC
+++ src/utilities/paths.vala
-@@ -71,21 +71,21 @@ public class Paths : GLib.Object {
+@@ -70,21 +70,21 @@ public class Paths : GLib.Object {
/// usually /usr/share/gnome-pie/themes.
/////////////////////////////////////////////////////////////////////
@@ -25,39 +25,33 @@
/////////////////////////////////////////////////////////////////////
/// The autostart file of gnome-pie_config
-@@ -115,7 +115,7 @@ public class Paths : GLib.Object {
+@@ -136,7 +136,7 @@ public class Paths : GLib.Object {
// get path of executable
try {
- executable = GLib.File.new_for_path(GLib.FileUtils.read_link("/proc/self/exe")).get_path();
-+ executable = GLib.File.new_for_path("%%PREFIX%%/bin/gnome-pie").get_path();
++ executable = GLib.File.new_for_path("/usr/local/bin/gnome-pie").get_path();
} catch (GLib.FileError e) {
warning("Failed to get path of executable!");
}
-@@ -128,12 +128,12 @@ public class Paths : GLib.Object {
- Gtk.IconTheme.get_default().append_search_path(path);
- }
-
-- Gtk.IconTheme.get_default().append_search_path("/usr/share/pixmaps/");
-+ Gtk.IconTheme.get_default().append_search_path("%%LOCALBASE%%/share/pixmaps/");
+@@ -152,7 +152,7 @@ public class Paths : GLib.Object {
+ Gtk.IconTheme.get_default().append_search_path(GLib.Environment.get_home_dir() + ".icons");
// get global paths
- var default_dir = GLib.File.new_for_path("/usr/share/gnome-pie/");
+- var default_dir = GLib.File.new_for_path("/usr/share/gnome-pie/");
++ var default_dir = GLib.File.new_for_path("/usr/share/gnome-pie");
if(!default_dir.query_exists()) {
-- default_dir = GLib.File.new_for_path("/usr/local/share/gnome-pie/");
-+ default_dir = GLib.File.new_for_path("%%DATADIR%%/");
+ default_dir = GLib.File.new_for_path("/usr/local/share/gnome-pie/");
- if(!default_dir.query_exists()) {
- default_dir = GLib.File.new_for_path(GLib.Path.get_dirname(
-@@ -149,9 +149,9 @@ public class Paths : GLib.Object {
+@@ -170,9 +170,9 @@ public class Paths : GLib.Object {
if(locale_dir.query_exists()) {
locale_dir = GLib.File.new_for_path("/usr/share/locale");
} else {
- locale_dir = GLib.File.new_for_path("/usr/local/share/locale/de/LC_MESSAGES/gnomepie.mo");
-+ locale_dir = GLib.File.new_for_path("%%LOCALBASE%%/share/locale/de/LC_MESSAGES/gnomepie.mo");
++ locale_dir = GLib.File.new_for_path("%%PREFIX%%/share/locale/de/LC_MESSAGES/gnomepie.mo");
if(locale_dir.query_exists()) {
- locale_dir = GLib.File.new_for_path("/usr/local/share/locale");
-+ locale_dir = GLib.File.new_for_path("%%LOCALBASE%%/share/locale");
++ locale_dir = GLib.File.new_for_path("%%PREFIX%%/share/locale");
} else {
locale_dir = GLib.File.new_for_path(GLib.Path.get_dirname(
executable)).get_child("resources/locale/de/LC_MESSAGES/gnomepie.mo");
diff --git a/x11/gnome-pie/files/pkg-message.in b/x11/gnome-pie/pkg-message
index 6a900aee24ed..3b27b59a075f 100644
--- a/x11/gnome-pie/files/pkg-message.in
+++ b/x11/gnome-pie/pkg-message
@@ -6,7 +6,11 @@ binding commands such as:
gnome-pie -o ID
-(Open Preferences to take the value of the pie ID)
+In a terminal run the command
+
+ gnome-pie -p
+
+to see the available IDs.
EOM
}
]
diff --git a/x11/gnome-pie/pkg-plist b/x11/gnome-pie/pkg-plist
index 9f722bfa969e..7548a245f5ee 100644
--- a/x11/gnome-pie/pkg-plist
+++ b/x11/gnome-pie/pkg-plist
@@ -1,14 +1,19 @@
bin/gnome-pie
-%%MANPAGES%%man/man1/gnome-pie.1.gz
%%DESKTOPDIR%%/gnome-pie.desktop
%%PORTDOCS%%%%DOCSDIR%%/README.md
-%%DATADIR%%/themes/adwaita/arrow.svg
%%DATADIR%%/themes/adwaita/caption_mask.svg
-%%DATADIR%%/themes/adwaita/icon_active.svg
-%%DATADIR%%/themes/adwaita/icon_inactive.svg
+%%DATADIR%%/themes/adwaita/icon.svg
+%%DATADIR%%/themes/adwaita/icon_highlight.svg
%%DATADIR%%/themes/adwaita/preview.png
%%DATADIR%%/themes/adwaita/ring.svg
%%DATADIR%%/themes/adwaita/theme.xml
+%%DATADIR%%/themes/adwaita_big/icon.svg
+%%DATADIR%%/themes/adwaita_big/icon_highlight.svg
+%%DATADIR%%/themes/adwaita_big/icon_mask.svg
+%%DATADIR%%/themes/adwaita_big/icon_mask_caption.svg
+%%DATADIR%%/themes/adwaita_big/preview.png
+%%DATADIR%%/themes/adwaita_big/ring.svg
+%%DATADIR%%/themes/adwaita_big/theme.xml
%%DATADIR%%/themes/bright/arrow.svg
%%DATADIR%%/themes/bright/caption.svg
%%DATADIR%%/themes/bright/caption_mask.svg
@@ -18,6 +23,7 @@ bin/gnome-pie
%%DATADIR%%/themes/bright/preview.png
%%DATADIR%%/themes/bright/ring.svg
%%DATADIR%%/themes/bright/theme.xml
+%%DATADIR%%/themes/elementary/arrow.svg
%%DATADIR%%/themes/elementary/icon_bg.svg
%%DATADIR%%/themes/elementary/preview.png
%%DATADIR%%/themes/elementary/ring.svg
@@ -46,17 +52,48 @@ bin/gnome-pie
%%DATADIR%%/themes/minimalistic_text/fg.svg
%%DATADIR%%/themes/minimalistic_text/preview.png
%%DATADIR%%/themes/minimalistic_text/theme.xml
+%%DATADIR%%/themes/numix/icon.svg
+%%DATADIR%%/themes/numix/icon_mask.svg
+%%DATADIR%%/themes/numix/icon_mask_caption.svg
+%%DATADIR%%/themes/numix/preview.png
+%%DATADIR%%/themes/numix/ring.svg
+%%DATADIR%%/themes/numix/theme.xml
%%DATADIR%%/themes/o-pie/arrow.svg
%%DATADIR%%/themes/o-pie/caption1.svg
%%DATADIR%%/themes/o-pie/caption2.svg
%%DATADIR%%/themes/o-pie/preview.png
%%DATADIR%%/themes/o-pie/ring.svg
%%DATADIR%%/themes/o-pie/theme.xml
+%%DATADIR%%/themes/simple/preview.png
+%%DATADIR%%/themes/simple/slice_caption.svg
+%%DATADIR%%/themes/simple/theme.xml
+%%DATADIR%%/themes/simple_clock/gloss.svg
+%%DATADIR%%/themes/simple_clock/hour.svg
+%%DATADIR%%/themes/simple_clock/icon.svg
+%%DATADIR%%/themes/simple_clock/icon_gloss.svg
+%%DATADIR%%/themes/simple_clock/icon_mask.svg
+%%DATADIR%%/themes/simple_clock/icon_mask_caption.svg
+%%DATADIR%%/themes/simple_clock/minute.svg
+%%DATADIR%%/themes/simple_clock/preview.png
+%%DATADIR%%/themes/simple_clock/ring.svg
+%%DATADIR%%/themes/simple_clock/second.svg
+%%DATADIR%%/themes/simple_clock/theme.xml
%%DATADIR%%/themes/slim/bg.svg
%%DATADIR%%/themes/slim/dot.svg
%%DATADIR%%/themes/slim/preview.png
%%DATADIR%%/themes/slim/slice_caption.svg
%%DATADIR%%/themes/slim/theme.xml
+%%DATADIR%%/themes/space_clock/center.svg
+%%DATADIR%%/themes/space_clock/hour.svg
+%%DATADIR%%/themes/space_clock/icon.svg
+%%DATADIR%%/themes/space_clock/icon_highlight.svg
+%%DATADIR%%/themes/space_clock/icon_mask.svg
+%%DATADIR%%/themes/space_clock/icon_mask_caption.svg
+%%DATADIR%%/themes/space_clock/minute.svg
+%%DATADIR%%/themes/space_clock/pointer.svg
+%%DATADIR%%/themes/space_clock/preview.png
+%%DATADIR%%/themes/space_clock/second.svg
+%%DATADIR%%/themes/space_clock/theme.xml
%%DATADIR%%/themes/unity/arrow.svg
%%DATADIR%%/themes/unity/caption.svg
%%DATADIR%%/themes/unity/caption_mask.svg
@@ -67,11 +104,18 @@ bin/gnome-pie
%%DATADIR%%/themes/unity/ring.svg
%%DATADIR%%/themes/unity/theme.xml
%%DATADIR%%/ui/icon_select.ui
+%%DATADIR%%/ui/pie_options.ui
%%DATADIR%%/ui/preferences.ui
-%%DATADIR%%/ui/rename_pie.ui
-%%DATADIR%%/ui/settings.ui
+%%DATADIR%%/ui/shapes/shape1.svg
+%%DATADIR%%/ui/shapes/shape2.svg
+%%DATADIR%%/ui/shapes/shape3.svg
+%%DATADIR%%/ui/shapes/shape4.svg
+%%DATADIR%%/ui/shapes/shape5.svg
+%%DATADIR%%/ui/shapes/shape6.svg
+%%DATADIR%%/ui/shapes/shape7.svg
+%%DATADIR%%/ui/shapes/shape8.svg
+%%DATADIR%%/ui/shapes/shape9.svg
%%DATADIR%%/ui/slice_select.ui
-%%DATADIR%%/ui/trigger_select.ui
share/icons/hicolor/scalable/apps/gnome-pie-symbolic.svg
share/icons/hicolor/scalable/apps/gnome-pie.svg
%%NLS%%share/locale/bg/LC_MESSAGES/gnomepie.mo
@@ -80,6 +124,11 @@ share/icons/hicolor/scalable/apps/gnome-pie.svg
%%NLS%%share/locale/fr/LC_MESSAGES/gnomepie.mo
%%NLS%%share/locale/it/LC_MESSAGES/gnomepie.mo
%%NLS%%share/locale/ko/LC_MESSAGES/gnomepie.mo
+%%NLS%%share/locale/lt/LC_MESSAGES/gnomepie.mo
+%%NLS%%share/locale/nl_NL/LC_MESSAGES/gnomepie.mo
+%%NLS%%share/locale/pl/LC_MESSAGES/gnomepie.mo
%%NLS%%share/locale/pt_BR/LC_MESSAGES/gnomepie.mo
%%NLS%%share/locale/ru/LC_MESSAGES/gnomepie.mo
+%%NLS%%share/locale/zanata.xml
%%NLS%%share/locale/zh_CN/LC_MESSAGES/gnomepie.mo
+%%MANPAGES%%share/man/man1/gnome-pie.1.gz