aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Engberg <diizzy@FreeBSD.org>2022-09-11 18:44:46 +0000
committerDaniel Engberg <diizzy@FreeBSD.org>2022-09-11 18:48:32 +0000
commite956cc2873e089fc8047681408c40dff61cf48ce (patch)
tree3de00ab78ef7f000550cf05c2c4c98cbe6434635
parent86cf90056da1c7f19dfba5cfc0b63d1323deb876 (diff)
downloadports-e956cc2873e089fc8047681408c40dff61cf48ce.tar.gz
ports-e956cc2873e089fc8047681408c40dff61cf48ce.zip
devel/protobuf-c: Update to 1.4.1
- Use upstream release archive as recommended by Porters Handbook USE_GITHUB section - Do some minor rework of port to improve readability and some minor cleanups PR: 265191 Approved by: truckman (maintainer timeout, 6+ weeks)
-rw-r--r--devel/protobuf-c/Makefile27
-rw-r--r--devel/protobuf-c/distinfo6
-rw-r--r--devel/protobuf-c/pkg-plist1
3 files changed, 13 insertions, 21 deletions
diff --git a/devel/protobuf-c/Makefile b/devel/protobuf-c/Makefile
index c5a90723b07b..dce9f30d48de 100644
--- a/devel/protobuf-c/Makefile
+++ b/devel/protobuf-c/Makefile
@@ -1,8 +1,7 @@
-PORTNAME= protobuf-c
-PORTVERSION= 1.4.0
-DISTVERSIONPREFIX= v
-PORTREVISION= 3
-CATEGORIES= devel
+PORTNAME= protobuf-c
+DISTVERSION= 1.4.1
+CATEGORIES= devel
+MASTER_SITES= https://github.com/${PORTNAME}/${PORTNAME}/releases/download/v${DISTVERSION}/
MAINTAINER= truckman@FreeBSD.org
COMMENT= Code generator and libraries to use Protocol Buffers from pure C
@@ -13,22 +12,19 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
LIB_DEPENDS= libprotobuf.so:devel/protobuf
-USES= autoreconf compiler:c++11-lang gmake libtool pkgconfig
-USE_GITHUB= yes
+USES= compiler:c++11-lang gmake libtool pkgconfig
+GNU_CONFIGURE= yes
USE_LDCONFIG= yes
-GNU_CONFIGURE= yes
+INSTALL_TARGET= install-strip
+TEST_TARGET= check
+PORTDOCS= *
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
+CONFIGURE_ARGS= --disable-static
OPTIONS_DEFINE= DOXYGEN DOCS
OPTIONS_DEFAULT= DOXYGEN
-PORTDOCS= *
-
-ALL_TARGET= all
-INSTALL_TARGET= install-strip
DOXYGEN_IMPLIES= DOCS
DOXYGEN_BUILD_DEPENDS= doxygen:devel/doxygen
DOXYGEN_ALL_TARGET= html-local
@@ -37,7 +33,4 @@ post-install-DOXYGEN-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}/html
${INSTALL_DATA} ${WRKSRC}/html/* ${STAGEDIR}${DOCSDIR}/html
-tests: build
- @(cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} check)
-
.include <bsd.port.mk>
diff --git a/devel/protobuf-c/distinfo b/devel/protobuf-c/distinfo
index 4ebc545a9034..09223f55bad9 100644
--- a/devel/protobuf-c/distinfo
+++ b/devel/protobuf-c/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1622437645
-SHA256 (protobuf-c-protobuf-c-v1.4.0_GH0.tar.gz) = 1068bca1e9870e9492096f97c409cd15f10c5019c183e52ec6d53e8d18630cbf
-SIZE (protobuf-c-protobuf-c-v1.4.0_GH0.tar.gz) = 134352
+TIMESTAMP = 1662921353
+SHA256 (protobuf-c-1.4.1.tar.gz) = 4cc4facd508172f3e0a4d3a8736225d472418aee35b4ad053384b137b220339f
+SIZE (protobuf-c-1.4.1.tar.gz) = 513596
diff --git a/devel/protobuf-c/pkg-plist b/devel/protobuf-c/pkg-plist
index fd1f27144529..ea6fc65a2e7c 100644
--- a/devel/protobuf-c/pkg-plist
+++ b/devel/protobuf-c/pkg-plist
@@ -3,7 +3,6 @@ bin/protoc-gen-c
include/google/protobuf-c/protobuf-c.h
include/protobuf-c/protobuf-c.h
include/protobuf-c/protobuf-c.proto
-lib/libprotobuf-c.a
lib/libprotobuf-c.so
lib/libprotobuf-c.so.1
lib/libprotobuf-c.so.1.0.0