aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVinícius Zavam <egypcio@FreeBSD.org>2021-10-04 10:04:00 +0000
committerVinícius Zavam <egypcio@FreeBSD.org>2021-10-04 10:04:00 +0000
commite959ca709bb76186dddf74c7e5a03893028e9d19 (patch)
tree313eac70399ab422146a2f0a29eec4012ae9f94a
parentb24894798645e4dece7286b6b3fbdb94800de757 (diff)
downloadports-e959ca709bb76186dddf74c7e5a03893028e9d19.tar.gz
ports-e959ca709bb76186dddf74c7e5a03893028e9d19.zip
devel/py-streamparse: update 3.16.0 to 4.0.0
- github.com/Parsely/streamparse/releases/tag/v4.0.0 Reported by: ygy@ PR: 257428
-rw-r--r--devel/py-streamparse/Makefile15
-rw-r--r--devel/py-streamparse/distinfo6
-rw-r--r--devel/py-streamparse/files/patch-setup.py12
3 files changed, 16 insertions, 17 deletions
diff --git a/devel/py-streamparse/Makefile b/devel/py-streamparse/Makefile
index d8ebdf797833..98f2f799829a 100644
--- a/devel/py-streamparse/Makefile
+++ b/devel/py-streamparse/Makefile
@@ -1,7 +1,7 @@
# Created by: Mark Felder <feld@FreeBSD.org>
PORTNAME= streamparse
-PORTVERSION= 3.16.0
+PORTVERSION= 4.0.0
CATEGORIES= devel python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -11,25 +11,24 @@ COMMENT= Python analysis of Apache Storm streams
LICENSE= APACHE20
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}fabric3>0:devel/py-fabric3@${PY_FLAVOR} \
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cython>0:lang/cython@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}fabric3>0:devel/py-fabric3@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}Jinja2>0:devel/py-Jinja2@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}pystorm>=3.1.0:devel/py-pystorm@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pystorm>=3.1.1:devel/py-pystorm@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}requests>0:www/py-requests@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}ruamel.yaml>0:devel/py-ruamel.yaml@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}simplejson>0:devel/py-simplejson@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}six>=1.5:devel/py-six@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}texttable>=0:textproc/py-texttable@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}thriftpy>=0.3.2:devel/py-thriftpy@${PY_FLAVOR}
+ ${PYTHON_PKGNAMEPREFIX}thriftpy2>=0:devel/py-thriftpy2@${PY_FLAVOR}
TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}mock>=0:devel/py-mock@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}nose>=0:devel/py-nose@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}unittest2>=0:devel/py-unittest2@${PY_FLAVOR}
+ ${PYTHON_PKGNAMEPREFIX}unittest2>=0:devel/py-unittest2@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}graphviz>=0:graphics/py-graphviz@${PY_FLAVOR}
USES= python:3.6+
USE_PYTHON= autoplist distutils
NO_ARCH= yes
-post-patch:
- ${RM} ${WRKSRC}/test/__init__.py
-
.include <bsd.port.mk>
diff --git a/devel/py-streamparse/distinfo b/devel/py-streamparse/distinfo
index 2d0767e4faa3..530d9cee1c5c 100644
--- a/devel/py-streamparse/distinfo
+++ b/devel/py-streamparse/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1555512127
-SHA256 (streamparse-3.16.0.tar.gz) = 9ff83c506981fbd0e9a4ca923a9ca1c4bea9ba85da47dd5856970774b30b5a26
-SIZE (streamparse-3.16.0.tar.gz) = 54852
+TIMESTAMP = 1633239786
+SHA256 (streamparse-4.0.0.tar.gz) = c1db519d83ab6f942cbc0cbd4cbdc8ef2c1a876a8c5cfa5d496f89b940953459
+SIZE (streamparse-4.0.0.tar.gz) = 54266
diff --git a/devel/py-streamparse/files/patch-setup.py b/devel/py-streamparse/files/patch-setup.py
index 5446d192dc69..76b1b8691614 100644
--- a/devel/py-streamparse/files/patch-setup.py
+++ b/devel/py-streamparse/files/patch-setup.py
@@ -1,14 +1,14 @@
---- setup.py.orig 2019-01-13 16:56:06 UTC
+--- setup.py.orig 2021-10-04 08:45:30 UTC
+++ setup.py
-@@ -16,6 +16,7 @@ limitations under the License.
+@@ -14,6 +14,7 @@ WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either e
+ See the License for the specific language governing permissions and
+ limitations under the License.
"""
- import re
- import sys
+import codecs
+ import re
from setuptools import setup, find_packages
-
-@@ -29,7 +30,7 @@ def get_version():
+@@ -28,7 +29,7 @@ def get_version():
def readme():
""" Returns README.rst contents as str """