aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason W. Bacon <jwb@FreeBSD.org>2023-08-06 18:14:56 +0000
committerJason W. Bacon <jwb@FreeBSD.org>2023-08-06 18:17:52 +0000
commite97c3457489f2abb3cda2b6b023ba580b6382c07 (patch)
treee92488e111841430dde8da793d31debe7cca9bca
parentd07382c7604b1436f655a09256f03a6f2282aeaa (diff)
biology/py-macs2: Update to 2.2.9.1
Mainly updates to dependencies Changes: https://github.com/macs3-project/MACS/releases Added test target Reported by: portscout
-rw-r--r--biology/py-macs2/Makefile15
-rw-r--r--biology/py-macs2/distinfo6
-rw-r--r--biology/py-macs2/files/patch-setup.py25
3 files changed, 14 insertions, 32 deletions
diff --git a/biology/py-macs2/Makefile b/biology/py-macs2/Makefile
index e8e1313b1da8..5a9d78cfe622 100644
--- a/biology/py-macs2/Makefile
+++ b/biology/py-macs2/Makefile
@@ -1,6 +1,6 @@
PORTNAME= macs2
DISTVERSIONPREFIX= v
-DISTVERSION= 2.2.8
+DISTVERSION= 2.2.9.1
CATEGORIES= biology python
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -12,18 +12,25 @@ LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= ${PYNUMPY}
-RUN_DEPENDS= ${PYNUMPY}
+RUN_DEPENDS= ${PYNUMPY} \
+ ${PYTHON_PKGNAMEPREFIX}cykhash>0:devel/py-cykhash@${PY_FLAVOR}
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>0:devel/py-pytest@${PY_FLAVOR} \
+ bash:shells/bash
-USES= python
+USES= python shebangfix
+USE_GITHUB= yes
USE_PYTHON= autoplist concurrent cython distutils
-USE_GITHUB= yes
GH_ACCOUNT= taoliu
GH_PROJECT= MACS
+SHEBANG_FILES= test/cmdlinetest_update test/cmdlinetest test/prockreport
post-stage:
${STRIP_CMD} \
${STAGEDIR}${PYTHON_SITELIBDIR}/MACS2/*.so \
${STAGEDIR}${PYTHON_SITELIBDIR}/MACS2/*/*.so
+do-test: install
+ @cd ${WRKSRC}/test && ./cmdlinetest tag
+
.include <bsd.port.mk>
diff --git a/biology/py-macs2/distinfo b/biology/py-macs2/distinfo
index 1999b76a294d..e6da44033e73 100644
--- a/biology/py-macs2/distinfo
+++ b/biology/py-macs2/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1684361836
-SHA256 (taoliu-MACS-v2.2.8_GH0.tar.gz) = cab63d7e8b862dbd6bb8ed32325e4fee728d85306e47931167fef753ef0ee743
-SIZE (taoliu-MACS-v2.2.8_GH0.tar.gz) = 133108890
+TIMESTAMP = 1691269587
+SHA256 (taoliu-MACS-v2.2.9.1_GH0.tar.gz) = 8e461dde82288280fe708cd4f5fec986fbf2da67b344f4dea5693af849549163
+SIZE (taoliu-MACS-v2.2.9.1_GH0.tar.gz) = 133109075
diff --git a/biology/py-macs2/files/patch-setup.py b/biology/py-macs2/files/patch-setup.py
deleted file mode 100644
index 3434e1146357..000000000000
--- a/biology/py-macs2/files/patch-setup.py
+++ /dev/null
@@ -1,25 +0,0 @@
---- setup.py.orig 2020-04-12 14:46:03 UTC
-+++ setup.py
-@@ -26,22 +26,6 @@ def main():
-
- cwd = os.path.abspath(os.path.dirname(__file__))
-
-- # install required numpy
-- p = subprocess.call([sys.executable, "-m", 'pip', 'install', f'numpy{numpy_requires}'],cwd=cwd)
-- if p != 0:
-- # Could be due to a too old pip version and build isolation, check that
-- try:
-- # Note, pip may not be installed or not have been used
-- import pip
-- if LooseVersion(pip.__version__) < LooseVersion('18.0.0'):
-- raise RuntimeError("Installing requirements failed. Possibly due "
-- "to `pip` being too old, found version {}, "
-- "needed is >= 18.0.0.".format(pip.__version__))
-- else:
-- raise RuntimeError("Installing requirements failed!")
-- except ImportError:
-- raise RuntimeError("Installing requirement failed! `pip` has to be installed!")
--
- from numpy import get_include as numpy_get_include
- numpy_include_dir = [numpy_get_include()]
-