aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJack <xxjack12xx@gmail.com>2021-10-27 08:18:00 +0000
committerFernando ApesteguĂ­a <fernape@FreeBSD.org>2021-10-30 09:43:03 +0000
commite9eb4687c7ca4e78a1fcc86ee071230ab16df350 (patch)
treeb278d7c3deb89b96e4d2c7c1f6a54b036647788e
parent6e5a9229f617b618a03fcfe40ed7efc58c9d2cc3 (diff)
downloadports-e9eb4687c7ca4e78a1fcc86ee071230ab16df350.tar.gz
ports-e9eb4687c7ca4e78a1fcc86ee071230ab16df350.zip
audio/audacity: Upgrade to 3.0.5
ChangeLog: https://wiki.audacityteam.org/wiki/Release_Notes_3.0.4 While here: * Pet linters * Add gdkpixbuf2 depdendency PR: 258107 Reported by: xxjack12xx@gmail.com (maintainer) Reviewed by: diizzy@, nc@, tatsuki_makino@hotmail.com
-rw-r--r--audio/audacity/Makefile71
-rw-r--r--audio/audacity/distinfo6
-rw-r--r--audio/audacity/files/patch-cmake-proxies_CMakeLists.txt72
-rw-r--r--audio/audacity/files/patch-cmake-proxies_cmake-modules_AudacityDependencies.cmake227
-rw-r--r--audio/audacity/files/patch-cmake-proxies_cmake-modules_Findlibmp3lame.cmake32
-rw-r--r--audio/audacity/files/patch-cmake-proxies_cmake-modules_dependencies_wxwidgets.cmake14
-rw-r--r--audio/audacity/files/patch-cmake-proxies_wxWidgets_CMakeLists.txt20
-rw-r--r--audio/audacity/files/patch-src_AboutDialog.cpp8
-rw-r--r--audio/audacity/files/patch-src_widgets_Grid.cpp11
-rw-r--r--audio/audacity/pkg-plist9
10 files changed, 391 insertions, 79 deletions
diff --git a/audio/audacity/Makefile b/audio/audacity/Makefile
index 136177388e43..c80de1d47163 100644
--- a/audio/audacity/Makefile
+++ b/audio/audacity/Makefile
@@ -1,11 +1,9 @@
# Created by: Marc van Woerkom <3d@FreeBSD.org>
PORTNAME= audacity
-DISTVERSIONPREFIX= minsrc-
-DISTVERSION= 3.0.2
-PORTREVISION= 1
+DISTVERSIONPREFIX= Audacity-
+DISTVERSION= 3.0.5
CATEGORIES= audio
-MASTER_SITES= https://github.com/${PORTNAME}/${PORTNAME}/releases/download/Audacity-${PORTVERSION}/
MAINTAINER= xxjack12xx@gmail.com
COMMENT= GUI editor for digital audio waveforms
@@ -13,41 +11,51 @@ COMMENT= GUI editor for digital audio waveforms
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+BUILD_DEPENDS= conan:sysutils/conan
LIB_DEPENDS= libasound.so:audio/alsa-lib \
libexpat.so:textproc/expat2 \
+ libmp3lame.so:audio/lame \
libportaudio.so:audio/portaudio \
+ libportmidi.so:audio/portmidi \
libsndfile.so:audio/libsndfile \
libsoxr.so:audio/libsoxr \
- libsqlite3.so:databases/sqlite3
+ libsqlite3.so:databases/sqlite3 \
+ libuuid.so:misc/e2fsprogs-libuuid
USES= cmake compiler:c++14-lang cpe desktop-file-utils gettext \
- gnome libtool python:build pkgconfig shared-mime-info tar:xz
-USE_GNOME= cairo gtk30
+ gnome libtool python:build pkgconfig shared-mime-info
+
+USE_GITHUB= yes
+USE_GNOME= cairo gdkpixbuf2 gtk30
USE_WX= 3.1+
WX_COMPS= wx
PORTDOCS= README.txt
CMAKE_ARGS= -Daudacity_lib_preference:STRING=system \
-Daudacity_use_expat:STRING=system \
- -Daudacity_use_wxwidgets:STRING=system \
- -Daudacity_use_soxr:STRING=system \
- -Daudacity_use_sndfile:STRING=system \
+ -Daudacity_use_midi:STRING=system \
+ -Daudacity_use_nyquist:STRING=local \
-Daudacity_use_portsmf:STRING=local \
-Daudacity_use_portmixer:STRING=local \
- -Daudacity_use_portaudio:STRING=system
-CMAKE_OFF= audacity_use_pch
+ -Daudacity_use_portaudio:STRING=system \
+ -Daudacity_use_soxr:STRING=system \
+ -Daudacity_use_sndfile:STRING=system \
+ -Daudacity_use_sqlite:STRING=system \
+ -Daudacity_use_wxwidgets:STRING=system \
+ -Daudacity_use_zlib:STRING=system
+CMAKE_ON= audacity_obey_system_dependencies
+CMAKE_OFF= audacity_has_networking audacity_has_updates_check \
+ audacity_use_pa_alsa audacity_use_pch
-OPTIONS_DEFINE= DEBUG DOCS FFMPEG FLAC ID3TAG LADSPA LAME LV2 MAD \
- MIDI OGG SBSMS SOUNDTOUCH TWOLAME VAMP \
+OPTIONS_DEFINE= DEBUG DOCS FFMPEG FLAC ID3TAG LADSPA LV2 MAD \
+ OGG SBSMS SOUNDTOUCH TWOLAME VAMP \
VORBIS VST
-OPTIONS_DEFAULT= FFMPEG FLAC ID3TAG LV2 MAD MIDI OGG SBSMS \
+OPTIONS_DEFAULT= FFMPEG FLAC ID3TAG LV2 MAD OGG SBSMS \
SOUNDTOUCH TWOLAME VAMP VORBIS VST
OPTIONS_EXCLUDE_i386= SBSMS
-LAME_DESC= Use lame for import and export support
LV2_DESC= Add LV2 plug-in support
MAD_DESC= Use libmad for mp2/3 decoding support
-MIDI_DESC= MIDI support
SBSMS_DESC= Use libsbsms for pitch and tempo changing
SOUNDTOUCH_DESC= Use libSoundTouch for pitch and tempo changing
TWOLAME_DESC= Use libtwolame for MP2 export support
@@ -58,6 +66,7 @@ DEBUG_CMAKE_ON= wxWidgets_USE_DEBUG
DOCS_BUILD_DEPENDS= docbook-to-man:textproc/docbook-to-man \
docbook2man:textproc/docbook-utils
+DOCS_LIB_DEPENDS= libharfbuzz.so:print/harfbuzz
FFMPEG_CMAKE_ON= -Daudacity_use_ffmpeg:STRING=loaded
FFMPEG_CMAKE_OFF= -Daudacity_use_ffmpeg:STRING=off
@@ -68,20 +77,13 @@ FLAC_CMAKE_ON= -Daudacity_use_flac:STRING=system
FLAC_CMAKE_OFF= -Daudacity_use_flac:STRING=local
FLAC_LIB_DEPENDS= libFLAC.so:audio/flac
-ID3TAG_CMAKE_ON= -Daudacity_use_id3tag:STRING=system
-ID3TAG_CMAKE_OFF= -Daudacity_use_id3tag:STRING=off
+ID3TAG_CMAKE_ON= -Daudacity_use_libid3tag:STRING=system
+ID3TAG_CMAKE_OFF= -Daudacity_use_libid3tag:STRING=off
ID3TAG_LIB_DEPENDS= libid3tag.so:audio/libid3tag
LADSPA_CMAKE_BOOL= audacity_use_ladspa
LADSPA_RUN_DEPENDS= listplugins:audio/ladspa
-LAME_CMAKE_ON= -Daudacity_use_lame:STRING=system
-LAME_CMAKE_OFF= -Daudacity_use_lame:STRING=local
-LAME_BUILD_DEPENDS= ${LOCALBASE}/include/lame/lame.h:audio/lame
-LAME_CPPFLAGS= -I${LOCALBASE}/include/lame
-LAME_LDFLAGS= -L${LOCALBASE}/lib
-LAME_LIB_DEPENDS= libmp3lame.so:audio/lame
-
LV2_CMAKE_ON= -Daudacity_use_lv2:STRING=system
LV2_CMAKE_OFF= -Daudacity_use_lv2:STRING=off
LV2_LIB_DEPENDS= liblilv-0.so:audio/lilv \
@@ -90,13 +92,10 @@ LV2_LIB_DEPENDS= liblilv-0.so:audio/lilv \
libsratom-0.so:audio/sratom \
libsuil-0.so:audio/suil
-MAD_CMAKE_ON= -Daudacity_use_mad:STRING=system
-MAD_CMAKE_OFF= -Daudacity_use_mad:STRING=off
+MAD_CMAKE_ON= -Daudacity_use_libmad:STRING=system
+MAD_CMAKE_OFF= -Daudacity_use_libmad:STRING=off
MAD_LIB_DEPENDS= libmad.so:audio/libmad
-MIDI_CMAKE_ON= -Daudacity_use_midi:STRING=local
-MIDI_CMAKE_OFF= -Daudacity_use_midi:STRING=off
-
# TODO: fix NLS support properly
PLIST_SUB+= NLS=""
@@ -109,7 +108,7 @@ SBSMS_CMAKE_OFF= -Daudacity_use_sbsms:STRING=off
SOUNDTOUCH_CMAKE_ON= -Daudacity_use_soundtouch:STRING=system
SOUNDTOUCH_CMAKE_OFF= -Daudacity_use_soundtouch:STRING=off
-SOUNDTOUCH_LIB_DEPENDS= libSoundTouch.so:audio/soundtouch
+SOUNDTOUCH_LIB_DEPENDS= libSoundTouch.so:audio/soundtouch
TWOLAME_CMAKE_ON= -Daudacity_use_twolame:STRING=system
TWOLAME_CMAKE_OFF= -Daudacity_use_twolame:STRING=off
@@ -135,13 +134,13 @@ CMAKE_ARGS+= -DHAVE_MMX:BOOL=OFF \
.endif
post-install:
- @cd ${STAGEDIR}${PREFIX} && ${STRIP_CMD} \
- bin/${PORTNAME} \
- share/audacity/modules/mod-script-pipe.so
@${RM} ${STAGEDIR}${DOCSDIR}/LICENSE.txt
- # delete empty directories: https://github.com/audacity/audacity/issues/808
+ #delete empty directories: https://github.com/audacity/audacity/issues/808
@${FIND} ${STAGEDIR} -type d -empty -delete
+post-install-DEBUG-off:
+ @${FIND} ${STAGEDIR}${PREFIX}/lib/audacity -name '*.so*' -exec ${STRIP_CMD} {} +
+
post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR}
diff --git a/audio/audacity/distinfo b/audio/audacity/distinfo
index 3442dbc6b929..c24f472d0d6c 100644
--- a/audio/audacity/distinfo
+++ b/audio/audacity/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1619066304
-SHA256 (audacity-minsrc-3.0.2.tar.xz) = 728d6459931da006ed45a31e63b7fe6ca47a2547459a2aff3bf0880cef85c296
-SIZE (audacity-minsrc-3.0.2.tar.xz) = 13330160
+TIMESTAMP = 1633473095
+SHA256 (audacity-audacity-Audacity-3.0.5_GH0.tar.gz) = 4b94dcaf45545ebf0d9a44b71fbdc1251109100b465ff4d71860849b5ffcf525
+SIZE (audacity-audacity-Audacity-3.0.5_GH0.tar.gz) = 63066756
diff --git a/audio/audacity/files/patch-cmake-proxies_CMakeLists.txt b/audio/audacity/files/patch-cmake-proxies_CMakeLists.txt
index bec1681c2429..61e936d9dfaa 100644
--- a/audio/audacity/files/patch-cmake-proxies_CMakeLists.txt
+++ b/audio/audacity/files/patch-cmake-proxies_CMakeLists.txt
@@ -1,7 +1,73 @@
---- cmake-proxies/CMakeLists.txt.orig 2021-02-04 18:52:51 UTC
+--- cmake-proxies/CMakeLists.txt.orig 2021-08-18 10:21:37 UTC
+++ cmake-proxies/CMakeLists.txt
-@@ -132,7 +132,7 @@ addlib( expat expat EXPAT YES
- addlib( lame lame LAME YES YES "lame >= 3.100" )
+@@ -87,6 +87,7 @@ add_conan_lib(
+ REQUIRED
+ INTERFACE_NAME libmp3lame::libmp3lame
+ PKG_CONFIG "lame >= 3.100"
++ ALLOW_FIND_PACKAGE
+ )
+
+ add_conan_lib(
+@@ -105,24 +106,23 @@ add_conan_lib(
+ PKG_CONFIG "mad >= 0.15.1b"
+ )
+
+-if( CMAKE_SYSTEM_NAME MATCHES "Darwin" )
+- set( curl_ssl "darwinssl" )
+-elseif( CMAKE_SYSTEM_NAME MATCHES "Windows" )
+- set( curl_ssl "schannel")
+-else()
+- set ( curl_ssl "openssl" )
+-endif ()
+-
+-add_conan_lib(
+- ThreadPool
+- threadpool/20140926
+- REQUIRED
+- ALWAYS_ALLOW_CONAN_FALLBACK
+-)
+-
+ if( ${_OPT}has_networking )
++ if( CMAKE_SYSTEM_NAME MATCHES "Darwin" )
++ set( curl_ssl "darwinssl" )
++ elseif( CMAKE_SYSTEM_NAME MATCHES "Windows" )
++ set( curl_ssl "schannel")
++ else()
++ set ( curl_ssl "openssl" )
++ endif ()
+
+ add_conan_lib(
++ ThreadPool
++ threadpool/20140926
++ REQUIRED
++ ALWAYS_ALLOW_CONAN_FALLBACK
++ )
++
++ add_conan_lib(
+ CURL
+ libcurl/7.75.0
+ REQUIRED
+@@ -148,11 +148,13 @@ if( NOT CMAKE_SYSTEM_NAME MATCHES "Darwin|Windows")
+ )
+ endif()
+
+-add_conan_lib(
+- RapidJSON
+- rapidjson/1.1.0
+- REQUIRED
+-)
++if( ${_OPT}has_sentry_reporting )
++ add_conan_lib(
++ RapidJSON
++ rapidjson/1.1.0
++ REQUIRED
++ )
++endif()
+
+ set_conan_vars_to_parent()
+
+@@ -161,7 +163,7 @@ set_conan_vars_to_parent()
+ # directory option symbol req chk version
addlib( libsndfile sndfile SNDFILE YES YES "sndfile >= 1.0.28" )
addlib( libsoxr soxr SOXR YES YES "soxr >= 0.1.1" )
-addlib( portaudio-v19 portaudio PORTAUDIO YES YES "" )
diff --git a/audio/audacity/files/patch-cmake-proxies_cmake-modules_AudacityDependencies.cmake b/audio/audacity/files/patch-cmake-proxies_cmake-modules_AudacityDependencies.cmake
new file mode 100644
index 000000000000..aa56ade9b838
--- /dev/null
+++ b/audio/audacity/files/patch-cmake-proxies_cmake-modules_AudacityDependencies.cmake
@@ -0,0 +1,227 @@
+--- cmake-proxies/cmake-modules/AudacityDependencies.cmake.orig 2021-08-27 22:30:37 UTC
++++ cmake-proxies/cmake-modules/AudacityDependencies.cmake
+@@ -1,11 +1,14 @@
+ # Load Conan
+-include( conan )
+
+-conan_add_remote(NAME audacity
+- URL https://artifactory.audacityteam.org/artifactory/api/conan/conan-local
+- VERIFY_SSL True
+-)
++if( ${_OPT}conan_enabled )
++ include( conan )
+
++ conan_add_remote(NAME audacity
++ URL https://artifactory.audacityteam.org/artifactory/api/conan/conan-local
++ VERIFY_SSL True
++ )
++endif()
++
+ set( CONAN_BUILD_REQUIRES )
+ set( CONAN_REQUIRES )
+ set( CONAN_PACKAGE_OPTIONS )
+@@ -13,24 +16,30 @@ set( CONAN_ONLY_DEBUG_RELEASE )
+ set( CONAN_CONFIG_OPTIONS )
+ set( CONAN_RESOLVE_LIST )
+
+-# Add a Conan dependency
+-# Example usage:
+-# add_conan_lib(
+-# wxWdidget
+-# wxwidgets/3.1.3-audacity
+-# OPTION_NAME wxwidgets
+-# SYMBOL WXWIDGET
+-# REQUIRED
+-# ALWAYS_ALLOW_CONAN_FALLBACK
+-# PKG_CONFIG "wxwidgets >= 3.1.3"
+-# FIND_PACKAGE_OPTIONS COMPONENTS adv base core html qa xml
+-# INTERFACE_NAME wxwidgets::wxwidgets
+-# HAS_ONLY_DEBUG_RELEASE
+-# CONAN_OPTIONS
+-# wxwidgets:shared=True
+-# )
++#[[
++Add a Conan dependency
+
++Example usage:
+
++add_conan_lib(
++ wxWdidget
++ wxwidgets/3.1.3-audacity
++ OPTION_NAME wxwidgets
++ SYMBOL WXWIDGET
++ REQUIRED
++ ALWAYS_ALLOW_CONAN_FALLBACK
++ PKG_CONFIG "wxwidgets >= 3.1.3"
++ FIND_PACKAGE_OPTIONS COMPONENTS adv base core html qa xml
++ INTERFACE_NAME wxwidgets::wxwidgets
++ HAS_ONLY_DEBUG_RELEASE
++ CONAN_OPTIONS
++ wxwidgets:shared=True
++)
++
++PKG_CONFIG accepts a list of possible package configurations.
++add_conan_lib will iterate over it one by one until the library is found.
++]]
++
+ function (add_conan_lib package conan_package_name )
+ # Extract the list of packages from the function args
+ list( SUBLIST ARGV 2 -1 options )
+@@ -54,6 +63,8 @@ function (add_conan_lib package conan_package_name )
+ set( list_mode on )
+ set( allow_find_package on )
+ set( current_var "find_package_options" )
++ elseif ( opt STREQUAL "ALLOW_FIND_PACKAGE" )
++ set ( allow_find_package on )
+ elseif ( opt STREQUAL "CONAN_OPTIONS" )
+ set( list_mode on )
+ set( current_var "conan_package_options" )
+@@ -93,14 +104,23 @@ function (add_conan_lib package conan_package_name )
+
+ set( option_desc "local" )
+
+- if( pkg_config_options OR allow_find_package )
++ if( pkg_config_options OR allow_find_package OR NOT ${_OPT}conan_enabled )
+ set( sysopt "system" )
+ string( PREPEND option_desc "system (if available), " )
+- set( default "${${_OPT}lib_preference}" )
++
++ if( ${_OPT}conan_enabled )
++ set( default "${${_OPT}lib_preference}" )
++ else()
++ set( default "system" )
++ endif()
+ else()
+ set( default "local" )
+ endif()
+
++ if( ${_OPT}conan_enabled )
++ set( localopt "local" )
++ endif()
++
+ if( NOT required )
+ set( reqopt "off" )
+ string( APPEND option_desc ", off" )
+@@ -109,7 +129,7 @@ function (add_conan_lib package conan_package_name )
+ cmd_option( ${option_name}
+ "Use ${option_name_base} library [${option_desc}]"
+ "${default}"
+- STRINGS ${sysopt} "local" ${reqopt}
++ STRINGS ${sysopt} ${localopt} ${reqopt}
+ )
+
+ # Early bail out
+@@ -129,26 +149,28 @@ function (add_conan_lib package conan_package_name )
+ return()
+ endif()
+
+- if( ${option_name} STREQUAL "system" )
++ if( ${option_name} STREQUAL "system" OR NOT ${_OPT}conan_enabled )
+ if( pkg_config_options )
+- pkg_check_modules( PKG_${package} ${pkg_config_options} )
++ foreach(variant ${pkg_config_options})
++ pkg_check_modules( PKG_${package} ${variant} )
+
+- if( PKG_${package}_FOUND )
+- message( STATUS "Using '${package}' system library" )
+-
+- # Create the target interface library
+- add_library( ${interface_name} INTERFACE IMPORTED GLOBAL)
++ if( PKG_${package}_FOUND )
++ message( STATUS "Using '${package}' system library" )
+
+- # Retrieve the package information
+- get_package_interface( PKG_${package} )
+-
+- # And add it to our target
+- target_include_directories( ${interface_name} INTERFACE ${INCLUDES} )
+- target_link_libraries( ${interface_name} INTERFACE ${LIBRARIES} )
++ # Create the target interface library
++ add_library( ${interface_name} INTERFACE IMPORTED GLOBAL)
++
++ # Retrieve the package information
++ get_package_interface( PKG_${package} )
++
++ # And add it to our target
++ target_include_directories( ${interface_name} INTERFACE ${INCLUDES} )
++ target_link_libraries( ${interface_name} INTERFACE ${LIBRARIES} )
+
+- message(STATUS "Added inteface ${interface_name} ${INCLUDES} ${LIBRARIES}")
+- return()
+- endif()
++ message(STATUS "Added inteface ${interface_name} ${INCLUDES} ${LIBRARIES}")
++ return()
++ endif()
++ endforeach()
+ endif()
+
+ if( allow_find_package )
+@@ -160,7 +182,7 @@ function (add_conan_lib package conan_package_name )
+ endif()
+ endif()
+
+- if( system_only )
++ if( system_only OR NOT ${_OPT}conan_enabled )
+ message( FATAL_ERROR "Failed to find the system package ${package}" )
+ else()
+ set( ${option_name} "local" )
+@@ -237,34 +259,36 @@ function ( _conan_install build_type )
+ endfunction()
+
+ macro( resolve_conan_dependencies )
+- message(STATUS
+- "Executing Conan: \
+- REQUIRES ${CONAN_REQUIRES}
+- GENERATORS cmake_find_package_multi
+- BUILD_REQUIRES ${CONAN_BUILD_REQUIRES}
+- ${CONAN_CONFIG_OPTIONS}
+- OPTIONS ${CONAN_PACKAGE_OPTIONS}
+- ")
++ if( ${_OPT}conan_enabled )
++ message(STATUS
++ "Executing Conan: \
++ REQUIRES ${CONAN_REQUIRES}
++ GENERATORS cmake_find_package_multi
++ BUILD_REQUIRES ${CONAN_BUILD_REQUIRES}
++ ${CONAN_CONFIG_OPTIONS}
++ OPTIONS ${CONAN_PACKAGE_OPTIONS}
++ ")
+
+- if(MSVC OR XCODE)
+- foreach(TYPE ${CMAKE_CONFIGURATION_TYPES})
+- _conan_install(${TYPE})
+- endforeach()
+- else()
+- _conan_install(${CMAKE_BUILD_TYPE})
+- endif()
++ if(MSVC OR XCODE)
++ foreach(TYPE ${CMAKE_CONFIGURATION_TYPES})
++ _conan_install(${TYPE})
++ endforeach()
++ else()
++ _conan_install(${CMAKE_BUILD_TYPE})
++ endif()
+
+- list( REMOVE_DUPLICATES CONAN_REQUIRES )
++ list( REMOVE_DUPLICATES CONAN_REQUIRES )
+
+- foreach( package ${CONAN_RESOLVE_LIST} )
+- message(STATUS "Resolving Conan library ${package}")
++ foreach( package ${CONAN_RESOLVE_LIST} )
++ message(STATUS "Resolving Conan library ${package}")
+
+- find_package(${package} CONFIG)
++ find_package(${package} CONFIG)
+
+- if (NOT ${package}_FOUND)
+- message( FATAL_ERROR "Failed to find the conan package ${package}" )
+- endif()
+- endforeach()
++ if (NOT ${package}_FOUND)
++ message( FATAL_ERROR "Failed to find the conan package ${package}" )
++ endif()
++ endforeach()
++ endif()
+
+ file(GLOB dependency_helpers "${AUDACITY_MODULE_PATH}/dependencies/*.cmake")
+
diff --git a/audio/audacity/files/patch-cmake-proxies_cmake-modules_Findlibmp3lame.cmake b/audio/audacity/files/patch-cmake-proxies_cmake-modules_Findlibmp3lame.cmake
new file mode 100644
index 000000000000..04ba97036acb
--- /dev/null
+++ b/audio/audacity/files/patch-cmake-proxies_cmake-modules_Findlibmp3lame.cmake
@@ -0,0 +1,32 @@
+--- cmake-proxies/cmake-modules/Findlibmp3lame.cmake.orig 2021-08-27 22:30:58 UTC
++++ cmake-proxies/cmake-modules/Findlibmp3lame.cmake
+@@ -0,0 +1,29 @@
++#[[
++A module to look for libmp3lame
++]]
++
++if( NOT libmp3lame_FOUND )
++ find_path( libmp3lame_INCLUDE_DIR lame/lame.h )
++ find_library( libmp3lame_LIBRARIES NAMES mp3lame )
++
++ if( libmp3lame_INCLUDE_DIR AND libmp3lame_LIBRARIES )
++ set( libmp3lame_FOUND Yes )
++ endif()
++
++ if( libmp3lame_FOUND )
++ if( NOT libmp3lame_FIND_QUIETLY )
++ message( STATUS "Found lame: \n\tlibmp3lame_INCLUDE_DIR: ${libmp3lame_INCLUDE_DIR}\n\tlibmp3lame_LIBRARIES: ${libmp3lame_LIBRARIES}" )
++ endif()
++
++ if( NOT TARGET libmp3lame::libmp3lame )
++ add_library( libmp3lame::libmp3lame INTERFACE IMPORTED GLOBAL)
++
++ target_include_directories( libmp3lame::libmp3lame INTERFACE ${libmp3lame_INCLUDE_DIR} )
++ target_link_libraries( libmp3lame::libmp3lame INTERFACE ${libmp3lame_LIBRARIES} )
++ endif()
++ else()
++ if( libmp3lame_FIND_REQUIRED )
++ message( FATAL_ERROR "Could not find libmp3lame")
++ endif()
++ endif()
++endif()
diff --git a/audio/audacity/files/patch-cmake-proxies_cmake-modules_dependencies_wxwidgets.cmake b/audio/audacity/files/patch-cmake-proxies_cmake-modules_dependencies_wxwidgets.cmake
new file mode 100644
index 000000000000..934cfad48eb6
--- /dev/null
+++ b/audio/audacity/files/patch-cmake-proxies_cmake-modules_dependencies_wxwidgets.cmake
@@ -0,0 +1,14 @@
+--- cmake-proxies/cmake-modules/dependencies/wxwidgets.cmake.orig 2021-08-27 06:00:39 UTC
++++ cmake-proxies/cmake-modules/dependencies/wxwidgets.cmake
+@@ -1,4 +1,10 @@
+-if( ${_OPT}use_wxwidgets STREQUAL "system" )
++if( ${_OPT}use_wxwidgets STREQUAL "system" OR NOT ${_OPT}conan_enabled )
++ # DV: find_package will be scoped, as FindwxWidgets.cmake is rather outdated.
++ # Still - let's perform the sanity check first.
++ if( NOT wxWidgets_FOUND )
++ find_package( wxWidgets REQUIRED COMPONENTS adv base core html qa xml net )
++ endif()
++
+ if( NOT TARGET wxwidgets::wxwidgets )
+ add_library( wxwidgets::wxwidgets INTERFACE IMPORTED GLOBAL)
+ endif()
diff --git a/audio/audacity/files/patch-cmake-proxies_wxWidgets_CMakeLists.txt b/audio/audacity/files/patch-cmake-proxies_wxWidgets_CMakeLists.txt
deleted file mode 100644
index 9be6dbd70f27..000000000000
--- a/audio/audacity/files/patch-cmake-proxies_wxWidgets_CMakeLists.txt
+++ /dev/null
@@ -1,20 +0,0 @@
---- cmake-proxies/wxWidgets/CMakeLists.txt.orig 2020-08-05 16:32:53 UTC
-+++ cmake-proxies/wxWidgets/CMakeLists.txt
-@@ -237,17 +237,6 @@ file(
- "^#define +wxVERSION_STRING +"
- )
-
--string( REGEX MATCHALL "\".+(Audacity).+\"" ours "${output}")
--if( NOT ours )
-- message( FATAL_ERROR
-- "\n########################################################################\n"
-- "Audacity version 3.0.0 or higher requires use of a customized version of "
-- "wxWidgets. For details:\n"
-- " https://wiki.audacityteam.org/wiki/Building_for_Distros\n"
-- "########################################################################\n"
-- )
--endif()
--
- target_include_directories( ${TARGET} INTERFACE ${INCLUDES} )
- target_compile_definitions( ${TARGET} INTERFACE ${DEFINES} )
- target_compile_options( ${TARGET} INTERFACE ${COPTS} )
diff --git a/audio/audacity/files/patch-src_AboutDialog.cpp b/audio/audacity/files/patch-src_AboutDialog.cpp
index 36cf61b58bff..db7c2510c6de 100644
--- a/audio/audacity/files/patch-src_AboutDialog.cpp
+++ b/audio/audacity/files/patch-src_AboutDialog.cpp
@@ -1,11 +1,11 @@
---- src/AboutDialog.cpp.orig 2020-06-28 06:25:54 UTC
+--- src/AboutDialog.cpp.orig 2021-09-22 19:37:04 UTC
+++ src/AboutDialog.cpp
-@@ -63,7 +63,7 @@ hold information about one contributor to Audacity.
+@@ -64,7 +64,7 @@ hold information about one contributor to Audacity.
// RevisionIdent.h may contain #defines like these ones:
//#define REV_LONG "28864acb238cb3ca71dda190a2d93242591dd80e"
//#define REV_TIME "Sun Apr 12 12:40:22 2015 +0100"
--#include <RevisionIdent.h>
-+//#include <RevisionIdent.h>
+-#include "RevisionIdent.h"
++//#include "RevisionIdent.h"
#ifndef REV_TIME
#define REV_TIME "unknown date and time"
diff --git a/audio/audacity/files/patch-src_widgets_Grid.cpp b/audio/audacity/files/patch-src_widgets_Grid.cpp
deleted file mode 100644
index 4945a5bc8067..000000000000
--- a/audio/audacity/files/patch-src_widgets_Grid.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/widgets/Grid.cpp.orig 2021-02-04 18:52:51 UTC
-+++ src/widgets/Grid.cpp
-@@ -572,7 +572,7 @@ void Grid::OnKeyDown(wxKeyEvent &event)
- {
- wxTextDataObject *data = safenew wxTextDataObject(GetCellValue(crow, ccol));
- wxClipboard::Get()->SetData(data);
-- SetCellValue(crow, ccol, {});
-+ SetCellValue(crow, ccol, "");
- return;
- }
- break;
diff --git a/audio/audacity/pkg-plist b/audio/audacity/pkg-plist
index 5457883d5bd6..f19977850dcd 100644
--- a/audio/audacity/pkg-plist
+++ b/audio/audacity/pkg-plist
@@ -1,9 +1,13 @@
+audacity
bin/audacity
+lib/audacity/lib-string-utils.so
+lib/audacity/lib-strings.so
+lib/audacity/lib-utility.so
+lib/audacity/lib-uuid.so
+lib/audacity/modules/mod-script-pipe.so
man/man1/audacity.1.gz
-share/appdata/audacity.appdata.xml
share/applications/audacity.desktop
%%DATADIR%%/EQDefaultCurves.xml
-%%DATADIR%%/modules/mod-script-pipe.so
%%DATADIR%%/nyquist/aud-do-support.lsp
%%DATADIR%%/nyquist/dspprims.lsp
%%DATADIR%%/nyquist/envelopes.lsp
@@ -141,6 +145,7 @@ share/icons/hicolor/scalable/apps/audacity.svg
%%NLS%%share/locale/vi/LC_MESSAGES/audacity.mo
%%NLS%%share/locale/zh_CN/LC_MESSAGES/audacity.mo
%%NLS%%share/locale/zh_TW/LC_MESSAGES/audacity.mo
+share/metainfo/audacity.appdata.xml
share/mime/packages/audacity.xml
share/pixmaps/audacity.xpm
share/pixmaps/audacity16.xpm