aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2022-04-03 21:14:48 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2022-04-03 21:14:48 +0000
commite9f8f9983c6dbda860a341c361d987fdd940f3c5 (patch)
treedf59036df373d00bacdfbac51a01e16da30a5e7d
parent125faea51f6c625e67562fe1436c35d871468e8c (diff)
downloadports-e9f8f9983c6dbda860a341c361d987fdd940f3c5.tar.gz
ports-e9f8f9983c6dbda860a341c361d987fdd940f3c5.zip
databases/py-alembic16: New port
Alembic is a new database migrations tool, written by the author of SQLAlchemy. A migrations tool offers the following functionality: - Can emit ALTER statements to a database in order to change the structure of tables and other constructs - Provides a system whereby "migration scripts" may be constructed; each script indicates a particular series of steps that can "upgrade" a target database to a new version, and optionally a series of steps that can "downgrade" similarly, doing the same steps in reverse. - Allows the scripts to execute in some sequential manner. WWW: http://alembic.zzzcomputing.com/ PR: 258941 Reported by: einar@isnic.is
-rw-r--r--databases/Makefile1
-rw-r--r--databases/py-alembic16/Makefile33
-rw-r--r--databases/py-alembic16/distinfo3
-rw-r--r--databases/py-alembic16/pkg-descr12
4 files changed, 49 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index 970fa1493ce1..17e77a7f6541 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -738,6 +738,7 @@
SUBDIR += py-aiosqlite
SUBDIR += py-alembic
SUBDIR += py-alembic14
+ SUBDIR += py-alembic16
SUBDIR += py-apsw
SUBDIR += py-asyncmy
SUBDIR += py-asyncpg
diff --git a/databases/py-alembic16/Makefile b/databases/py-alembic16/Makefile
new file mode 100644
index 000000000000..aaad96b22569
--- /dev/null
+++ b/databases/py-alembic16/Makefile
@@ -0,0 +1,33 @@
+PORTNAME= alembic
+PORTVERSION= 1.6.5
+CATEGORIES= databases python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+PKGNAMESUFFIX= 16
+
+MAINTAINER= bofh@FreeBSD.org
+COMMENT= Database migration tool for SQLAlchemy (1.6.x)
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}dateutil>0:devel/py-dateutil@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}importlib-metadata>0:devel/py-importlib-metadata@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}importlib-resources>0:devel/py-importlib-resources@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}mako>=0:textproc/py-mako@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}sqlalchemy13>=1.3.0:databases/py-sqlalchemy13@${PY_FLAVOR}
+
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>0:devel/py-pytest@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}tox>0:devel/py-tox@${PY_FLAVOR}
+
+USES= python:3.6+
+USE_PYTHON= autoplist concurrent distutils
+
+CONFLICTS_INSTALL= py*-alembic14
+
+NO_ARCH= yes
+
+do-test:
+ @cd ${WRKSRC} && ${LOCALBASE}/bin/tox -e ${PY_FLAVOR}
+
+.include <bsd.port.mk>
diff --git a/databases/py-alembic16/distinfo b/databases/py-alembic16/distinfo
new file mode 100644
index 000000000000..2fa3abdf5b0e
--- /dev/null
+++ b/databases/py-alembic16/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1649019902
+SHA256 (alembic-1.6.5.tar.gz) = a21fedebb3fb8f6bbbba51a11114f08c78709377051384c9c5ead5705ee93a51
+SIZE (alembic-1.6.5.tar.gz) = 1174376
diff --git a/databases/py-alembic16/pkg-descr b/databases/py-alembic16/pkg-descr
new file mode 100644
index 000000000000..a921927d7568
--- /dev/null
+++ b/databases/py-alembic16/pkg-descr
@@ -0,0 +1,12 @@
+Alembic is a new database migrations tool, written by the author of
+SQLAlchemy. A migrations tool offers the following functionality:
+
+- Can emit ALTER statements to a database in order to change the structure of
+ tables and other constructs
+- Provides a system whereby "migration scripts" may be constructed; each
+ script indicates a particular series of steps that can "upgrade" a target
+ database to a new version, and optionally a series of steps that can
+ "downgrade" similarly, doing the same steps in reverse.
+- Allows the scripts to execute in some sequential manner.
+
+WWW: http://alembic.zzzcomputing.com/