aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2023-06-12 08:39:36 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2023-06-12 08:39:36 +0000
commitea591b90eaad4a71ea5f47021af566a94c3ccc75 (patch)
tree8c63ace30082aa0ed844c57f69ef1729aa950878
parent34b6a729e1ea3936cbbd7052574fe45aef5c0e80 (diff)
downloadports-ea591b90eaad4a71ea5f47021af566a94c3ccc75.tar.gz
ports-ea591b90eaad4a71ea5f47021af566a94c3ccc75.zip
graphics/catimg: Add new port
catimg is a little program written in C with no dependencies that prints images in terminal. It supports JPEG, PNG and GIF formats. This program was originally a script that did the same by using ImageMagick convert.
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/catimg/Makefile19
-rw-r--r--graphics/catimg/distinfo3
-rw-r--r--graphics/catimg/pkg-descr3
4 files changed, 26 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index d65655c497fc..fee35e57f0b2 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -94,6 +94,7 @@
SUBDIR += cairomm
SUBDIR += cal3d
SUBDIR += camerakit
+ SUBDIR += catimg
SUBDIR += cbonsai
SUBDIR += cbviewer
SUBDIR += cegui
diff --git a/graphics/catimg/Makefile b/graphics/catimg/Makefile
new file mode 100644
index 000000000000..f20af1d1e01c
--- /dev/null
+++ b/graphics/catimg/Makefile
@@ -0,0 +1,19 @@
+PORTNAME= catimg
+PORTVERSION= 2.7.0
+CATEGORIES= graphics
+
+MAINTAINER= ehaupt@FreeBSD.org
+COMMENT= Insanely fast image printing in your terminal
+WWW= https://github.com/posva/catimg/
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= cmake
+USE_GITHUB= yes
+GH_ACCOUNT= posva
+
+PLIST_FILES= bin/catimg \
+ share/man/man1/catimg.1.gz
+
+.include <bsd.port.mk>
diff --git a/graphics/catimg/distinfo b/graphics/catimg/distinfo
new file mode 100644
index 000000000000..ffde6c4d53b2
--- /dev/null
+++ b/graphics/catimg/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1686319032
+SHA256 (posva-catimg-2.7.0_GH0.tar.gz) = 3a6450316ff62fb07c3facb47ea208bf98f62abd02783e88c56f2a6508035139
+SIZE (posva-catimg-2.7.0_GH0.tar.gz) = 90898
diff --git a/graphics/catimg/pkg-descr b/graphics/catimg/pkg-descr
new file mode 100644
index 000000000000..08e01690b681
--- /dev/null
+++ b/graphics/catimg/pkg-descr
@@ -0,0 +1,3 @@
+catimg is a little program written in C with no dependencies that prints
+images in terminal. It supports JPEG, PNG and GIF formats. This program
+was originally a script that did the same by using ImageMagick convert.