aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJun Kuriyama <kuriyama@FreeBSD.org>2003-11-11 03:00:44 +0000
committerJun Kuriyama <kuriyama@FreeBSD.org>2003-11-11 03:00:44 +0000
commitea97079060e9a6c8095577fa8dba741af7d2b3df (patch)
tree67ef7f9ae4714419d82fe007ffff01ac5a8460f8
parent250deab6e84c213e4a3ef911c918c76302412237 (diff)
downloadports-ea97079060e9a6c8095577fa8dba741af7d2b3df.tar.gz
ports-ea97079060e9a6c8095577fa8dba741af7d2b3df.zip
Fix symbol problem caused by recent commit.
Submitted by: marcus
Notes
Notes: svn path=/head/; revision=93713
-rw-r--r--textproc/opensp/Makefile3
-rw-r--r--textproc/opensp/files/patch-aclocal.m446
-rw-r--r--textproc/opensp/files/patch-configure20
3 files changed, 21 insertions, 48 deletions
diff --git a/textproc/opensp/Makefile b/textproc/opensp/Makefile
index 350387027e2e..6e247e22a02f 100644
--- a/textproc/opensp/Makefile
+++ b/textproc/opensp/Makefile
@@ -7,7 +7,7 @@
PORTNAME= OpenSP
PORTVERSION= 1.5
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= textproc
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= openjade
@@ -22,7 +22,6 @@ USE_GMAKE= YES
USE_REINPLACE= YES
USE_LIBTOOL= YES
USE_PERL5= yes
-USE_AUTOCONF_VER=253
CONFIGURE_ARGS= --enable-default-catalog=${PREFIX}/share/sgml/catalog \
--datadir=${PREFIX}/share/sgml/openjade
CONFIGURE_ENV= CFLAGS="${CFLAGS} -I${LOCALBASE}/include" \
diff --git a/textproc/opensp/files/patch-aclocal.m4 b/textproc/opensp/files/patch-aclocal.m4
deleted file mode 100644
index 63e17ff1b43c..000000000000
--- a/textproc/opensp/files/patch-aclocal.m4
+++ /dev/null
@@ -1,46 +0,0 @@
-
-$FreeBSD: /tmp/pcvs/ports/textproc/opensp/files/Attic/patch-aclocal.m4,v 1.1 2003-10-31 04:33:39 kuriyama Exp $
-
---- aclocal.m4.orig Wed Jul 17 20:48:30 2002
-+++ aclocal.m4 Thu Jul 18 16:38:49 2002
-@@ -545,7 +545,7 @@
- rm -f conf.gdk_pixbuftest
- ])
-
--# gettext.m4 serial 13 (gettext-0.11.1)
-+# gettext.m4 serial 14 (gettext-0.11.2)
- dnl Copyright (C) 1995-2002 Free Software Foundation, Inc.
- dnl This file is free software, distributed under the terms of the GNU
- dnl General Public License. As a special exception to the GNU General
-@@ -689,14 +689,13 @@
- dnl Now see whether libintl exists and does not depend on libiconv.
- AC_TRY_LINK([#include <libintl.h>
- extern int _nl_msg_cat_cntr;
--extern int *_nl_domain_bindings;
- extern
- #ifdef __cplusplus
- "C"
- #endif
- const char *_nl_expand_alias ();],
- [bindtextdomain ("", "");
--return (int) gettext ("")]ifelse([$2], [need-ngettext], [ + (int) ngettext ("", "", 0)], [])[ + _nl_msg_cat_cntr + *_nl_domain_bindings + *_nl_expand_alias (0)],
-+return (int) gettext ("")]ifelse([$2], [need-ngettext], [ + (int) ngettext ("", "", 0)], [])[ + _nl_msg_cat_cntr + *_nl_expand_alias (0)],
- gt_cv_func_gnugettext_libintl=yes,
- gt_cv_func_gnugettext_libintl=no)
- dnl Now see whether libintl exists and depends on libiconv.
-@@ -704,14 +703,13 @@
- LIBS="$LIBS $LIBICONV"
- AC_TRY_LINK([#include <libintl.h>
- extern int _nl_msg_cat_cntr;
--extern int *_nl_domain_bindings;
- extern
- #ifdef __cplusplus
- "C"
- #endif
- const char *_nl_expand_alias ();],
- [bindtextdomain ("", "");
--return (int) gettext ("")]ifelse([$2], [need-ngettext], [ + (int) ngettext ("", "", 0)], [])[ + _nl_msg_cat_cntr + *_nl_domain_bindings + *_nl_expand_alias (0)],
-+return (int) gettext ("")]ifelse([$2], [need-ngettext], [ + (int) ngettext ("", "", 0)], [])[ + _nl_msg_cat_cntr + *_nl_expand_alias (0)],
- [LIBINTL="$LIBINTL $LIBICONV"
- LTLIBINTL="$LTLIBINTL $LTLIBICONV"
- gt_cv_func_gnugettext_libintl=yes
diff --git a/textproc/opensp/files/patch-configure b/textproc/opensp/files/patch-configure
new file mode 100644
index 000000000000..3ad7406109a7
--- /dev/null
+++ b/textproc/opensp/files/patch-configure
@@ -0,0 +1,20 @@
+--- configure.orig Mon Nov 10 13:18:00 2003
++++ configure Mon Nov 10 13:18:54 2003
+@@ -10832,7 +10832,7 @@
+ #include "confdefs.h"
+ #include <libintl.h>
+ extern int _nl_msg_cat_cntr;
+-extern int *_nl_domain_bindings;
++extern int *libintl_nl_domain_bindings;
+ #ifdef F77_DUMMY_MAIN
+ # ifdef __cplusplus
+ extern "C"
+@@ -10843,7 +10843,7 @@
+ main ()
+ {
+ bindtextdomain ("", "");
+-return (int) gettext ("") + _nl_msg_cat_cntr + *_nl_domain_bindings
++return (int) gettext ("") + _nl_msg_cat_cntr + *libintl_nl_domain_bindings
+ ;
+ return 0;
+ }