aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Engberg <diizzy@FreeBSD.org>2023-10-23 18:08:48 +0000
committerDaniel Engberg <diizzy@FreeBSD.org>2023-10-23 18:22:57 +0000
commiteadcbcb177f3bcd18a34a637af8efd6ed0ef15d7 (patch)
tree6061a90f6cbec060e9564e5a5d13c214533c5b9b
parenta00a9c80645455e486cf6146437336422ba45018 (diff)
downloadports-eadcbcb177f3bcd18a34a637af8efd6ed0ef15d7.tar.gz
ports-eadcbcb177f3bcd18a34a637af8efd6ed0ef15d7.zip
print/pdfcpu: New port: PDF processor written in Go
PDF processing library providing both an API and a CLI with focus on strong support for batch processing and scripting via a rich command-line. Common functions such as extract assets, merge, split, rotate, trim, validate, watermark PDF files are supported and many more. Website: https://github.com/pdfcpu/pdfcpu
-rw-r--r--print/Makefile1
-rw-r--r--print/pdfcpu/Makefile21
-rw-r--r--print/pdfcpu/distinfo5
-rw-r--r--print/pdfcpu/pkg-descr4
4 files changed, 31 insertions, 0 deletions
diff --git a/print/Makefile b/print/Makefile
index e70dbf79c4f1..9a580b29435c 100644
--- a/print/Makefile
+++ b/print/Makefile
@@ -139,6 +139,7 @@
SUBDIR += pdfarranger
SUBDIR += pdfbox
SUBDIR += pdfchain
+ SUBDIR += pdfcpu
SUBDIR += pdflib
SUBDIR += pdflib-perl
SUBDIR += pdfmixtool
diff --git a/print/pdfcpu/Makefile b/print/pdfcpu/Makefile
new file mode 100644
index 000000000000..5579727d586d
--- /dev/null
+++ b/print/pdfcpu/Makefile
@@ -0,0 +1,21 @@
+PORTNAME= pdfcpu
+DISTVERSIONPREFIX= v
+DISTVERSION= 0.5.0
+CATEGORIES= print
+
+MAINTAINER= diizzy@FreeBSD.org
+COMMENT= PDF processor written in Go
+WWW= https://github.com/pdfcpu/pdfcpu
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+USES= go:modules
+
+GO_MODULE= github.com/${PORTNAME}/${PORTNAME}
+
+PLIST_FILES= bin/pdfcpu
+
+GO_TARGET= ./cmd/${PORTNAME}
+
+.include <bsd.port.mk>
diff --git a/print/pdfcpu/distinfo b/print/pdfcpu/distinfo
new file mode 100644
index 000000000000..be8cb734f36a
--- /dev/null
+++ b/print/pdfcpu/distinfo
@@ -0,0 +1,5 @@
+TIMESTAMP = 1698012245
+SHA256 (go/print_pdfcpu/pdfcpu-v0.5.0/v0.5.0.mod) = bd1f3e5cedaca62187d34f73aa7f2f9e0cbbcb68aebf0ede87dcd48c559d6857
+SIZE (go/print_pdfcpu/pdfcpu-v0.5.0/v0.5.0.mod) = 319
+SHA256 (go/print_pdfcpu/pdfcpu-v0.5.0/v0.5.0.zip) = dbda196a444c313ae06181c417ebbb73f52a4d29bdcbdc6dbba582e0e0988876
+SIZE (go/print_pdfcpu/pdfcpu-v0.5.0/v0.5.0.zip) = 293287851
diff --git a/print/pdfcpu/pkg-descr b/print/pdfcpu/pkg-descr
new file mode 100644
index 000000000000..70694947e1a3
--- /dev/null
+++ b/print/pdfcpu/pkg-descr
@@ -0,0 +1,4 @@
+PDF processing library providing both an API and a CLI with focus on strong
+support for batch processing and scripting via a rich command-line. Common
+functions such as extract assets, merge, split, rotate, trim, validate,
+watermark PDF files are supported and many more.