aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Clausecker <fuz@fuz.su>2022-11-07 04:18:52 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2022-11-07 04:18:52 +0000
commiteb0fbcfdfa6ec1203d95bc81ddeb1151698e79e8 (patch)
tree6844203dc0efed99766db2024f6500aed32248dd
parent8e57739426c9e1381b8aef151fa67fa3e9d5b37d (diff)
downloadports-eb0fbcfdfa6ec1203d95bc81ddeb1151698e79e8.tar.gz
ports-eb0fbcfdfa6ec1203d95bc81ddeb1151698e79e8.zip
sysutils/wmflame: fix the port's build against -fno-common
Ensure that there is only one variable definition per each object, as the C (and C++) standards mandated for years and compilers started to enforce as of recently (Clang 11, GCC 10). While we are at it, at missing `xext' component to the USE_XORG list. PR: 267600
-rw-r--r--sysutils/wmflame/Makefile5
-rw-r--r--sysutils/wmflame/files/patch-wmgeneral_wmgeneral.c12
-rw-r--r--sysutils/wmflame/files/patch-wmgeneral_wmgeneral.h15
3 files changed, 28 insertions, 4 deletions
diff --git a/sysutils/wmflame/Makefile b/sysutils/wmflame/Makefile
index 5c0e2c8b39b0..da6b44c53692 100644
--- a/sysutils/wmflame/Makefile
+++ b/sysutils/wmflame/Makefile
@@ -11,11 +11,8 @@ WWW= http://web.novalis.org/
LICENSE= GPLv2
-BROKEN_FreeBSD_13= ld: error: duplicate symbol: Root
-BROKEN_FreeBSD_14= ld: error: duplicate symbol: Root
-
USES= gmake xorg
-USE_XORG= x11 xpm
+USE_XORG= x11 xext xpm
PLIST_FILES= bin/wmflame
diff --git a/sysutils/wmflame/files/patch-wmgeneral_wmgeneral.c b/sysutils/wmflame/files/patch-wmgeneral_wmgeneral.c
new file mode 100644
index 000000000000..e3fafba3a215
--- /dev/null
+++ b/sysutils/wmflame/files/patch-wmgeneral_wmgeneral.c
@@ -0,0 +1,12 @@
+--- ../wmgeneral/wmgeneral.c.orig 1999-07-12 03:30:14 UTC
++++ ../wmgeneral/wmgeneral.c
+@@ -57,6 +57,9 @@
+ /* X11 Variables */
+ /*****************/
+
++Display *display;
++Window Root, iconwin, win;
++XpmIcon wmgen;
+ int screen;
+ int x_fd;
+ int d_depth;
diff --git a/sysutils/wmflame/files/patch-wmgeneral_wmgeneral.h b/sysutils/wmflame/files/patch-wmgeneral_wmgeneral.h
new file mode 100644
index 000000000000..87c392721b23
--- /dev/null
+++ b/sysutils/wmflame/files/patch-wmgeneral_wmgeneral.h
@@ -0,0 +1,15 @@
+--- ../wmgeneral/wmgeneral.h.orig 1999-06-17 06:48:13 UTC
++++ ../wmgeneral/wmgeneral.h
+@@ -36,9 +36,9 @@ typedef struct {
+ /* Global variable */
+ /*******************/
+
+-Display *display;
+-Window Root, iconwin, win;
+-XpmIcon wmgen;
++extern Display *display;
++extern Window Root, iconwin, win;
++extern XpmIcon wmgen;
+
+ /***********************/
+ /* Function Prototypes */